Bug 307227 - Kate and KWrite crashing constantly after changing endline character settings
Summary: Kate and KWrite crashing constantly after changing endline character settings
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-22 19:52 UTC by Dániel Simon
Modified: 2012-09-22 20:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dániel Simon 2012-09-22 19:52:13 UTC
Application: kwrite (4.9.1 "release 561")
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.4.6-2.10-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I have changed the settings of endline character: Unix style to DOS/Windows style.
After the first closing of the application I can't start it again, it crashes.
- Custom settings of the application:
Endline character: DOS/Windows style

The crash can be reproduced every time.

-- Backtrace:
Application: KWrite (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f76b67e0780 (LWP 18520))]

Thread 2 (Thread 0x7f769d6fd700 (LWP 18523)):
#0  0x00007f76b50b08f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f76a9f85ef7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f76aa293640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f76a9f85f29 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f76b50ace0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f76b3e272bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f76b67e0780 (LWP 18520)):
[KCrash Handler]
#5  0x00007f76b3dcdce1 in __memcpy_sse2 () from /lib64/libc.so.6
#6  0x00007f76a9ec910b in memcpy (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/bits/string3.h:52
#7  executableCopy (allocator=0x7f769ce04960, this=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h:139
#8  executableCopy (allocator=0x7f769ce04960, this=0x7fffe18a0bc0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#9  executableCopy (allocator=0x7f769ce04960, this=0x7fffe18a0bc0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#10 LinkBuffer (executablePool=..., masm=0x7fffe18a0bc0, this=0x7fffe18a0b30) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
#11 QTJSC::JIT::privateCompileCTIMachineTrampolines (this=0x7fffe18a0bc0, executablePool=0x7f769cdfe9e8, globalData=<optimized out>, ctiStringLengthTrampoline=0x7f769cdfe9f0, ctiVirtualCallLink=0x7f769cdfe9f8, ctiVirtualCall=0x7f769cdfea00, ctiNativeCallThunk=0x7f769cdfea08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITOpcodes.cpp:1817
#12 0x00007f76a9ede83c in QTJSC::JIT::compileCTIMachineTrampolines (globalData=0x7f769cdfd800, executablePool=executablePool@entry=0x7f769cdfe9e8, ctiStringLengthTrampoline=ctiStringLengthTrampoline@entry=0x7f769cdfe9f0, ctiVirtualCallLink=ctiVirtualCallLink@entry=0x7f769cdfe9f8, ctiVirtualCall=ctiVirtualCall@entry=0x7f769cdfea00, ctiNativeCallThunk=ctiNativeCallThunk@entry=0x7f769cdfea08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JIT.h:323
#13 0x00007f76a9edacf3 in QTJSC::JITThunks::JITThunks (this=0x7f769cdfe9e8, globalData=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:768
#14 0x00007f76a9f27788 in QTJSC::JSGlobalData::JSGlobalData (this=0x7f769cdfd800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#15 0x00007f76a9f27e3c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#16 0x00007f76a9fc6150 in QScriptEnginePrivate::QScriptEnginePrivate (this=0x1260b90) at api/qscriptengine.cpp:979
#17 0x00007f76a9fc7156 in QScriptEngine::QScriptEngine (this=0x126a610) at api/qscriptengine.cpp:1964
#18 0x00007f769df9158a in load (this=0x104c100) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:247
#19 KateScript::load (this=0x104c100) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:230
#20 0x00007f769df918f9 in KateScript::clearExceptions (this=0x104c100) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:157
#21 0x00007f769df92c1c in KateCommandLineScript::actionInfo (this=0x104c100, cmd=...) at /usr/src/debug/kate-4.9.1/part/script/katecommandlinescript.cpp:78
#22 0x00007f769df98ba1 in KateScriptActionMenu::repopulate (this=this@entry=0x12a7a70) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:118
#23 0x00007f769df9927c in KateScriptActionMenu::KateScriptActionMenu (this=0x12a7a70, view=0x11fde40, text=...) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:74
#24 0x00007f769dff769a in KateView::setupActions (this=this@entry=0x11fde40) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:350
#25 0x00007f769dffb5f5 in KateView::KateView (this=0x11fde40, doc=0x11f5dc0, parent=<optimized out>) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:240
#26 0x00007f769df67114 in KateDocument::createView (this=0x11f5dc0, parent=0x10f4be0) at /usr/src/debug/kate-4.9.1/part/document/katedocument.cpp:335
#27 0x00007f76a39a0b31 in KWrite::KWrite (this=0x10f4be0, doc=0x11f5dc0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kate-4.9.1/kwrite/kwritemain.cpp:77
#28 0x00007f76a39a2950 in KWriteApp::init (this=this@entry=0x7fffe18a1a10) at /usr/src/debug/kate-4.9.1/kwrite/kwriteapp.cpp:129
#29 0x00007f76a39a313d in KWriteApp::KWriteApp (this=0x7fffe18a1a10, m_args=<optimized out>) at /usr/src/debug/kate-4.9.1/kwrite/kwriteapp.cpp:51
#30 0x00007f76a399fe5d in kdemain (argc=2, argv=0xed7710) at /usr/src/debug/kate-4.9.1/kwrite/kwritemain.cpp:678
#31 0x0000000000408932 in _start ()

This bug may be a duplicate of or related to bug 305718.

Possible duplicates by query: bug 307166.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-22 20:08:57 UTC

*** This bug has been marked as a duplicate of bug 305718 ***