Bug 307640 - Kate-kwrite y kde editores chashean
Summary: Kate-kwrite y kde editores chashean
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-30 21:34 UTC by raziel_soulreaver2_kain
Modified: 2012-09-30 22:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raziel_soulreaver2_kain 2012-09-30 21:34:18 UTC
Application: kate (3.9.1)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.4.6-2.10-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
Todos los editores de kde crashean al iniciar despues de usar por un tiempo el 
qtcreator y de compilar,   e incluso el cursor aveces se queda pasmado y solo permite el mivimiento  de paginas hacia arriba y abajo

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6d0b33e780 (LWP 5018))]

Thread 2 (Thread 0x7f6cf2048700 (LWP 5019)):
#0  0x00007f6d09c1f8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6cfeaf1ef7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f6cfedff640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f6cfeaf1f29 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f6d09c1be0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6d089952bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f6d0b33e780 (LWP 5018)):
[KCrash Handler]
#5  0x00007f6d089d96c7 in __memcpy_ssse3 () from /lib64/libc.so.6
#6  0x00007f6cfea3510b in memcpy (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/bits/string3.h:52
#7  executableCopy (allocator=0x7f6cf174f960, this=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h:139
#8  executableCopy (allocator=0x7f6cf174f960, this=0x7fffbdc11260) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#9  executableCopy (allocator=0x7f6cf174f960, this=0x7fffbdc11260) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#10 LinkBuffer (executablePool=..., masm=0x7fffbdc11260, this=0x7fffbdc111d0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
#11 QTJSC::JIT::privateCompileCTIMachineTrampolines (this=0x7fffbdc11260, executablePool=0x7f6cf17499e8, globalData=<optimized out>, ctiStringLengthTrampoline=0x7f6cf17499f0, ctiVirtualCallLink=0x7f6cf17499f8, ctiVirtualCall=0x7f6cf1749a00, ctiNativeCallThunk=0x7f6cf1749a08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITOpcodes.cpp:1817
#12 0x00007f6cfea4a83c in QTJSC::JIT::compileCTIMachineTrampolines (globalData=0x7f6cf1748800, executablePool=executablePool@entry=0x7f6cf17499e8, ctiStringLengthTrampoline=ctiStringLengthTrampoline@entry=0x7f6cf17499f0, ctiVirtualCallLink=ctiVirtualCallLink@entry=0x7f6cf17499f8, ctiVirtualCall=ctiVirtualCall@entry=0x7f6cf1749a00, ctiNativeCallThunk=ctiNativeCallThunk@entry=0x7f6cf1749a08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JIT.h:323
#13 0x00007f6cfea46cf3 in QTJSC::JITThunks::JITThunks (this=0x7f6cf17499e8, globalData=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:768
#14 0x00007f6cfea93788 in QTJSC::JSGlobalData::JSGlobalData (this=0x7f6cf1748800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#15 0x00007f6cfea93e3c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#16 0x00007f6cfeb32150 in QScriptEnginePrivate::QScriptEnginePrivate (this=0xc55a40) at api/qscriptengine.cpp:979
#17 0x00007f6cfeb33156 in QScriptEngine::QScriptEngine (this=0xc55a20) at api/qscriptengine.cpp:1964
#18 0x00007f6cf2b9658a in load (this=0xa53980) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:247
#19 KateScript::load (this=0xa53980) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:230
#20 0x00007f6cf2b968f9 in KateScript::clearExceptions (this=0xa53980) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:157
#21 0x00007f6cf2b97c1c in KateCommandLineScript::actionInfo (this=0xa53980, cmd=...) at /usr/src/debug/kate-4.9.1/part/script/katecommandlinescript.cpp:78
#22 0x00007f6cf2b9dba1 in KateScriptActionMenu::repopulate (this=this@entry=0xc55230) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:118
#23 0x00007f6cf2b9e27c in KateScriptActionMenu::KateScriptActionMenu (this=0xc55230, view=0xb28030, text=...) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:74
#24 0x00007f6cf2bfc69a in KateView::setupActions (this=this@entry=0xb28030) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:350
#25 0x00007f6cf2c005f5 in KateView::KateView (this=0xb28030, doc=0xa6f5a0, parent=<optimized out>) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:240
#26 0x00007f6cf2b6c114 in KateDocument::createView (this=0xa6f5a0, parent=0xaab2d0) at /usr/src/debug/kate-4.9.1/part/document/katedocument.cpp:335
#27 0x00007f6cf8c76dea in createView (doc=<optimized out>, this=0xaa07e0) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:391
#28 KateViewManager::createView (this=0xaa07e0, doc=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:382
#29 0x00007f6cf8c7b4ea in KateViewSpace::restoreConfig (this=0xbb7830, viewMan=0xaa07e0, config=0x846b50, groupname=...) at /usr/src/debug/kate-4.9.1/kate/app/kateviewspace.cpp:266
#30 0x00007f6cf8c7938c in KateViewManager::restoreSplitter (this=this@entry=0xaa07e0, configBase=0x846b50, group=..., parent=parent@entry=0xaa07e0, viewConfGrp=...) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:939
#31 0x00007f6cf8c79c1d in KateViewManager::restoreViewConfiguration (this=0xaa07e0, config=...) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:820
#32 0x00007f6cf8c6e74e in KateMainWindow::KateMainWindow (this=0xa90160, sconfig=0x846b50, sgroup=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/katemainwindow.cpp:195
#33 0x00007f6cf8c5ffa4 in KateApp::newMainWindow (this=<optimized out>, sconfig_=<optimized out>, sgroup_=...) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:390
#34 0x00007f6cf8c83ed3 in KateSessionManager::activateSession (this=0xa7a190, session=..., closeLast=<optimized out>, saveLast=<optimized out>, loadNew=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/katesession.cpp:338
#35 0x00007f6cf8c61458 in KateApp::startupKate (this=0x7fffbdc12d10) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:194
#36 0x00007f6cf8c61c85 in KateApp::initKate (this=this@entry=0x7fffbdc12d10) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:135
#37 0x00007f6cf8c61ea2 in KateApp::KateApp (this=0x7fffbdc12d10, args=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:72
#38 0x00007f6cf8eb5928 in kdemain (argc=<optimized out>, argv=0x767b00) at /usr/src/debug/kate-4.9.1/kate/app/katemain.cpp:373
#39 0x0000000000408932 in _start ()

Possible duplicates by query: bug 307461, bug 307227, bug 307166, bug 305718.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-30 22:06:11 UTC

*** This bug has been marked as a duplicate of bug 305718 ***