Bug 305718 - Several applications crash in QtScript initialization [@__memcpy_sse2, QTJSC::JIT::privateCompileCTIMachineTrampolines]
Summary: Several applications crash in QtScript initialization [@__memcpy_sse2, QTJSC:...
Status: RESOLVED UPSTREAM
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: qt (show other bugs)
Version: 4.9.1
Platform: Fedora RPMs Linux
: NOR crash with 41 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 305806 305830 305913 305923 306009 306016 306018 306149 307149 307166 307179 307227 307431 307461 307478 307562 307640 324528 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-24 13:51 UTC by Jaroslav Reznik
Modified: 2013-09-05 08:31 UTC (History)
28 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (13.21 KB, text/plain)
2012-09-05 13:04 UTC, Carlos Cámara
Details
New crash information added by DrKonqi (13.23 KB, text/plain)
2012-09-11 19:43 UTC, Märt Rang
Details
New crash information added by DrKonqi (10.00 KB, text/plain)
2012-09-23 20:25 UTC, squan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Reznik 2012-08-24 13:51:31 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.6.0-0.rc1.git6.1.fc18.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

* run System Settings
* click Workspace Appearance

Current behaviour: crash

Fedora 18 Alpha TC3

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f67a06da880 (LWP 963))]

Thread 2 (Thread 0x7f677adbb700 (LWP 964)):
#0  0x00007f679cdcb5e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f679a0ad767 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /lib64/libQtScript.so.4
#2  0x00007f679a0ad799 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib64/libQtScript.so.4
#3  0x00007f679cdc7d15 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f679c2e018d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f67a06da880 (LWP 963)):
[KCrash Handler]
#5  0x00007f679c27c6d1 in __memcpy_sse2 () from /lib64/libc.so.6
#6  0x00007f6799ff050b in QTJSC::JIT::privateCompileCTIMachineTrampolines(QTWTF::RefPtr<QTJSC::ExecutablePool>*, QTJSC::JSGlobalData*, QTJSC::MacroAssemblerCodePtr*, QTJSC::MacroAssemblerCodePtr*, QTJSC::MacroAssemblerCodePtr*, QTJSC::MacroAssemblerCodePtr*) () from /lib64/libQtScript.so.4
#7  0x00007f679a005d6f in QTJSC::JIT::compileCTIMachineTrampolines(QTJSC::JSGlobalData*, QTWTF::RefPtr<QTJSC::ExecutablePool>*, QTJSC::MacroAssemblerCodePtr*, QTJSC::MacroAssemblerCodePtr*, QTJSC::MacroAssemblerCodePtr*, QTJSC::MacroAssemblerCodePtr*) () from /lib64/libQtScript.so.4
#8  0x00007f679a0020f3 in QTJSC::JITThunks::JITThunks(QTJSC::JSGlobalData*) () from /lib64/libQtScript.so.4
#9  0x00007f679a04ee98 in QTJSC::JSGlobalData::JSGlobalData(bool) () from /lib64/libQtScript.so.4
#10 0x00007f679a04f54c in QTJSC::JSGlobalData::create() () from /lib64/libQtScript.so.4
#11 0x00007f679a0efcf0 in QScriptEnginePrivate::QScriptEnginePrivate() () from /lib64/libQtScript.so.4
#12 0x00007f679a0f0ce6 in QScriptEngine::QScriptEngine() () from /lib64/libQtScript.so.4
#13 0x00007f67998f753c in QDeclarativeScriptEngine::QDeclarativeScriptEngine(QDeclarativeEnginePrivate*) () from /lib64/libQtDeclarative.so.4
#14 0x00007f67998fc3ef in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate(QDeclarativeEngine*) () from /lib64/libQtDeclarative.so.4
#15 0x00007f67998fc6d1 in QDeclarativeEngine::QDeclarativeEngine(QObject*) () from /lib64/libQtDeclarative.so.4
#16 0x00007f67997fb8b6 in QDeclarativeViewPrivate::init() () from /lib64/libQtDeclarative.so.4
#17 0x00007f67997fbae3 in QDeclarativeView::QDeclarativeView(QWidget*) () from /lib64/libQtDeclarative.so.4
#18 0x00007f677b007c99 in Ui_KWinDecorationForm::setupUi(QWidget*) () from /usr/lib64/kde4/kcm_kwindecoration.so
#19 0x00007f677b004318 in KWin::KWinDecorationForm::KWinDecorationForm(QWidget*) () from /usr/lib64/kde4/kcm_kwindecoration.so
#20 0x00007f677b006c8e in KWin::KWinDecorationModule::KWinDecorationModule(QWidget*, QList<QVariant> const&) () from /usr/lib64/kde4/kcm_kwindecoration.so
#21 0x00007f677b008654 in QObject* KPluginFactory::createInstance<KWin::KWinDecorationModule, QWidget>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib64/kde4/kcm_kwindecoration.so
#22 0x00007f679d936e65 in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /lib64/libkdecore.so.5
#23 0x00007f679f9048ca in KCModuleLoader::loadModule(KCModuleInfo const&, KCModuleLoader::ErrorReporting, QWidget*, QStringList const&) () from /lib64/libkcmutils.so.4
#24 0x00007f679f9098b0 in KCModuleProxyPrivate::loadModule() () from /lib64/libkcmutils.so.4
#25 0x00007f679f90a005 in KCModuleProxy::realModule() const () from /lib64/libkcmutils.so.4
#26 0x00007f679f90a042 in KCModuleProxy::showEvent(QShowEvent*) () from /lib64/libkcmutils.so.4
#27 0x00007f679de0fe4e in QWidget::event(QEvent*) () from /lib64/libQtGui.so.4
#28 0x00007f679ddc03cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#29 0x00007f679ddc484a in QApplication::notify(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#30 0x00007f679ed35356 in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#31 0x00007f679d15240e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#32 0x00007f679de11e57 in QWidgetPrivate::show_helper() () from /lib64/libQtGui.so.4
#33 0x00007f679de11cca in QWidgetPrivate::showChildren(bool) () from /lib64/libQtGui.so.4
#34 0x00007f679de11d5d in QWidgetPrivate::show_helper() () from /lib64/libQtGui.so.4
#35 0x00007f679de12142 in QWidget::setVisible(bool) () from /lib64/libQtGui.so.4
#36 0x00007f679de11cde in QWidgetPrivate::showChildren(bool) () from /lib64/libQtGui.so.4
#37 0x00007f679de11d5d in QWidgetPrivate::show_helper() () from /lib64/libQtGui.so.4
#38 0x00007f679de12142 in QWidget::setVisible(bool) () from /lib64/libQtGui.so.4
#39 0x00007f679ddf3ada in QStackedLayout::setCurrentIndex(int) () from /lib64/libQtGui.so.4
#40 0x00007f679ed63b6f in KPageViewPrivate::_k_pageSelected(QItemSelection const&, QItemSelection const&) () from /lib64/libkdeui.so.5
#41 0x00007f679d168bbf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
#42 0x00007f679e319877 in QItemSelectionModel::selectionChanged(QItemSelection const&, QItemSelection const&) () from /lib64/libQtGui.so.4
#43 0x00007f679e31b553 in QItemSelectionModel::emitSelectionChanged(QItemSelection const&, QItemSelection const&) () from /lib64/libQtGui.so.4
#44 0x00007f679e31f6cc in QItemSelectionModel::select(QItemSelection const&, QFlags<QItemSelectionModel::SelectionFlag>) () from /lib64/libQtGui.so.4
#45 0x00007f679e31b38b in QItemSelectionModel::select(QModelIndex const&, QFlags<QItemSelectionModel::SelectionFlag>) () from /lib64/libQtGui.so.4
#46 0x00007f679e319ac1 in QItemSelectionModel::setCurrentIndex(QModelIndex const&, QFlags<QItemSelectionModel::SelectionFlag>) () from /lib64/libQtGui.so.4
#47 0x00007f679ed629cf in KPageViewPrivate::_k_rebuildGui() () from /lib64/libkdeui.so.5
#48 0x00007f679ed638d5 in KPageViewPrivate::_k_modelChanged() () from /lib64/libkdeui.so.5
#49 0x00007f679d168bbf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
#50 0x00007f679ed68091 in KPageWidgetModel::addPage(KPageWidgetItem*) () from /lib64/libkdeui.so.5
#51 0x00007f679f6e1530 in ModuleView::addModule(KCModuleInfo*) () from /lib64/libsystemsettingsview.so.2
#52 0x00007f679f6e1cc7 in ModuleView::loadModule(QModelIndex) () from /lib64/libsystemsettingsview.so.2
#53 0x00007f677b2d4778 in IconMode::changeModule(QModelIndex const&) () from /usr/lib64/kde4/icon_mode.so
#54 0x00007f679d168bbf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
#55 0x00007f679e2c4845 in QAbstractItemView::activated(QModelIndex const&) () from /lib64/libQtGui.so.4
#56 0x00007f679e2c63ec in QAbstractItemView::mouseReleaseEvent(QMouseEvent*) () from /lib64/libQtGui.so.4
#57 0x00007f679e2e408e in QListView::mouseReleaseEvent(QMouseEvent*) () from /lib64/libQtGui.so.4
#58 0x00007f679ed0c43b in KCategorizedView::mouseReleaseEvent(QMouseEvent*) () from /lib64/libkdeui.so.5
#59 0x00007f679de0fad0 in QWidget::event(QEvent*) () from /lib64/libQtGui.so.4
#60 0x00007f679e1b9876 in QFrame::event(QEvent*) () from /lib64/libQtGui.so.4
#61 0x00007f679e2c6e43 in QAbstractItemView::viewportEvent(QEvent*) () from /lib64/libQtGui.so.4
#62 0x00007f679d152576 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#63 0x00007f679ddc039c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#64 0x00007f679ddc50ab in QApplication::notify(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#65 0x00007f679ed35356 in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#66 0x00007f679d15240e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#67 0x00007f679ddc120b in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /lib64/libQtGui.so.4
#68 0x00007f679de3b744 in QETWidget::translateMouseEvent(_XEvent const*) () from /lib64/libQtGui.so.4
#69 0x00007f679de3a4d1 in QApplication::x11ProcessEvent(_XEvent*) () from /lib64/libQtGui.so.4
#70 0x00007f679de604ec in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQtGui.so.4
#71 0x00007f67939a3c55 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#72 0x00007f67939a3f88 in g_main_context_iterate.isra.23 () from /lib64/libglib-2.0.so.0
#73 0x00007f67939a4044 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#74 0x00007f679d180506 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#75 0x00007f679de601ce in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
#76 0x00007f679d15115f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#77 0x00007f679d1513e8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#78 0x00007f679d1561d8 in QCoreApplication::exec() () from /lib64/libQtCore.so.4
#79 0x000000000040aa3e in main ()

Reported using DrKonqi
Comment 1 Martin Flöser 2012-08-24 15:19:48 UTC
debugging symbols for KWin are missing. Please attach a new backtrace with debugging symbols (three starts in the DrKonqui dialog)
Comment 2 Christoph Feck 2012-08-24 15:42:59 UTC
Since it crashes in memcpy, this is either an upstream (QtScript) bug, or the memory got corrupted earlier, in which case we would need a valgrind log.
Comment 3 Thomas Lübking 2012-08-26 11:06:47 UTC
also see bug #299575
Comment 4 Thomas Lübking 2012-08-26 18:04:53 UTC
*** Bug 305830 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Lübking 2012-08-26 18:08:01 UTC
from dupe:
-----------------

Application: systemsettings (1.0)
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.5.0-11-generic x86_64
Distribution: Ubuntu quantal (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I was trying to change some appearance of my workspace but systemsettings crashed

The crash can be reproduced every time.

-- Backtrace:
Application: Ustawienia systemowe (systemsettings), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3a9877e780 (LWP 2208))]

Thread 2 (Thread 0x7f3a7bb27700 (LWP 2225)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3a9384f967 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f3a9384f999 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f3a8f662e9a in start_thread (arg=0x7f3a7bb27700) at pthread_create.c:308
#4  0x00007f3a9579439d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3a9877e780 (LWP 2208)):
[KCrash Handler]
#6  __memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:202
#7  0x00007f3a9379249b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#8  0x00007f3a937a7d5f in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#9  0x00007f3a937a4103 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#10 0x00007f3a937f0f08 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#11 0x00007f3a937f15bc in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#12 0x00007f3a93891db0 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#13 0x00007f3a93892da6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f3a92b19d0c in QDeclarativeScriptEngine::QDeclarativeScriptEngine (this=0x1a13908, priv=0x1a13800) at qml/qdeclarativeengine.cpp:382
#15 0x00007f3a92b1ebaf in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate (this=0x1a13800, e=0x1a113c0) at qml/qdeclarativeengine.cpp:353
#16 0x00007f3a92b1eec1 in QDeclarativeEngine::QDeclarativeEngine (this=0x1a113c0, parent=0x0) at qml/qdeclarativeengine.cpp:634
#17 0x00007f3a92a1d766 in QDeclarativeViewPrivate::init (this=this@entry=0x19fae30) at util/qdeclarativeview.cpp:281
#18 0x00007f3a92a1d993 in QDeclarativeView::QDeclarativeView (this=0x19fae00, parent=0x1abcbf0) at util/qdeclarativeview.cpp:261
#19 0x00007f3a7bd74c09 in Ui_KWinDecorationForm::setupUi (this=this@entry=0x1abcc18, KWinDecorationForm=KWinDecorationForm@entry=0x1abcbf0) at ./ui_decoration.h:56
#20 0x00007f3a7bd71288 in KWin::KWinDecorationForm::KWinDecorationForm (this=0x1abcbf0, parent=<optimized out>) at ../../../../kwin/kcmkwin/kwindecoration/kwindecoration.cpp:68
#21 0x00007f3a7bd73bfe in KWin::KWinDecorationModule::KWinDecorationModule (this=0x19ddba0, parent=<optimized out>) at ../../../../kwin/kcmkwin/kwindecoration/kwindecoration.cpp:82
#22 0x00007f3a7bd755c4 in KPluginFactory::createInstance<KWin::KWinDecorationModule, QWidget> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/KDE/../kpluginfactory.h:477
#23 0x00007f3a966ad1c5 in KPluginFactory::create (this=0x1a984d0, iface=0x7f3a979a8c40 <qt_meta_stringdata_KCModule> "KCModule", parentWidget=0x0, parent=0x16a8840, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203
#24 0x00007f3a97e8988a in create<KCModule> (args=..., keyword=..., parent=0x16a8840, parentWidget=0x0, this=<optimized out>) at ../../kdecore/util/kpluginfactory.h:531
#25 createInstance<KCModule> (error=0x7fff6896da60, args=..., parent=0x16a8840, parentWidget=0x0, this=0x15f5ff0) at ../../kdecore/services/kservice.h:559
#26 createInstance<KCModule> (error=0x7fff6896da60, args=..., parent=0x16a8840, this=0x15f5ff0) at ../../kdecore/services/kservice.h:536
#27 KCModuleLoader::loadModule (mod=..., report=KCModuleLoader::Inline, parent=0x16a8840, args=...) at ../../kutils/kcmoduleloader.cpp:89
#28 0x00007f3a97e8e870 in KCModuleProxyPrivate::loadModule (this=this@entry=0x1abafd0) at ../../kutils/kcmoduleproxy.cpp:106
#29 0x00007f3a97e8efc5 in KCModuleProxy::realModule (this=this@entry=0x16a8840) at ../../kutils/kcmoduleproxy.cpp:83
#30 0x00007f3a97e8f002 in KCModuleProxy::showEvent (this=0x16a8840, ev=0x7fff6896e520) at ../../kutils/kcmoduleproxy.cpp:197
#31 0x00007f3a96b829ae in QWidget::event (this=0x16a8840, event=0x7fff6896e520) at kernel/qwidget.cpp:8578
#32 0x00007f3a96b32d9c in QApplicationPrivate::notify_helper (this=this@entry=0x1249120, receiver=receiver@entry=0x16a8840, e=e@entry=0x7fff6896e520) at kernel/qapplication.cpp:4556
#33 0x00007f3a96b3720a in QApplication::notify (this=0x7fff68970ad0, receiver=0x16a8840, e=0x7fff6896e520) at kernel/qapplication.cpp:4417
#34 0x00007f3a9783aaf6 in KApplication::notify (this=0x7fff68970ad0, receiver=0x16a8840, event=0x7fff6896e520) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f3a95ed892e in QCoreApplication::notifyInternal (this=0x7fff68970ad0, receiver=0x16a8840, event=0x7fff6896e520) at kernel/qcoreapplication.cpp:915
#36 0x00007f3a96b849b7 in sendEvent (event=0x7fff6896e520, receiver=0x16a8840) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#37 QWidgetPrivate::show_helper (this=0x1a8d0d0) at kernel/qwidget.cpp:7551
#38 0x00007f3a96b8482a in QWidgetPrivate::showChildren (this=this@entry=0x1aa4ce0, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7859
#39 0x00007f3a96b848bd in QWidgetPrivate::show_helper (this=this@entry=0x1aa4ce0) at kernel/qwidget.cpp:7498
#40 0x00007f3a96b84ca2 in QWidget::setVisible (this=0x1a815e0, visible=<optimized out>) at kernel/qwidget.cpp:7773
#41 0x00007f3a96b8483e in show (this=0x1a815e0) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:494
#42 QWidgetPrivate::showChildren (this=this@entry=0x1a98a70, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7861
#43 0x00007f3a96b848bd in QWidgetPrivate::show_helper (this=this@entry=0x1a98a70) at kernel/qwidget.cpp:7498
#44 0x00007f3a96b84ca2 in QWidget::setVisible (this=0x1aaa050, visible=<optimized out>) at kernel/qwidget.cpp:7773
#45 0x00007f3a96b666ca in show (this=0x1aaa050) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:494
#46 QStackedLayout::setCurrentIndex (this=0x16a6c80, index=1) at kernel/qstackedlayout.cpp:311
#47 0x00007f3a97868b1f in KPageViewPrivate::_k_pageSelected (this=0x16a6300, index=..., previous=...) at ../../kdeui/paged/kpageview.cpp:235
#48 0x00007f3a95eee31f in QMetaObject::activate (sender=0x1a916f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6896e9e0) at kernel/qobject.cpp:3547
#49 0x00007f3a97091557 in QItemSelectionModel::selectionChanged (this=this@entry=0x1a916f0, _t1=..., _t2=...) at .moc/release-shared/moc_qitemselectionmodel.cpp:166
#50 0x00007f3a970961f3 in QItemSelectionModel::emitSelectionChanged (this=this@entry=0x1a916f0, newSelection=..., oldSelection=...) at itemviews/qitemselectionmodel.cpp:1544
#51 0x00007f3a970973bc in QItemSelectionModel::select (this=0x1a916f0, selection=..., command=...) at itemviews/qitemselectionmodel.cpp:1110
#52 0x00007f3a9709306b in QItemSelectionModel::select (this=this@entry=0x1a916f0, index=..., command=...) at itemviews/qitemselectionmodel.cpp:985
#53 0x00007f3a970917a1 in QItemSelectionModel::setCurrentIndex (this=0x1a916f0, index=..., command=...) at itemviews/qitemselectionmodel.cpp:1174
#54 0x00007f3a9786797f in KPageViewPrivate::_k_rebuildGui (this=0x16a6300) at ../../kdeui/paged/kpageview.cpp:70
#55 0x00007f3a97868885 in KPageViewPrivate::_k_modelChanged (this=0x16a6300) at ../../kdeui/paged/kpageview.cpp:190
#56 0x00007f3a95eee31f in QMetaObject::activate (sender=0x16ab2d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#57 0x00007f3a9786d041 in KPageWidgetModel::addPage (this=0x16ab2d0, item=0x1a91f70) at ../../kdeui/paged/kpagewidgetmodel.cpp:401
#58 0x00007f3a97c67990 in ModuleView::addModule (this=this@entry=0x16a4ae0, module=0x1627758) at ../../../systemsettings/core/ModuleView.cpp:191
#59 0x00007f3a97c67fb2 in ModuleView::loadModule (this=0x16a4ae0, menuItem=...) at ../../../systemsettings/core/ModuleView.cpp:144
#60 0x00007f3a7d28f6c8 in IconMode::changeModule (this=0x169e1a0, activeModule=...) at ../../../systemsettings/icons/IconMode.cpp:134
#61 0x00007f3a95eee31f in QMetaObject::activate (sender=0x16bd490, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6896f210) at kernel/qobject.cpp:3547
#62 0x00007f3a9703c525 in QAbstractItemView::activated (this=this@entry=0x16bd490, _t1=...) at .moc/release-shared/moc_qabstractitemview.cpp:362
#63 0x00007f3a9703c6d4 in QAbstractItemView::mouseDoubleClickEvent (this=0x16bd490, event=0x7fff6896fe60) at itemviews/qabstractitemview.cpp:1849
#64 0x00007f3a96b8264a in QWidget::event (this=0x16bd490, event=0x7fff6896fe60) at kernel/qwidget.cpp:8375
#65 0x00007f3a96f311d6 in QFrame::event (this=0x16bd490, e=0x7fff6896fe60) at widgets/qframe.cpp:557
#66 0x00007f3a9703eb23 in QAbstractItemView::viewportEvent (this=0x16bd490, event=0x7fff6896fe60) at itemviews/qabstractitemview.cpp:1644
#67 0x00007f3a95ed8a96 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x16a6010, event=0x7fff6896fe60) at kernel/qcoreapplication.cpp:1025
#68 0x00007f3a96b32d6c in QApplicationPrivate::notify_helper (this=this@entry=0x1249120, receiver=receiver@entry=0x16a6010, e=e@entry=0x7fff6896fe60) at kernel/qapplication.cpp:4552
#69 0x00007f3a96b37a6b in QApplication::notify (this=<optimized out>, receiver=0x16a6010, e=0x7fff6896fe60) at kernel/qapplication.cpp:4099
#70 0x00007f3a9783aaf6 in KApplication::notify (this=0x7fff68970ad0, receiver=0x16a6010, event=0x7fff6896fe60) at ../../kdeui/kernel/kapplication.cpp:311
#71 0x00007f3a95ed892e in QCoreApplication::notifyInternal (this=0x7fff68970ad0, receiver=0x16a6010, event=0x7fff6896fe60) at kernel/qcoreapplication.cpp:915
#72 0x00007f3a96b33bd3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#73 QApplicationPrivate::sendMouseEvent (receiver=0x16a6010, event=0x7fff6896fe60, alienWidget=0x16a6010, nativeWidget=0x13d0430, buttonDown=0x7f3a9760f2e8 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3167
#74 0x00007f3a96bb12a4 in QETWidget::translateMouseEvent (this=this@entry=0x13d0430, event=event@entry=0x7fff689705e0) at kernel/qapplication_x11.cpp:4617
#75 0x00007f3a96bb019f in QApplication::x11ProcessEvent (this=0x7fff68970ad0, event=0x7fff689705e0) at kernel/qapplication_x11.cpp:3732
#76 0x00007f3a96bd7d02 in x11EventSourceDispatch (s=0x123e700, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#77 0x00007f3a8f193db5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#78 0x00007f3a8f1940e8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#79 0x00007f3a8f1941a4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#80 0x00007f3a95f07076 in QEventDispatcherGlib::processEvents (this=0x11f8ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#81 0x00007f3a96bd797e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x00007f3a95ed767f in QEventLoop::processEvents (this=this@entry=0x7fff689709b0, flags=...) at kernel/qeventloop.cpp:149
#83 0x00007f3a95ed7908 in QEventLoop::exec (this=0x7fff689709b0, flags=...) at kernel/qeventloop.cpp:204
#84 0x00007f3a95edcac8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#85 0x000000000040a98e in main (argc=5, argv=0x7fff68970c18) at ../../../systemsettings/app/main.cpp:49

Reported using DrKonqi
Comment 6 Christoph Feck 2012-08-29 22:44:53 UTC
*** Bug 306009 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2012-08-29 22:46:13 UTC
As pointed out by a duplicate reported, the same crash happens in Kate, see bug 305913, so it most probably is a QtScript issue.
Comment 8 Becheru Petru-Ioan 2012-08-31 19:44:46 UTC
I confirm the bug with QT 4.8.2 and KDE 4.9!

WORKAROUND: downgrade QT to 4.8.1 !
With QT 4.8.1, the bug doesn't show up, so it must be a QT (script) issue as said by #7
Comment 9 Sandro Mani 2012-09-01 00:53:53 UTC
Happens after upgrading to
qt-4.8.2-5.fc17.x86_64

Does not occur with
qt-4.8.2-4.fc17.x86_64

qt-4.8.2-5.fc17.x86_64 applied http://qt.gitorious.org/qt/qt/commit/ada98493bbfbd9af0d0b593017e29d39bcd3495e/diffs , which seems to cause the problem (also noticed on debian, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=685524)
Comment 10 Jekyll Wu 2012-09-02 07:42:40 UTC
*** Bug 306149 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2012-09-04 09:53:22 UTC
*** Bug 305806 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2012-09-04 09:54:01 UTC
*** Bug 305913 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Feck 2012-09-04 09:54:31 UTC
*** Bug 305923 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2012-09-04 09:55:11 UTC
*** Bug 306016 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2012-09-04 09:56:34 UTC
*** Bug 306018 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2012-09-04 10:00:38 UTC
Has this already been reported to qt-project.org ?
Comment 17 Jaroslav Reznik 2012-09-04 14:45:05 UTC
(In reply to comment #16)
> Has this already been reported to qt-project.org ?

I commented it in the original JSC crash bug - https://bugreports.qt-project.org/browse/QTBUG-23871 as it seems the patch is causing this issue (according to the comment #9).
Comment 18 Carlos Cámara 2012-09-05 13:04:34 UTC
Created attachment 73671 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed:
Trying to change window decorator settings

- Unusual behavior I noticed:
nothing

- Custom settings of the application:
using default oxygen window decorator

-- Backtrace (Reduced):
#6  __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:495
[...]
#13 0x00007feee73966c6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007feee6609d5c in QDeclarativeScriptEngine::QDeclarativeScriptEngine (this=0x102d078, priv=0x102cf70) at qml/qdeclarativeengine.cpp:382
#15 0x00007feee660f40f in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate (this=0x102cf70, e=0x102cac0) at qml/qdeclarativeengine.cpp:353
#16 0x00007feee660f721 in QDeclarativeEngine::QDeclarativeEngine (this=0x102cac0, parent=0x0) at qml/qdeclarativeengine.cpp:634
Comment 19 fa 2012-09-08 11:52:58 UTC
On Kubuntu Quantal, this bug is fixed with beta1 updates for me.
Comment 20 Märt Rang 2012-09-11 19:43:34 UTC
Created attachment 73838 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed:
Tried to open Workspace Settings.
- Custom settings of the application:
I've installed different language settings, crash appeared sometime after that (might not be related at all).

-- Backtrace (Reduced):
#6  __memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:202
[...]
#13 0x00007ffa31a536c6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007ffa30cc6d5c in QDeclarativeScriptEngine::QDeclarativeScriptEngine (this=0x23645e8, priv=0x23644e0) at qml/qdeclarativeengine.cpp:382
#15 0x00007ffa30ccc40f in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate (this=0x23644e0, e=0x1e56140) at qml/qdeclarativeengine.cpp:353
#16 0x00007ffa30ccc721 in QDeclarativeEngine::QDeclarativeEngine (this=0x1e56140, parent=0x0) at qml/qdeclarativeengine.cpp:634
Comment 21 Jonathan 2012-09-15 02:54:31 UTC
Kate crashes with this error, I believe.

Application: Kate (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f70851e6780 (LWP 1305))]

Thread 2 (Thread 0x7f7069be3700 (LWP 1306)):
#0  0x00007f7083aba954 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7076a98787 in ?? () from /usr/lib/libQtScript.so.4
#2  0x00007f7076a987b9 in ?? () from /usr/lib/libQtScript.so.4
#3  0x00007f7083ab6e0f in start_thread () from /usr/lib/libpthread.so.0
#4  0x00007f708284945d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f70851e6780 (LWP 1305)):
[KCrash Handler]
#5  0x00007f708288d507 in __memcpy_ssse3 () from /usr/lib/libc.so.6
#6  0x00007f70769db4cb in ?? () from /usr/lib/libQtScript.so.4
#7  0x00007f70769f0d2f in ?? () from /usr/lib/libQtScript.so.4
#8  0x00007f70769ed0b3 in ?? () from /usr/lib/libQtScript.so.4
#9  0x00007f7076a39e88 in ?? () from /usr/lib/libQtScript.so.4
#10 0x00007f7076a3a53c in ?? () from /usr/lib/libQtScript.so.4
#11 0x00007f7076adacc0 in ?? () from /usr/lib/libQtScript.so.4
#12 0x00007f7076adbcb6 in QScriptEngine::QScriptEngine() () from /usr/lib/libQtScript.so.4
#13 0x00007f706a8594da in ?? () from /usr/lib/libkatepartinterfaces.so.4
#14 0x00007f706a859849 in ?? () from /usr/lib/libkatepartinterfaces.so.4
#15 0x00007f706a85ab6c in ?? () from /usr/lib/libkatepartinterfaces.so.4
#16 0x00007f706a860af1 in ?? () from /usr/lib/libkatepartinterfaces.so.4
#17 0x00007f706a8611cc in ?? () from /usr/lib/libkatepartinterfaces.so.4
#18 0x00007f706a8bf5ea in KateView::setupActions() () from /usr/lib/libkatepartinterfaces.so.4
#19 0x00007f706a8c3545 in KateView::KateView(KateDocument*, QWidget*) () from /usr/lib/libkatepartinterfaces.so.4
#20 0x00007f706a82f084 in KateDocument::createView(QWidget*) () from /usr/lib/libkatepartinterfaces.so.4
#21 0x00007f707006a6ca in ?? () from /usr/lib/libkateinterfaces.so.4
#22 0x00007f707006edca in ?? () from /usr/lib/libkateinterfaces.so.4
#23 0x00007f707006cc6c in ?? () from /usr/lib/libkateinterfaces.so.4
#24 0x00007f707006d4fd in ?? () from /usr/lib/libkateinterfaces.so.4
#25 0x00007f707006202e in ?? () from /usr/lib/libkateinterfaces.so.4
#26 0x00007f7070053884 in KateApp::newMainWindow(KConfig*, QString const&) () from /usr/lib/libkateinterfaces.so.4
#27 0x00007f70700777b3 in ?? () from /usr/lib/libkateinterfaces.so.4
#28 0x00007f707007a923 in ?? () from /usr/lib/libkateinterfaces.so.4
#29 0x00007f70700551a7 in KateApp::startupKate() () from /usr/lib/libkateinterfaces.so.4
#30 0x00007f7070055565 in KateApp::initKate() () from /usr/lib/libkateinterfaces.so.4
#31 0x00007f7070055782 in KateApp::KateApp(KCmdLineArgs*) () from /usr/lib/libkateinterfaces.so.4
#32 0x00007f70702a95f8 in kdemain () from /usr/lib/libkdeinit4_kate.so
#33 0x0000000000408342 in _start ()
Comment 22 Jonathan 2012-09-15 16:09:04 UTC
No, sorry, just logged out and logged back in, and I believe it is working

(In reply to comment #21)
> Kate crashes with this error, I believe.
> 
> Application: Kate (kdeinit4), signal: Segmentation fault
> Using host libthread_db library "/usr/lib/libthread_db.so.1".
> [Current thread is 1 (Thread 0x7f70851e6780 (LWP 1305))]
> 
> Thread 2 (Thread 0x7f7069be3700 (LWP 1306)):
> #0  0x00007f7083aba954 in pthread_cond_wait@@GLIBC_2.3.2 () from
> /usr/lib/libpthread.so.0
> #1  0x00007f7076a98787 in ?? () from /usr/lib/libQtScript.so.4
> #2  0x00007f7076a987b9 in ?? () from /usr/lib/libQtScript.so.4
> #3  0x00007f7083ab6e0f in start_thread () from /usr/lib/libpthread.so.0
> #4  0x00007f708284945d in clone () from /usr/lib/libc.so.6
> 
> Thread 1 (Thread 0x7f70851e6780 (LWP 1305)):
> [KCrash Handler]
> #5  0x00007f708288d507 in __memcpy_ssse3 () from /usr/lib/libc.so.6
> #6  0x00007f70769db4cb in ?? () from /usr/lib/libQtScript.so.4
> #7  0x00007f70769f0d2f in ?? () from /usr/lib/libQtScript.so.4
> #8  0x00007f70769ed0b3 in ?? () from /usr/lib/libQtScript.so.4
> #9  0x00007f7076a39e88 in ?? () from /usr/lib/libQtScript.so.4
> #10 0x00007f7076a3a53c in ?? () from /usr/lib/libQtScript.so.4
> #11 0x00007f7076adacc0 in ?? () from /usr/lib/libQtScript.so.4
> #12 0x00007f7076adbcb6 in QScriptEngine::QScriptEngine() () from
> /usr/lib/libQtScript.so.4
> #13 0x00007f706a8594da in ?? () from /usr/lib/libkatepartinterfaces.so.4
> #14 0x00007f706a859849 in ?? () from /usr/lib/libkatepartinterfaces.so.4
> #15 0x00007f706a85ab6c in ?? () from /usr/lib/libkatepartinterfaces.so.4
> #16 0x00007f706a860af1 in ?? () from /usr/lib/libkatepartinterfaces.so.4
> #17 0x00007f706a8611cc in ?? () from /usr/lib/libkatepartinterfaces.so.4
> #18 0x00007f706a8bf5ea in KateView::setupActions() () from
> /usr/lib/libkatepartinterfaces.so.4
> #19 0x00007f706a8c3545 in KateView::KateView(KateDocument*, QWidget*) ()
> from /usr/lib/libkatepartinterfaces.so.4
> #20 0x00007f706a82f084 in KateDocument::createView(QWidget*) () from
> /usr/lib/libkatepartinterfaces.so.4
> #21 0x00007f707006a6ca in ?? () from /usr/lib/libkateinterfaces.so.4
> #22 0x00007f707006edca in ?? () from /usr/lib/libkateinterfaces.so.4
> #23 0x00007f707006cc6c in ?? () from /usr/lib/libkateinterfaces.so.4
> #24 0x00007f707006d4fd in ?? () from /usr/lib/libkateinterfaces.so.4
> #25 0x00007f707006202e in ?? () from /usr/lib/libkateinterfaces.so.4
> #26 0x00007f7070053884 in KateApp::newMainWindow(KConfig*, QString const&)
> () from /usr/lib/libkateinterfaces.so.4
> #27 0x00007f70700777b3 in ?? () from /usr/lib/libkateinterfaces.so.4
> #28 0x00007f707007a923 in ?? () from /usr/lib/libkateinterfaces.so.4
> #29 0x00007f70700551a7 in KateApp::startupKate() () from
> /usr/lib/libkateinterfaces.so.4
> #30 0x00007f7070055565 in KateApp::initKate() () from
> /usr/lib/libkateinterfaces.so.4
> #31 0x00007f7070055782 in KateApp::KateApp(KCmdLineArgs*) () from
> /usr/lib/libkateinterfaces.so.4
> #32 0x00007f70702a95f8 in kdemain () from /usr/lib/libkdeinit4_kate.so
> #33 0x0000000000408342 in _start ()
Comment 23 Christoph Feck 2012-09-21 15:57:53 UTC
*** Bug 307166 has been marked as a duplicate of this bug. ***
Comment 24 Christoph Feck 2012-09-22 09:26:17 UTC
*** Bug 307179 has been marked as a duplicate of this bug. ***
Comment 25 Andrea 2012-09-22 10:44:28 UTC
(In reply to comment #23)
> *** Bug 307166 has been marked as a duplicate of this bug. ***

Today I have discovered something new about my report: for me the crash occur only if apper (apper-sentinel) is running.
I tried to kill process apper-sentinel and programs (kate, kwrite) works, then I reopen it and crash again.
I hope that this information will be useful.
Comment 26 Christoph Feck 2012-09-22 20:08:57 UTC
*** Bug 307227 has been marked as a duplicate of this bug. ***
Comment 27 Andrew Munkres 2012-09-23 01:25:08 UTC
Now that Qt 4.8.3 (the first upstream Qt version to include this patch) is in Arch Linux, the problem occurs there too. For me, it caused both plasma-desktop and kwin to segfault on startup, thus making KDE almost unusable. (As a temporary measure to prevent these from crashing, I reverted to Qt 4.8.2.)
https://bugs.archlinux.org/task/31654

There's also an Ubuntu bug report which looks it it might be caused by this patch:
https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/1045755

This patch actually appears to have originated 2 years ago in the upstream WebKit SVN repository:
http://trac.webkit.org/changeset/62799
https://bugs.webkit.org/show_bug.cgi?id=41641
But it wasn't until August this year that it migrated from WebKit's JavaScriptCore to the copy of JavaScriptCore in the QtScript module of Qt:
http://qt.gitorious.org/qt/qtscript/commit/79ebd39d0d4846cb911ae122d2059e5add568d7e
http://qt.gitorious.org/qt/qt/commit/ada98493bbfbd9af0d0b593017e29d39bcd3495e
https://bugreports.qt-project.org/browse/QTBUG-23871

Maybe it would be worth reporting the problem to the upstream WebKit developers?
Comment 28 squan 2012-09-23 20:25:56 UTC
Created attachment 74119 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.9.1 "release 561" using Qt 4.8.3

Here a slightliy different backtrace from openSUSE-12.2 with KDE-4.9 and qt-4.8.3.
HTH

- What I was doing when the application crashed:
Clicking a konsole window entry in window list ("task manager") of a "panel"

-- Backtrace (Reduced):
#7  0x00007fc60268210b in memcpy (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/bits/string3.h:52
#8  executableCopy (allocator=0x7fc5e4080960, this=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h:139
#9  executableCopy (allocator=0x7fc5e4080960, this=0x7fff384c8ea0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#10 executableCopy (allocator=0x7fc5e4080960, this=0x7fff384c8ea0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#11 LinkBuffer (executablePool=..., masm=0x7fff384c8ea0, this=0x7fff384c8e10) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
Comment 29 Milian Wolff 2012-09-24 17:07:50 UTC
proper upstream bug: https://bugreports.qt-project.org/browse/QTBUG-27322
Comment 30 Rex Dieter 2012-09-26 14:59:25 UTC
*** Bug 307431 has been marked as a duplicate of this bug. ***
Comment 31 Rex Dieter 2012-09-26 15:00:44 UTC
I think we can safely take this bug out of  "unconfirmed"  status now.
Comment 32 Johan Krüger Haglert 2012-09-26 15:06:39 UTC
(In reply to comment #27)
> Now that Qt 4.8.3 (the first upstream Qt version to include this patch) is
> in Arch Linux, the problem occurs there too. For me, it caused both
> plasma-desktop and kwin to segfault on startup, thus making KDE almost
> unusable. (As a temporary measure to prevent these from crashing, I reverted
> to Qt 4.8.2.)

kdeinit4 and kwin crashes here to using 4.8.3 in opensuse since they got that in their kde49 repository.
Comment 33 Christoph Feck 2012-09-26 23:27:46 UTC
*** Bug 307461 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2012-09-27 12:19:34 UTC
*** Bug 307478 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2012-09-29 20:09:11 UTC
*** Bug 307562 has been marked as a duplicate of this bug. ***
Comment 36 Christoph Feck 2012-09-29 20:09:49 UTC
*** Bug 307149 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Feck 2012-09-30 22:06:11 UTC
*** Bug 307640 has been marked as a duplicate of this bug. ***
Comment 38 Milian Wolff 2012-11-09 23:32:38 UTC
Note: This bug is fixed upstream, see https://bugreports.qt-project.org/browse/QTBUG-27322 and https://codereview.qt-project.org/#change,37896 

If you can reproduce this with Qt 4.8.4, then this should be reopened.
Comment 39 Dominik Haumann 2013-09-05 08:27:48 UTC
*** Bug 324528 has been marked as a duplicate of this bug. ***
Comment 40 Dominik Haumann 2013-09-05 08:31:29 UTC
Milian, according to bug #324528 this just happened again in KDE 4.11, Qt 4.8.4 (64bit).

Is this fixed in Qt 4.8.5?