Bug 307461 - KWrite and other Kate-related applications (Kile, for example) randomly crash at startup
Summary: KWrite and other Kate-related applications (Kile, for example) randomly crash...
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-26 21:57 UTC by dzmail90-dev
Modified: 2012-09-26 23:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dzmail90-dev 2012-09-26 21:57:57 UTC
Application: kwrite (4.9.1 "release 561")
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I started KWrite and it crashed. Same behaviour happens with other applications related to Kate, for example Kile. Not always the applications crashed, and the times they not crashed they worked seamlessly. Crashes occurs often when a lot of other applications are open, while when few or no other applications are open KWrite doesn't crash. It must be noted that if I can start KWrite and then start a lot of other applications, KWrite continues to work seamlessly. The bug must be in some part of the code executed almost only on application start.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWrite (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4ae4c24760 (LWP 13231))]

Thread 2 (Thread 0x7f4acc4e2700 (LWP 13234)):
#0  0x00007f4ae34b7e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4ad8174772 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f4ad846de80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f4ad81747a9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f4ae34b3f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f4ae221410d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4ae4c24760 (LWP 13231)):
[KCrash Handler]
#6  0x00007f4ae226217e in __memcpy_ssse3_back () from /lib64/libc.so.6
#7  0x00007f4ad80ae179 in executableCopy (allocator=0x7f4acbbe9960, this=<optimized out>) at /usr/include/bits/string3.h:52
#8  executableCopy (this=0x7fff47724420, allocator=0x7f4acbbe9960) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#9  executableCopy (allocator=0x7f4acbbe9960, this=0x7fff47724420) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#10 LinkBuffer (executablePool=..., masm=0x7fff47724420, this=0x7fff47724340) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
#11 QTJSC::JIT::privateCompileCTIMachineTrampolines (this=0x7fff47724420, executablePool=0x7f4acbbe39e8, globalData=<optimized out>, ctiStringLengthTrampoline=0x7f4acbbe39f0, ctiVirtualCallLink=0x7f4acbbe39f8, ctiVirtualCall=0x7f4acbbe3a00, ctiNativeCallThunk=0x7f4acbbe3a08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITOpcodes.cpp:1817
#12 0x00007f4ad80cde8c in QTJSC::JIT::compileCTIMachineTrampolines (globalData=0x7f4acbbe2800, executablePool=0x7f4acbbe39e8, ctiStringLengthTrampoline=0x7f4acbbe39f0, ctiVirtualCallLink=0x7f4acbbe39f8, ctiVirtualCall=0x7f4acbbe3a00, ctiNativeCallThunk=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JIT.h:323
#13 0x00007f4ad80cb8ba in QTJSC::JITThunks::JITThunks (this=0x7f4acbbe39e8, globalData=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:768
#14 0x00007f4ad81199bd in QTJSC::JSGlobalData::JSGlobalData (this=0x7f4acbbe2800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#15 0x00007f4ad811a04c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#16 0x00007f4ad81b6eb7 in QScriptEnginePrivate::QScriptEnginePrivate (this=0xac9770) at api/qscriptengine.cpp:979
#17 0x00007f4ad81b7df6 in QScriptEngine::QScriptEngine (this=0xa672b0) at api/qscriptengine.cpp:1964
#18 0x00007f4accdb6273 in load (this=0x9df6d0) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:247
#19 KateScript::load (this=0x9df6d0) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:230
#20 0x00007f4accdb6619 in KateScript::clearExceptions (this=0x9df6d0) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:157
#21 0x00007f4accdb82e2 in KateCommandLineScript::actionInfo (this=0x9df6d0, cmd=...) at /usr/src/debug/kate-4.9.1/part/script/katecommandlinescript.cpp:78
#22 0x00007f4accdbde4b in KateScriptActionMenu::repopulate (this=0xafdb50) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:118
#23 0x00007f4accdbe50b in KateScriptActionMenu::KateScriptActionMenu (this=0xafdb50, view=0x9b3540, text=...) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:74
#24 0x00007f4acce22acb in KateView::setupActions (this=0x9b3540) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:350
#25 0x00007f4acce26dd3 in KateView::KateView (this=0x9b3540, doc=0x9aaeb0, parent=<optimized out>) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:240
#26 0x00007f4accd8a094 in KateDocument::createView (this=0x9aaeb0, parent=0x9a8840) at /usr/src/debug/kate-4.9.1/part/document/katedocument.cpp:335
#27 0x00007f4ad2774e11 in KWrite::KWrite (this=0x9a8840, doc=0x9aaeb0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kate-4.9.1/kwrite/kwritemain.cpp:77
#28 0x00007f4ad27772c1 in KWriteApp::init (this=0x7fff47726680) at /usr/src/debug/kate-4.9.1/kwrite/kwriteapp.cpp:129
#29 0x00007f4ad2777b18 in KWriteApp::KWriteApp (this=0x7fff47726680, m_args=<optimized out>) at /usr/src/debug/kate-4.9.1/kwrite/kwriteapp.cpp:51
#30 0x00007f4ad277467c in kdemain (argc=2, argv=<optimized out>) at /usr/src/debug/kate-4.9.1/kwrite/kwritemain.cpp:678
#31 0x0000000000408984 in _start ()

This bug may be a duplicate of or related to bug 305718.

Possible duplicates by query: bug 307227, bug 307166, bug 305718.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-26 23:27:46 UTC

*** This bug has been marked as a duplicate of bug 305718 ***