Bug 319847 - Kwin crashes after pluggin an VGA cable
Summary: Kwin crashes after pluggin an VGA cable
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-14 22:09 UTC by eddie_strantor
Modified: 2013-05-15 06:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eddie_strantor 2013-05-14 22:09:34 UTC
Application: kwin (4.10.2)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-19-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

Just plugged an VGA cable and then it crashed. At the same time I was executing (alt+F2) dolphin.

The crash does not seem to be reproducible.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7fb36677c0 (LWP 1897))]

Thread 2 (Thread 0x7f7f86a11700 (LWP 1909)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7faf76ee77 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f7faf76eea9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f7fa6aa4f8e in start_thread (arg=0x7f7f86a11700) at pthread_create.c:311
#4  0x00007f7fb2e7ee1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f7fb36677c0 (LWP 1897)):
[KCrash Handler]
#6  0x00007f7fb3223935 in KWin::EffectsHandlerImpl::buildQuads (this=0x1e63090, w=0x2650cb0, quadList=...) at ../../kwin/effects.cpp:329
#7  0x00007f7fb32053ac in KWin::Scene::Window::buildQuads (this=0x2652d10, force=<optimized out>) at ../../kwin/scene.cpp:621
#8  0x00007f7fb3221c21 in KWin::EffectWindowImpl::buildQuads (this=<optimized out>, force=<optimized out>) at ../../kwin/effects.cpp:1582
#9  0x00007f7fb31c30a5 in KWin::Shadow::updateShadow (this=0x26e5450) at ../../kwin/shadow.cpp:216
#10 0x00007f7fb320171f in KWin::Toplevel::getShadow (this=0x298d190) at ../../kwin/toplevel.cpp:346
#11 0x00007f7fb31c034a in KWin::Toplevel::propertyNotifyEvent (this=this@entry=0x298d190, e=e@entry=0x7fff141d6af0) at ../../kwin/events.cpp:1667
#12 0x00007f7fb31c0389 in KWin::Client::propertyNotifyEvent (this=0x298d190, e=0x7fff141d6af0) at ../../kwin/events.cpp:827
#13 0x00007f7fb31bf868 in KWin::Client::windowEvent (this=0x298d190, e=e@entry=0x7fff141d6af0) at ../../kwin/events.cpp:598
#14 0x00007f7fb31c069b in KWin::Workspace::workspaceEvent (this=0x1a458c0, e=e@entry=0x7fff141d6af0) at ../../kwin/events.cpp:288
#15 0x00007f7fb31b5568 in KWin::Application::x11EventFilter (this=0x7fff141d7050, e=0x7fff141d6af0) at ../../kwin/main.cpp:362
#16 0x00007f7fad69d0cc in qt_x11EventFilter (ev=0x7fff141d6af0) at kernel/qapplication_x11.cpp:441
#17 qt_x11EventFilter (ev=0x7fff141d6af0) at kernel/qapplication_x11.cpp:429
#18 0x00007f7fad6ab170 in QApplication::x11ProcessEvent (this=0x7fff141d7050, event=event@entry=0x7fff141d6af0) at kernel/qapplication_x11.cpp:3458
#19 0x00007f7fad6d7b39 in QEventDispatcherX11::processEvents (this=0x18cfad0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#20 0x00007f7fae28a38f in QEventLoop::processEvents (this=this@entry=0x7fff141d6d60, flags=...) at kernel/qeventloop.cpp:149
#21 0x00007f7fae28a618 in QEventLoop::exec (this=this@entry=0x7fff141d6d60, flags=...) at kernel/qeventloop.cpp:204
#22 0x00007f7fae28fcf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#23 0x00007f7fad62fffc in QApplication::exec () at kernel/qapplication.cpp:3828
#24 0x00007f7fb31b502a in kdemain (argc=3, argv=0x7fff141d7198) at ../../kwin/main.cpp:537
#25 0x00007f7fb2da6ea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=3, ubp_av=0x7fff141d7198, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff141d7188) at libc-start.c:260
#26 0x0000000000400701 in _start ()

This bug may be a duplicate of or related to bug 315477.

Possible duplicates by query: bug 319255, bug 318734, bug 318328, bug 315477, bug 315144.

Reported using DrKonqi
Comment 1 Martin Flöser 2013-05-15 06:06:08 UTC

*** This bug has been marked as a duplicate of bug 308201 ***