Bug 315144 - KWin crashed when disconnecting from docking station
Summary: KWin crashed when disconnecting from docking station
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.0
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-14 16:03 UTC by Martin Holec
Modified: 2013-02-14 16:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holec 2013-02-14 16:03:24 UTC
Application: kwin (4.10.00)
KDE Platform Version: 4.10.00
Qt Version: 4.8.4
Operating System: Linux 3.8.0-0.rc6.git2.1.fc19.x86_64 x86_64

-- Information about the crash:
- What I was doing when the application crashed:
KWin crashed when disconnecting from docking station.....

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f71f38b08c0 (LWP 2009))]

Thread 2 (Thread 0x7f71e0d41700 (LWP 2018)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x0000003013d8971b in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3014087f00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x0000003013d89759 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00000037ee207d15 in start_thread (arg=0x7f71e0d41700) at pthread_create.c:308
#4  0x00000037edaf4c4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f71f38b08c0 (LWP 2009)):
[KCrash Handler]
#6  0x000000300fcd2f0a in KWin::EffectsHandlerImpl::buildQuads(KWin::EffectWindow*, KWin::WindowQuadList&) () from /lib64/libkdeinit4_kwin.so
#7  0x000000300fcb4d06 in KWin::Scene::Window::buildQuads(bool) const () from /lib64/libkdeinit4_kwin.so
#8  0x000000300fcce651 in KWin::EffectWindowImpl::buildQuads(bool) const () from /lib64/libkdeinit4_kwin.so
#9  0x000000300fc73e86 in KWin::Shadow::updateShadow() () from /lib64/libkdeinit4_kwin.so
#10 0x000000300fcb132b in KWin::Toplevel::getShadow() () from /lib64/libkdeinit4_kwin.so
#11 0x000000300fc7116a in KWin::Toplevel::propertyNotifyEvent(XPropertyEvent*) () from /lib64/libkdeinit4_kwin.so
#12 0x000000300fc711a1 in KWin::Client::propertyNotifyEvent(XPropertyEvent*) () from /lib64/libkdeinit4_kwin.so
#13 0x000000300fc70498 in KWin::Client::windowEvent(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#14 0x000000300fc71493 in KWin::Workspace::workspaceEvent(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#15 0x000000300fc65ea0 in KWin::Application::x11EventFilter(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#16 0x000000300a23042c in qt_x11EventFilter (ev=0x7fffc8013560) at kernel/qapplication_x11.cpp:435
#17 0x000000300a23df09 in QApplication::x11ProcessEvent (this=0x7fffc8013950, event=0x7fffc8013560) at kernel/qapplication_x11.cpp:3372
#18 0x000000300a2658f0 in QEventDispatcherX11::processEvents (this=0xfdabe0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#19 0x0000003008178d8f in QEventLoop::processEvents (this=this@entry=0x7fffc80137c0, flags=...) at kernel/qeventloop.cpp:149
#20 0x0000003008179085 in QEventLoop::exec (this=0x7fffc80137c0, flags=...) at kernel/qeventloop.cpp:204
#21 0x000000300817e09b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#22 0x000000300fc66e5f in kdemain () from /lib64/libkdeinit4_kwin.so
#23 0x00000037eda21c25 in __libc_start_main (main=0x400960 <main>, argc=3, ubp_av=0x7fffc8013a98, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc8013a88) at libc-start.c:258
#24 0x0000000000400991 in _start ()

Possible duplicates by query: bug 313765, bug 311269, bug 308201, bug 299582, bug 294451.

Reported using DrKonqi
Comment 1 Martin Flöser 2013-02-14 16:28:32 UTC

*** This bug has been marked as a duplicate of bug 308201 ***