Bug 318734 - kwin crashed after screen resolution change
Summary: kwin crashed after screen resolution change
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-22 19:15 UTC by Toralf Förster
Modified: 2013-04-22 19:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster 2013-04-22 19:15:35 UTC
Application: kwin (4.10.2)
KDE Platform Version: 4.10.2 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.9.0-rc7+ i686
Distribution: "Gentoo Base System release 2.1"

-- Information about the crash:
- What I was doing when the application crashed:
I plugged in an external VGA screen, probably a dup, but I'm unsure. Today I updated KWIn to 4.1.02-r1

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb2533740 (LWP 21056))]

Thread 2 (Thread 0xae10eb40 (LWP 21063)):
#0  0xb775f424 in __kernel_vsyscall ()
#1  0x46b2fb8c in pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x46a7874c in __pthread_cond_wait (cond=0xb6a3b890 <QTWTF::pageheap_memory+20720>, mutex=0xb6a3b878 <QTWTF::pageheap_memory+20696>) at forward.c:139
#3  0xb6936961 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6a367a0 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb693699f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6a367a0 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x46b2bdef in start_thread (arg=0xae10eb40) at pthread_create.c:305
#6  0x46a6b41e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb2533740 (LWP 21056)):
[KCrash Handler]
#7  0xb76bbbea in KWin::EffectsHandlerImpl::buildQuads (this=0xa209d50, w=0xa1f1c60, quadList=...) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/effects.cpp:329
#8  0xb76971b0 in KWin::Scene::Window::buildQuads (this=0x9fec330, force=true) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/scene.cpp:621
#9  0xb76b9d34 in KWin::EffectWindowImpl::buildQuads (this=0xa1f1c60, force=true) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/effects.cpp:1582
#10 0xb7643b2f in KWin::Shadow::updateShadow (this=0x9fec5d0) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/shadow.cpp:216
#11 0xb76927c3 in KWin::Toplevel::getShadow (this=0xb77340c8 <vtable for KWin::EffectWindowImpl+8>) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/toplevel.cpp:346
#12 0xb76418c0 in KWin::Toplevel::propertyNotifyEvent (this=0xa18ec38, e=0xbfc2845c) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/events.cpp:1667
#13 0xb764190e in KWin::Client::propertyNotifyEvent (this=0xa18ec38, e=0xbfc2845c) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/events.cpp:827
#14 0xb7640d3c in KWin::Client::windowEvent (this=0xa18ec38, e=0xbfc2845c) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/events.cpp:598
#15 0xb7641e8c in KWin::Workspace::workspaceEvent (this=0x9c9ef40, e=0xbfc2845c) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/events.cpp:297
#16 0xb7631d32 in KWin::Application::x11EventFilter (this=0xbfc28684, e=0xbfc2845c) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/main.cpp:362
#17 0xb57d5bd4 in qt_x11EventFilter (ev=0xbfc2845c) at kernel/qapplication_x11.cpp:435
#18 qt_x11EventFilter (ev=0xbfc2845c) at kernel/qapplication_x11.cpp:423
#19 0xb57e2a4b in QApplication::x11ProcessEvent (this=0xbfc28684, event=0xbfc2845c) at kernel/qapplication_x11.cpp:3351
#20 0xb580f6a5 in QEventDispatcherX11::processEvents (this=0x9bb9ef0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0xb62433cd in QEventLoop::processEvents (this=0xbfc285e4, flags=...) at kernel/qeventloop.cpp:149
#22 0xb6243669 in QEventLoop::exec (this=0xbfc285e4, flags=...) at kernel/qeventloop.cpp:204
#23 0xb6248c1a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#24 0xb5758de4 in QApplication::exec () at kernel/qapplication.cpp:3823
#25 0xb7634baa in kdemain (argc=3, argv=0xbfc28924) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2/kwin/main.cpp:537
#26 0x080485fb in main (argc=3, argv=0xbfc28924) at /var/tmp/portage/kde-base/kwin-4.10.2-r1/work/kwin-4.10.2_build/kwin/kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 308201.

Possible duplicates by query: bug 318328, bug 315477, bug 315144, bug 313765, bug 311269.

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-04-22 19:22:29 UTC

*** This bug has been marked as a duplicate of bug 308201 ***