Bug 315477 - KWin crashed when an external VGA screen is attached
Summary: KWin crashed when an external VGA screen is attached
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 21:34 UTC by Toralf Förster
Modified: 2013-02-19 21:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster 2013-02-19 21:34:50 UTC
Application: kwin (4.10.00)
KDE Platform Version: 4.10.00 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.8.0 i686
Distribution: "Gentoo Base System release 2.1"

-- Information about the crash:
- What I was doing when the application crashed:

plugged in an external VGA cable onto my ThinkPad T420, running a stable x86 Gentoo and kernel 3.8.0 + Mesa 9.1_rc2 + i915

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb289e740 (LWP 5639))]

Thread 2 (Thread 0xae433b40 (LWP 5676)):
#0  0xb77bf424 in __kernel_vsyscall ()
#1  0x46b2fb8c in pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x46a7874c in __pthread_cond_wait (cond=0xb6a9d890 <QTWTF::pageheap_memory+20720>, mutex=0xb6a9d878 <QTWTF::pageheap_memory+20696>) at forward.c:139
#3  0xb6998961 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6a987a0 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb699899f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6a987a0 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x46b2bdef in start_thread (arg=0xae433b40) at pthread_create.c:305
#6  0x46a6b41e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb289e740 (LWP 5639)):
[KCrash Handler]
#7  0xb771c38a in KWin::EffectsHandlerImpl::buildQuads (this=0x889e960, w=0x89d4c98, quadList=...) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/effects.cpp:329
#8  0xb76f7b40 in KWin::Scene::Window::buildQuads (this=0x89d5550, force=true) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/scene.cpp:621
#9  0xb771a4d4 in KWin::EffectWindowImpl::buildQuads (this=0x89d4c98, force=true) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/effects.cpp:1582
#10 0xb76a47df in KWin::Shadow::updateShadow (this=0x8a92890) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/shadow.cpp:216
#11 0xb76f3153 in KWin::Toplevel::getShadow (this=0xb7794228 <vtable for KWin::EffectWindowImpl+8>) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/toplevel.cpp:346
#12 0xb76a2570 in KWin::Toplevel::propertyNotifyEvent (this=0x88edad8, e=0xbfbd06cc) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/events.cpp:1667
#13 0xb76a25be in KWin::Client::propertyNotifyEvent (this=0x88edad8, e=0xbfbd06cc) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/events.cpp:827
#14 0xb76a19ec in KWin::Client::windowEvent (this=0x88edad8, e=0xbfbd06cc) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/events.cpp:598
#15 0xb76a2b3c in KWin::Workspace::workspaceEvent (this=0x84163e8, e=0xbfbd06cc) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/events.cpp:297
#16 0xb7692942 in KWin::Application::x11EventFilter (this=0xbfbd08f4, e=0xbfbd06cc) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/main.cpp:362
#17 0xb5837bd4 in qt_x11EventFilter (ev=0xbfbd06cc) at kernel/qapplication_x11.cpp:435
#18 qt_x11EventFilter (ev=0xbfbd06cc) at kernel/qapplication_x11.cpp:423
#19 0xb5844a4b in QApplication::x11ProcessEvent (this=0xbfbd08f4, event=0xbfbd06cc) at kernel/qapplication_x11.cpp:3351
#20 0xb58716a5 in QEventDispatcherX11::processEvents (this=0x8330ef0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0xb62a53cd in QEventLoop::processEvents (this=0xbfbd0854, flags=...) at kernel/qeventloop.cpp:149
#22 0xb62a5669 in QEventLoop::exec (this=0xbfbd0854, flags=...) at kernel/qeventloop.cpp:204
#23 0xb62aac1a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#24 0xb57bade4 in QApplication::exec () at kernel/qapplication.cpp:3823
#25 0xb76957ba in kdemain (argc=3, argv=0xbfbd0b94) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0/kwin/main.cpp:537
#26 0x080485fb in main (argc=3, argv=0xbfbd0b94) at /var/tmp/portage/kde-base/kwin-4.10.0/work/kwin-4.10.0_build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 315144, bug 313765, bug 311269, bug 308201, bug 299582.

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-02-19 21:40:47 UTC

*** This bug has been marked as a duplicate of bug 308201 ***