Bug 318328 - seems to be firefox related. Doesn't crash if firefox is not started
Summary: seems to be firefox related. Doesn't crash if firefox is not started
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-14 10:55 UTC by ray-ven
Modified: 2013-04-14 12:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ray-ven 2013-04-14 10:55:14 UTC
Application: kwin (4.10.2)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-17-generic x86_64
Distribution: Ubuntu Raring Ringtail (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
This problem accoures since lucid I think. Tried xrandr krandr and kscreen, doesn't make any difference. It crashes most of the times when I switch between 2 Desktops.
Didn't happen with firefox closed though.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f76f6e5d7c0 (LWP 4798))]

Thread 3 (Thread 0x7f76c9ddb700 (LWP 4806)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f76f2f68e77 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f76f2f68ea9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f76ea299f8e in start_thread (arg=0x7f76c9ddb700) at pthread_create.c:311
#4  0x00007f76f6678e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f76c7f6a700 (LWP 4808)):
#0  0x00007f76f6671233 in select () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f76f1aac4f3 in qt_safe_select (nfds=23, fdread=0x7f76c0000ac8, fdwrite=0x7f76c0000d60, fdexcept=0x7f76c0000ff8, orig_timeout=0x0) at kernel/qcore_unix.cpp:83
#2  0x00007f76f1ab1499 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f76c0000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007f76f1ab1c82 in QEventDispatcherUNIX::processEvents (this=0x7f76c00008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#4  0x00007f76f1a7f38f in QEventLoop::processEvents (this=this@entry=0x7f76c7f69d90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f76f1a7f618 in QEventLoop::exec (this=0x7f76c7f69d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f76f1981410 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f76f1a60edf in QInotifyFileSystemWatcherEngine::run (this=0x253ec40) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f76f1983bec in QThreadPrivate::start (arg=0x253ec40) at thread/qthread_unix.cpp:338
#9  0x00007f76ea299f8e in start_thread (arg=0x7f76c7f6a700) at pthread_create.c:311
#10 0x00007f76f6678e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f76f6e5d7c0 (LWP 4798)):
[KCrash Handler]
#6  0x0000000000000071 in ?? ()
#7  0x00007f76f6a1d8ab in KWin::EffectsHandlerImpl::buildQuads (this=0x1ec6790, w=0x1d45780, quadList=...) at ../../kwin/effects.cpp:329
#8  0x00007f76f69ff3ac in KWin::Scene::Window::buildQuads (this=0x1e2ff60, force=<optimized out>) at ../../kwin/scene.cpp:621
#9  0x00007f76f6a1bb91 in KWin::EffectWindowImpl::buildQuads (this=<optimized out>, force=<optimized out>) at ../../kwin/effects.cpp:1582
#10 0x00007f76f69bd0a5 in KWin::Shadow::updateShadow (this=0x29f1c20) at ../../kwin/shadow.cpp:216
#11 0x00007f76f69fb71f in KWin::Toplevel::getShadow (this=0x1c52250) at ../../kwin/toplevel.cpp:346
#12 0x00007f76f69ba34a in KWin::Toplevel::propertyNotifyEvent (this=0x1c52250, e=<optimized out>) at ../../kwin/events.cpp:1667
#13 0x00007f76f69ba389 in KWin::Client::propertyNotifyEvent (this=0x1c52250, e=0x7fff621f3f60) at ../../kwin/events.cpp:827
#14 0x00007f76f69b9868 in KWin::Client::windowEvent (this=0x1c52250, e=e@entry=0x7fff621f3f60) at ../../kwin/events.cpp:598
#15 0x00007f76f69ba69b in KWin::Workspace::workspaceEvent (this=0x1ae15a0, e=0x7fff621f3f60) at ../../kwin/events.cpp:288
#16 0x00007f76f69af568 in KWin::Application::x11EventFilter (this=0x7fff621f44c0, e=0x7fff621f3f60) at ../../kwin/main.cpp:362
#17 0x00007f76f0e920cc in qt_x11EventFilter (ev=0x7fff621f3f60) at kernel/qapplication_x11.cpp:441
#18 qt_x11EventFilter (ev=0x7fff621f3f60) at kernel/qapplication_x11.cpp:429
#19 0x00007f76f0ea0170 in QApplication::x11ProcessEvent (this=0x7fff621f44c0, event=0x7fff621f3f60) at kernel/qapplication_x11.cpp:3458
#20 0x00007f76f0eccb39 in QEventDispatcherX11::processEvents (this=0x19f3ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0x00007f76f1a7f38f in QEventLoop::processEvents (this=this@entry=0x7fff621f41d0, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f76f1a7f618 in QEventLoop::exec (this=0x7fff621f41d0, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f76f1a84cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#24 0x00007f76f69af02a in kdemain (argc=3, argv=0x7fff621f4608) at ../../kwin/main.cpp:537
#25 0x00007f76f65a0ea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=3, ubp_av=0x7fff621f4608, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff621f45f8) at libc-start.c:260
#26 0x0000000000400701 in _start ()

This bug may be a duplicate of or related to bug 308201.

Possible duplicates by query: bug 315477, bug 315144, bug 313765, bug 311269, bug 308201.

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-04-14 12:51:56 UTC

*** This bug has been marked as a duplicate of bug 308201 ***