Bug 319255 - Crash after possible kde4 memory leak
Summary: Crash after possible kde4 memory leak
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-03 07:29 UTC by misel.mesnjak
Modified: 2013-05-03 08:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description misel.mesnjak 2013-05-03 07:29:17 UTC
Application: kwin (4.10.2)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-19-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:
I restarted the lighdm to again login in system and wanted to start an app with Alt+F2. It was after the whole night of beeing on and laptop lid closed (only screen off - not suspend or hibernate). Screen was corrupted and a restarted the lightdm on textual console (Ctrl+Alt+F1). I noticed that kde4 process took about 78% of my 16GB of RAM.

- Unusual behavior I noticed:
Corrupted screen prior to new logon system and trying to start launcher with Alt+F2

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb8451567c0 (LWP 3070))]

Thread 2 (Thread 0x7fb81bfff700 (LWP 3078)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb841269e77 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fb841269ea9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fb83859ff8e in start_thread (arg=0x7fb81bfff700) at pthread_create.c:311
#4  0x00007fb844979e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fb8451567c0 (LWP 3070)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fb844d1e8ab in KWin::EffectsHandlerImpl::buildQuads (this=0x1a9e8e0, w=0x1a9ea70, quadList=...) at ../../kwin/effects.cpp:329
#8  0x00007fb844d003ac in KWin::Scene::Window::buildQuads (this=0x1a9e830, force=<optimized out>) at ../../kwin/scene.cpp:621
#9  0x00007fb844d1cb91 in KWin::EffectWindowImpl::buildQuads (this=<optimized out>, force=<optimized out>) at ../../kwin/effects.cpp:1582
#10 0x00007fb844cbe0a5 in KWin::Shadow::updateShadow (this=0x1903140) at ../../kwin/shadow.cpp:216
#11 0x00007fb844cfc71f in KWin::Toplevel::getShadow (this=0x1baf6f0) at ../../kwin/toplevel.cpp:346
#12 0x00007fb844cbb34a in KWin::Toplevel::propertyNotifyEvent (this=this@entry=0x1baf6f0, e=e@entry=0x7fff426d4b40) at ../../kwin/events.cpp:1667
#13 0x00007fb844cbb389 in KWin::Client::propertyNotifyEvent (this=0x1baf6f0, e=0x7fff426d4b40) at ../../kwin/events.cpp:827
#14 0x00007fb844cba868 in KWin::Client::windowEvent (this=0x1baf6f0, e=e@entry=0x7fff426d4b40) at ../../kwin/events.cpp:598
#15 0x00007fb844cbb69b in KWin::Workspace::workspaceEvent (this=0x15bc910, e=e@entry=0x7fff426d4b40) at ../../kwin/events.cpp:288
#16 0x00007fb844cb0568 in KWin::Application::x11EventFilter (this=0x7fff426d50a0, e=0x7fff426d4b40) at ../../kwin/main.cpp:362
#17 0x00007fb83f1980cc in qt_x11EventFilter (ev=0x7fff426d4b40) at kernel/qapplication_x11.cpp:441
#18 qt_x11EventFilter (ev=0x7fff426d4b40) at kernel/qapplication_x11.cpp:429
#19 0x00007fb83f1a6170 in QApplication::x11ProcessEvent (this=0x7fff426d50a0, event=event@entry=0x7fff426d4b40) at kernel/qapplication_x11.cpp:3458
#20 0x00007fb83f1d2b39 in QEventDispatcherX11::processEvents (this=0x1482f20, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0x00007fb83fd8538f in QEventLoop::processEvents (this=this@entry=0x7fff426d4db0, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007fb83fd85618 in QEventLoop::exec (this=this@entry=0x7fff426d4db0, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007fb83fd8acf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#24 0x00007fb83f12affc in QApplication::exec () at kernel/qapplication.cpp:3828
#25 0x00007fb844cb002a in kdemain (argc=3, argv=0x7fff426d51e8) at ../../kwin/main.cpp:537
#26 0x00007fb8448a1ea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=3, ubp_av=0x7fff426d51e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff426d51d8) at libc-start.c:260
#27 0x0000000000400701 in _start ()

This bug may be a duplicate of or related to bug 299582.

Possible duplicates by query: bug 318734, bug 318328, bug 315477, bug 315144, bug 313765.

Reported using DrKonqi
Comment 1 Martin Flöser 2013-05-03 07:34:55 UTC

*** This bug has been marked as a duplicate of bug 308201 ***
Comment 2 Thomas Lübking 2013-05-03 07:36:25 UTC
can you please specify "kde process"? - what binary in particular?
Comment 3 misel.mesnjak 2013-05-03 08:02:55 UTC
I think it was this one:
3208     1  0 09:56 ?        00:00:00 kdeinit4: kded4 [kdeinit]
Comment 4 Thomas Lübking 2013-05-03 08:21:38 UTC
that's the daemon container

please record the output of
    qdbus org.kde.kded /kded loadedModules
Comment 5 misel.mesnjak 2013-05-03 08:32:12 UTC
Output>

misel@miselap:~$ qdbus org.kde.kded /kded loadedModules
networkstatus
bluedevil
remotedirnotify
ktouchpadenabler
obexftpdaemon
powerdevil
device_automounter
keyboard
kscreen
appmenu
favicons
networkmanagement
nepomuksearchmodule
khotkeys
dnssdwatcher
solidautoeject
kwrited
kmixd
freespacenotifier
desktopnotifier
ktimezoned
statusnotifierwatcher