Bug 313765 - kwin crashed when disconnecting external screen
Summary: kwin crashed when disconnecting external screen
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-23 14:33 UTC by franz.bergesund
Modified: 2013-01-23 14:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description franz.bergesund 2013-01-23 14:33:33 UTC
Application: kwin (4.9.98)
KDE Platform Version: 4.9.98
Qt Version: 4.8.3
Operating System: Linux 3.5.0-22-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
On Kubuntu 12.10, Qt: 4.8.3, KDE Development Platform: 4.9.98
I use Kscreen for display configurations

- What I was doing when the application crashed:
kwin crashed after disconnecting the external screen. I have used Kscreen only in the last few days and I don't recall other crashes 

- Unusual behavior I noticed:
afterwards all the windows of the open applications have the correct size but they are all moved rightward by about a forth of the screen widths

- Custom settings of the application:
external screen on top of the laptop one.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff901da77c0 (LWP 28502))]

Thread 3 (Thread 0x7ff8ea993700 (LWP 28510)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff912784cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007ff912784d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007ff90a262e9a in start_thread (arg=0x7ff8ea993700) at pthread_create.c:308
#4  0x00007ff915e8ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff8e79b5700 (LWP 29117)):
#0  0x00007ff915e88023 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007ff9112cf023 in qt_safe_select (nfds=22, fdread=0x7ff8e0000ac8, fdwrite=0x7ff8e0000d60, fdexcept=0x7ff8e0000ff8, orig_timeout=0x0) at kernel/qcore_unix.cpp:83
#2  0x00007ff9112d39e4 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7ff8e0000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007ff9112d4572 in QEventDispatcherUNIX::processEvents (this=0x7ff8e00008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007ff9112a22bf in QEventLoop::processEvents (this=this@entry=0x7ff8e79b4d80, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff9112a2548 in QEventLoop::exec (this=0x7ff8e79b4d80, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff9111a3b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007ff911284478 in QDnotifySignalThread::run (this=0x235a4d0) at io/qfilesystemwatcher_dnotify.cpp:179
#8  0x00007ff9111a6aec in QThreadPrivate::start (arg=0x235a4d0) at thread/qthread_unix.cpp:338
#9  0x00007ff90a262e9a in start_thread (arg=0x7ff8e79b5700) at pthread_create.c:308
#10 0x00007ff915e8ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff901da77c0 (LWP 28502)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007ff9162308cb in KWin::EffectsHandlerImpl::buildQuads (this=0x2608460, w=0x2b75180, quadList=...) at ../../kwin/effects.cpp:329
#8  0x00007ff916211f9c in KWin::Scene::Window::buildQuads (this=0x2b75040, force=<optimized out>) at ../../kwin/scene.cpp:621
#9  0x00007ff91622e941 in KWin::EffectWindowImpl::buildQuads (this=<optimized out>, force=<optimized out>) at ../../kwin/effects.cpp:1582
#10 0x00007ff9161cf045 in KWin::Shadow::updateShadow (this=0x245e080) at ../../kwin/shadow.cpp:216
#11 0x00007ff91620e71f in KWin::Toplevel::getShadow (this=0x1d45740) at ../../kwin/toplevel.cpp:346
#12 0x00007ff9161cd22a in KWin::Toplevel::propertyNotifyEvent (this=0x1d45740, e=<optimized out>) at ../../kwin/events.cpp:1667
#13 0x00007ff9161cd269 in KWin::Client::propertyNotifyEvent (this=0x1d45740, e=0x7fffe5e7abe0) at ../../kwin/events.cpp:827
#14 0x00007ff9161cc748 in KWin::Client::windowEvent (this=0x1d45740, e=0x7fffe5e7abe0) at ../../kwin/events.cpp:598
#15 0x00007ff9161cd57b in KWin::Workspace::workspaceEvent (this=0x177c870, e=0x7fffe5e7abe0) at ../../kwin/events.cpp:297
#16 0x00007ff9161bf748 in KWin::Application::x11EventFilter (this=0x7fffe5e7b140, e=0x7fffe5e7abe0) at ../../kwin/main.cpp:362
#17 0x00007ff9106b77bc in qt_x11EventFilter (ev=0x7fffe5e7abe0) at kernel/qapplication_x11.cpp:441
#18 qt_x11EventFilter (ev=0x7fffe5e7abe0) at kernel/qapplication_x11.cpp:429
#19 0x00007ff9106c77f0 in QApplication::x11ProcessEvent (this=0x7fffe5e7b140, event=0x7fffe5e7abe0) at kernel/qapplication_x11.cpp:3449
#20 0x00007ff9106f09d9 in QEventDispatcherX11::processEvents (this=0x1635400, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0x00007ff9112a22bf in QEventLoop::processEvents (this=this@entry=0x7fffe5e7ae50, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007ff9112a2548 in QEventLoop::exec (this=0x7fffe5e7ae50, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007ff9112a7708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#24 0x00007ff9161c1d9a in kdemain (argc=3, argv=0x7fffe5e7b288) at ../../kwin/main.cpp:537
#25 0x00007ff915dbc76d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=3, ubp_av=0x7fffe5e7b288, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffe5e7b278) at libc-start.c:226
#26 0x00000000004006d1 in _start ()

This bug may be a duplicate of or related to bug 308201.

Possible duplicates by query: bug 311269, bug 308201, bug 299582, bug 294451.

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-01-23 14:56:56 UTC

*** This bug has been marked as a duplicate of bug 308201 ***