Bug 311269 - KWin crashes when changing screen settings
Summary: KWin crashes when changing screen settings
Status: RESOLVED DUPLICATE of bug 308201
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-06 20:12 UTC by Nicolas Müller
Modified: 2012-12-06 20:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Müller 2012-12-06 20:12:30 UTC
Application: kwin (4.9.3)
KDE Platform Version: 4.9.3
Qt Version: 4.8.3
Operating System: Linux 3.6.6-3.fc18.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
I'm using a dual monitor environment and tried to turn one monitor off. I'm using the open source driver for NVIDIA.

The content of both screens was corrupted.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6db7033880 (LWP 1402))]

Thread 3 (Thread 0x7f6da27ba700 (LWP 1411)):
#0  0x00007f6dc96bc5e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6da80e11a3 in radeon_drm_cs_emit_ioctl () from /usr/lib64/dri/r600_dri.so
#2  0x00007f6dc96b8d15 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f6dc764f2cd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f6da1977700 (LWP 1412)):
#0  0x00007f6dc96bc5e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6dcb338a77 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /lib64/libQtScript.so.4
#2  0x00007f6dcb338aa9 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib64/libQtScript.so.4
#3  0x00007f6dc96b8d15 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6dc764f2cd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f6db7033880 (LWP 1402)):
[KCrash Handler]
#5  0x00007f6dce3e4605 in KWin::EffectsHandlerImpl::buildQuads(KWin::EffectWindow*, KWin::WindowQuadList&) () from /lib64/libkdeinit4_kwin.so
#6  0x00007f6dce3e460b in KWin::EffectsHandlerImpl::buildQuads(KWin::EffectWindow*, KWin::WindowQuadList&) () from /lib64/libkdeinit4_kwin.so
#7  0x00007f6dce3c76fc in KWin::Scene::Window::buildQuads(bool) const () from /lib64/libkdeinit4_kwin.so
#8  0x00007f6dce3e2531 in KWin::EffectWindowImpl::buildQuads(bool) const () from /lib64/libkdeinit4_kwin.so
#9  0x00007f6dce386e25 in KWin::Shadow::updateShadow() () from /lib64/libkdeinit4_kwin.so
#10 0x00007f6dce3c3c7f in KWin::Toplevel::getShadow() () from /lib64/libkdeinit4_kwin.so
#11 0x00007f6dce384ffa in KWin::Toplevel::propertyNotifyEvent(XPropertyEvent*) () from /lib64/libkdeinit4_kwin.so
#12 0x00007f6dce385039 in KWin::Client::propertyNotifyEvent(XPropertyEvent*) () from /lib64/libkdeinit4_kwin.so
#13 0x00007f6dce384538 in KWin::Client::windowEvent(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#14 0x00007f6dce385343 in KWin::Workspace::workspaceEvent(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#15 0x00007f6dce377718 in KWin::Application::x11EventFilter(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#16 0x00007f6dc8c4677c in qt_x11EventFilter(_XEvent*) () from /lib64/libQtGui.so.4
#17 0x00007f6dc8c53d9b in QApplication::x11ProcessEvent(_XEvent*) () from /lib64/libQtGui.so.4
#18 0x00007f6dc8c7b399 in QEventDispatcherX11::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
#19 0x00007f6dc9a43e2f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#20 0x00007f6dc9a440b8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#21 0x00007f6dc9a48ea8 in QCoreApplication::exec() () from /lib64/libQtCore.so.4
#22 0x00007f6dce379da4 in kdemain () from /lib64/libkdeinit4_kwin.so
#23 0x00007f6dc757ea05 in __libc_start_main () from /lib64/libc.so.6
#24 0x0000000000400941 in _start ()

This bug may be a duplicate of or related to bug 308201.

Possible duplicates by query: bug 308201, bug 299582, bug 294451.

Reported using DrKonqi
Comment 1 Thomas Lübking 2012-12-06 20:16:08 UTC
Technically "dupe", but:
> #1  0x00007f6da80e11a3 in radeon_drm_cs_emit_ioctl () from /usr/lib64/dri/r600_dri.so

There's sth. *severely* wrong because that's not nouveau and i doubt the radeon driver works with nvidia GPUs at all.

*** This bug has been marked as a duplicate of bug 308201 ***