Bug 308845 - Kmail crashes not everytime bu often
Summary: Kmail crashes not everytime bu often
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-23 03:56 UTC by Thomas Nitsch
Modified: 2012-10-24 00:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Nitsch 2012-10-23 03:56:56 UTC
Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.6-2.10-default i686
Distribution: "openSUSE 12.2 (i586)"

-- Information about the crash:
- What I was doing when the application crashed: Readein email. I was browsing between them.

- Custom settings of the application: Have downloaded files from the community repositories.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1765740 (LWP 14949))]

Thread 3 (Thread 0xb017bb40 (LWP 14953)):
#0  0xb7799430 in __kernel_vsyscall ()
#1  0xb5894a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5ebb21c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb387054d in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb387057f in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb5890e32 in start_thread () from /lib/libpthread.so.0
#6  0xb5ead8ee in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaf852b40 (LWP 14954)):
#0  0xb455c59b in ?? () from /usr/lib/libglib-2.0.so.0
#1  0xb455c878 in g_mutex_unlock () from /usr/lib/libglib-2.0.so.0
#2  0xb451c6e8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#3  0xb451cb90 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb451cc71 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6222a9f in QEventDispatcherGlib::processEvents (this=0xaef00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb61efa3c in QEventLoop::processEvents (this=this@entry=0xaf852278, flags=...) at kernel/qeventloop.cpp:149
#7  0xb61efd31 in QEventLoop::exec (this=0xaf852278, flags=...) at kernel/qeventloop.cpp:204
#8  0xb60dd93c in QThread::exec (this=this@entry=0x8e6a1f0) at thread/qthread.cpp:501
#9  0xb60dda9b in QThread::run (this=0x8e6a1f0) at thread/qthread.cpp:568
#10 0xb60e0d00 in QThreadPrivate::start (arg=0x8e6a1f0) at thread/qthread_unix.cpp:298
#11 0xb5890e32 in start_thread () from /lib/libpthread.so.0
#12 0xb5ead8ee in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb1765740 (LWP 14949)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x9dfb870, hm=<error reading variable: Cannot access memory at address 0x31>, sc=49, rp=<error reading variable: Cannot access memory at address 0x31>, pu=32, db=<error reading variable: Cannot access memory at address 0x31>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0xb5ac9911 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x9dfb870, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xae12e210) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0xb620297a in QMetaCallEvent::placeMetaCall (this=0xae12e550, object=0x9dfb870) at kernel/qobject.cpp:525
#9  0xb6206edb in QObject::event (this=0x9dfb870, e=0xae12e550) at kernel/qobject.cpp:1204
#10 0xb64a5aec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#11 0xb64aa5af in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#12 0xb7519201 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#13 0xb61f0c7e in QCoreApplication::notifyInternal (this=0xbfceec3c, receiver=0x9dfb870, event=0xae12e550) at kernel/qcoreapplication.cpp:876
#14 0xb61f49bd in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8b8a130) at kernel/qcoreapplication.cpp:1500
#16 0xb61f4c3c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#17 0xb6222904 in sendPostedEvents () at kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=0x8bc3ee0) at kernel/qeventdispatcher_glib.cpp:279
#19 0xb451c7f3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0xb451cb90 in ?? () from /usr/lib/libglib-2.0.so.0
#21 0xb451cc71 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#22 0xb6222a81 in QEventDispatcherGlib::processEvents (this=0x8b8d998, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0xb65571da in ?? () from /usr/lib/libQtGui.so.4
#24 0xb61efa3c in QEventLoop::processEvents (this=this@entry=0xbfceeb08, flags=...) at kernel/qeventloop.cpp:149
#25 0xb61efd31 in QEventLoop::exec (this=0xbfceeb08, flags=...) at kernel/qeventloop.cpp:204
#26 0xb61f4cea in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0xb64a3934 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#28 0x0804a59d in ?? ()
#29 0xb5ddc3d5 in __libc_start_main () from /lib/libc.so.6
#30 0x0804aa89 in _start ()

Possible duplicates by query: bug 304996, bug 304586, bug 303629, bug 303493, bug 303406.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-10-24 00:26:20 UTC

*** This bug has been marked as a duplicate of bug 286307 ***