Bug 303629 - Crashes when I try to open mails from groupon
Summary: Crashes when I try to open mails from groupon
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-16 20:02 UTC by Danjel Jungersen
Modified: 2012-07-16 20:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
source of a bad e-mail (60.32 KB, text/plain)
2012-07-16 20:16 UTC, Danjel Jungersen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Danjel Jungersen 2012-07-16 20:02:16 UTC
Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I click on the line with the offending e-mail.
Kmail crashes, every time.
I cannot provide a sample, unless I get help, since the program crashes as soon as I touch it...

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc9325df7c0 (LWP 3147))]

Thread 4 (Thread 0x7fc910290700 (LWP 3150)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc9248c3dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fc9248c3f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fc92d3ffe9a in start_thread (arg=0x7fc910290700) at pthread_create.c:308
#4  0x00007fc92f9304bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fc90f97f700 (LWP 3151)):
#0  0x00007fc9302bab75 in postEventSourcePrepare (s=0x7fc9080012d0, timeout=0x7fc90f97ec5c) at kernel/qeventdispatcher_glib.cpp:255
#1  0x00007fc9281cf846 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc9281cff5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc9281d0164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc9302bb426 in QEventDispatcherGlib::processEvents (this=0x7fc9080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fc93028ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fc93028aed7 in QEventLoop::exec (this=0x7fc90f97edc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fc930189fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fc93018cfcb in QThreadPrivate::start (arg=0x179af30) at thread/qthread_unix.cpp:298
#9  0x00007fc92d3ffe9a in start_thread (arg=0x7fc90f97f700) at pthread_create.c:308
#10 0x00007fc92f9304bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc90cff4700 (LWP 3154)):
#0  0x00007fc92820b5d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fc9281cf83b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc9281cff5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc9281d0164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc9302bb426 in QEventDispatcherGlib::processEvents (this=0x7fc8c00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fc93028ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fc93028aed7 in QEventLoop::exec (this=0x7fc90cff3d90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fc930189fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fc93026a9ff in QInotifyFileSystemWatcherEngine::run (this=0x1c3bbd0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fc93018cfcb in QThreadPrivate::start (arg=0x1c3bbd0) at thread/qthread_unix.cpp:298
#10 0x00007fc92d3ffe9a in start_thread (arg=0x7fc90cff4700) at pthread_create.c:308
#11 0x00007fc92f9304bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc9325df7c0 (LWP 3147)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff36758700) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff36758a10) at access/qabstractnetworkcache.cpp:240
#8  0x00007fc92e8d87bc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x2bfad00, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007fc92e8d9f14 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2bfad00, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007fc92e965709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2bfad00, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007fc9302a5446 in QObject::event (this=0x2bfad00, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x00007fc9307ae894 in notify_helper (e=0x7fc8b4004ec0, receiver=0x2bfad00, this=0x124f680) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x124f680, receiver=0x2bfad00, e=0x7fc8b4004ec0) at kernel/qapplication.cpp:4531
#14 0x00007fc9307b3713 in QApplication::notify (this=0x7fff36759510, receiver=0x2bfad00, e=0x7fc8b4004ec0) at kernel/qapplication.cpp:4420
#15 0x00007fc931fef9e6 in KApplication::notify (this=0x7fff36759510, receiver=0x2bfad00, event=0x7fc8b4004ec0) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007fc93028be9c in QCoreApplication::notifyInternal (this=0x7fff36759510, receiver=0x2bfad00, event=0x7fc8b4004ec0) at kernel/qcoreapplication.cpp:876
#17 0x00007fc93028fc6a in sendEvent (event=0x7fc8b4004ec0, receiver=0x2bfad00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x11df220) at kernel/qcoreapplication.cpp:1500
#19 0x00007fc9302baf93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007fc9281cfd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fc9281d00a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fc9281d0164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fc9302bb3bf in QEventDispatcherGlib::processEvents (this=0x11e0b00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007fc930856d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fc93028ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007fc93028aed7 in QEventLoop::exec (this=0x7fff367593f0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007fc93028ff67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000402bd3 in ?? ()
#30 0x00007fc92f85f76d in __libc_start_main (main=0x4021a0, argc=3, ubp_av=0x7fff36759968, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff36759958) at libc-start.c:226
#31 0x0000000000403095 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 303406, bug 295746, bug 291499, bug 289946, bug 289179.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-16 20:07:37 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 2 Danjel Jungersen 2012-07-16 20:16:11 UTC
Created attachment 72567 [details]
source of a bad e-mail