Bug 303493 - Accesing Gmail IMAP inbox
Summary: Accesing Gmail IMAP inbox
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-13 18:25 UTC by Rudi
Modified: 2012-07-13 21:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rudi 2012-07-13 18:25:29 UTC
Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.2
Operating System: Linux 3.4.4-5.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:
Reading new emails attached from my Gmail IMAP account.

- Unusual behavior I noticed:
The network suddenly fails meaning no webpage loads, emails do not load and messenger does not connect To fix it the network must be disabled and reenabled or log out and log back in KDE. Also recently a few times the system froze after login.
Applications that start at login: KTorrent, Kmail, KAlarm.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fb1eccf9880 (LWP 18493))]

Thread 7 (Thread 0x7fb1df478700 (LWP 18501)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x0000003ed741677d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3ed7e00980) at wtf/FastMalloc.cpp:2495
#2  0x0000003ed7416889 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x0000003fcae07d14 in start_thread (arg=0x7fb1df478700) at pthread_create.c:309
#4  0x0000003fcaaf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7fb1deb77700 (LWP 18502)):
#0  0x0000003fcaae8eef in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003fca6479b4 in g_main_context_poll (n_fds=1, fds=0x7fb1d80029c0, timeout=7382, context=0x7fb1d80009a0, priority=<optimized out>) at gmain.c:3440
#2  g_main_context_iterate (context=context@entry=0x7fb1d80009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3141
#3  0x0000003fca647ad4 in g_main_context_iteration (context=0x7fb1d80009a0, may_block=1) at gmain.c:3207
#4  0x0000003fd43a4506 in QEventDispatcherGlib::processEvents (this=0x7fb1d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003fd437513f in QEventLoop::processEvents (this=this@entry=0x7fb1deb76d20, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003fd43753c8 in QEventLoop::exec (this=0x7fb1deb76d20, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003fd4278650 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003fd427b5eb in QThreadPrivate::start (arg=0x16e28e0) at thread/qthread_unix.cpp:307
#9  0x0000003fcae07d14 in start_thread (arg=0x7fb1deb77700) at pthread_create.c:309
#10 0x0000003fcaaf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7fb197df0700 (LWP 19899)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x0000003fd427ba47 in wait (time=30000, this=0x1787500) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x17874a8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003fd426f36f in QThreadPoolThread::run (this=0x179a4a0) at concurrent/qthreadpool.cpp:141
#4  0x0000003fd427b5eb in QThreadPrivate::start (arg=0x179a4a0) at thread/qthread_unix.cpp:307
#5  0x0000003fcae07d14 in start_thread (arg=0x7fb197df0700) at pthread_create.c:309
#6  0x0000003fcaaf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fb1959c5700 (LWP 19904)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x0000003fd427ba47 in wait (time=30000, this=0x7fb190006440) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb1900063e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003fd426f36f in QThreadPoolThread::run (this=0x7fb1900066f0) at concurrent/qthreadpool.cpp:141
#4  0x0000003fd427b5eb in QThreadPrivate::start (arg=0x7fb1900066f0) at thread/qthread_unix.cpp:307
#5  0x0000003fcae07d14 in start_thread (arg=0x7fb1959c5700) at pthread_create.c:309
#6  0x0000003fcaaf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fb1951c4700 (LWP 19905)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x0000003fd427ba47 in wait (time=30000, this=0x7fb190006440) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb1900063e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003fd426f36f in QThreadPoolThread::run (this=0x7fb19000a890) at concurrent/qthreadpool.cpp:141
#4  0x0000003fd427b5eb in QThreadPrivate::start (arg=0x7fb19000a890) at thread/qthread_unix.cpp:307
#5  0x0000003fcae07d14 in start_thread (arg=0x7fb1951c4700) at pthread_create.c:309
#6  0x0000003fcaaf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fb1dce5a700 (LWP 19911)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x0000003fd427ba47 in wait (time=30000, this=0x1d734b0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1d748e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003fd426f36f in QThreadPoolThread::run (this=0x1d731e0) at concurrent/qthreadpool.cpp:141
#4  0x0000003fd427b5eb in QThreadPrivate::start (arg=0x1d731e0) at thread/qthread_unix.cpp:307
#5  0x0000003fcae07d14 in start_thread (arg=0x7fb1dce5a700) at pthread_create.c:309
#6  0x0000003fcaaf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fb1eccf9880 (LWP 18493)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x310d0b0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#7  0x0000003fd6ee8b8a in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x310d0b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:90
#8  0x0000003fd438acee in QObject::event (this=0x310d0b0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x0000003fd77ca37c in QApplicationPrivate::notify_helper (this=this@entry=0x1299d50, receiver=receiver@entry=0x310d0b0, e=e@entry=0x7fb17c00af60) at kernel/qapplication.cpp:4551
#10 0x0000003fd77ce7fa in QApplication::notify (this=0x7fff2cad5240, receiver=0x310d0b0, e=0x7fb17c00af60) at kernel/qapplication.cpp:4412
#11 0x0000003fd9246756 in KApplication::notify (this=0x7fff2cad5240, receiver=0x310d0b0, event=0x7fb17c00af60) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#12 0x0000003fd43763ee in QCoreApplication::notifyInternal (this=0x7fff2cad5240, receiver=receiver@entry=0x310d0b0, event=event@entry=0x7fb17c00af60) at kernel/qcoreapplication.cpp:915
#13 0x0000003fd4379ea1 in sendEvent (event=0x7fb17c00af60, receiver=0x310d0b0) at kernel/qcoreapplication.h:231
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x123e210) at kernel/qcoreapplication.cpp:1539
#15 0x0000003fd43a4353 in sendPostedEvents () at kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=s@entry=0x129ac00) at kernel/qeventdispatcher_glib.cpp:279
#17 0x0000003fca6476e5 in g_main_dispatch (context=0x129d000) at gmain.c:2539
#18 g_main_context_dispatch (context=context@entry=0x129d000) at gmain.c:3075
#19 0x0000003fca647a18 in g_main_context_iterate (context=context@entry=0x129d000, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#20 0x0000003fca647ad4 in g_main_context_iteration (context=0x129d000, may_block=1) at gmain.c:3207
#21 0x0000003fd43a44e6 in QEventDispatcherGlib::processEvents (this=0x123faf0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x0000003fd786a2ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#23 0x0000003fd437513f in QEventLoop::processEvents (this=this@entry=0x7fff2cad4ee0, flags=...) at kernel/qeventloop.cpp:149
#24 0x0000003fd43753c8 in QEventLoop::exec (this=0x7fff2cad4ee0, flags=...) at kernel/qeventloop.cpp:204
#25 0x0000003fd437a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#26 0x0000000000402d19 in ?? ()
#27 0x0000003fcaa21735 in __libc_start_main (main=0x402350, argc=3, ubp_av=0x7fff2cad5438, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff2cad5428) at libc-start.c:226
#28 0x00000000004031a5 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 303406, bug 303317, bug 303050, bug 302823, bug 302381.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-07-13 21:27:17 UTC
Fixed in 4.8.5