Bug 304586 - Crash when i click on "Message brut" to look at in in HTML
Summary: Crash when i click on "Message brut" to look at in in HTML
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-05 02:01 UTC by Patrick Carabin
Modified: 2012-08-05 14:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.22 KB, text/plain)
2012-08-05 13:59 UTC, Patrick Carabin
Details
New crash information added by DrKonqi (5.22 KB, text/plain)
2012-08-05 13:59 UTC, Patrick Carabin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Carabin 2012-08-05 02:01:02 UTC
Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I clicked on "messga brut" near a message to get the HTML. I look then to the following messages ( a few times ) and I got these automatically in HTML.
THEN, the following one was macked "message brut" instead of HTML and when i clicked to change it, the dump occured.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1491740 (LWP 3774))]

Thread 4 (Thread 0xae2a0b40 (LWP 4260)):
#0  0xb776f424 in __kernel_vsyscall ()
#1  0xb586596b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb5ecd3dc in __pthread_cond_wait (cond=0xb3fa4a30, mutex=0xb3fa4a18) at forward.c:139
#3  0xb3873263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb387337f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb5861d4c in start_thread (arg=0xae2a0b40) at pthread_create.c:308
#6  0xb5ebface in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xad977b40 (LWP 4261)):
#0  0xb449d8ba in __i686.get_pc_thunk.bx () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb44a15f4 in g_ptr_array_set_size (farray=0x9184698, length=0) at /build/buildd/glib2.0-2.32.3/./glib/garray.c:1113
#2  0xb44ce726 in g_main_context_prepare (context=0xad0004e0, priority=0xad977148) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2807
#3  0xb44cefaf in g_main_context_iterate (dispatch=1, block=1, context=0xad0004e0, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3126
#4  g_main_context_iterate (context=0xad0004e0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#5  0xb44cf201 in g_main_context_iteration (context=0xad0004e0, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#6  0xb622d8e7 in QEventDispatcherGlib::processEvents (this=0xad000468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb61f950d in QEventLoop::processEvents (this=0xad977270, flags=...) at kernel/qeventloop.cpp:149
#8  0xb61f97a9 in QEventLoop::exec (this=0xad977270, flags=...) at kernel/qeventloop.cpp:204
#9  0xb60e294c in QThread::exec (this=0x959b7e8) at thread/qthread.cpp:501
#10 0xb60e2a3b in QThread::run (this=0x959b7e8) at thread/qthread.cpp:568
#11 0xb60e5de0 in QThreadPrivate::start (arg=0x959b7e8) at thread/qthread_unix.cpp:298
#12 0xb5861d4c in start_thread (arg=0xad977b40) at pthread_create.c:308
#13 0xb5ebface in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xacb4eb40 (LWP 6142)):
#0  0xb5864d14 in __pthread_mutex_unlock (mutex=0xac205358) at pthread_mutex_unlock.c:290
#1  0xb5ecd634 in pthread_mutex_unlock (mutex=0xac205358) at forward.c:184
#2  0xb450e410 in g_mutex_unlock (mutex=0xac2051f8) at /build/buildd/glib2.0-2.32.3/./glib/gthread-posix.c:227
#3  0xb44ceb76 in g_main_context_check (context=0xac2051f8, max_priority=2147483647, fds=0xac205450, n_fds=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3021
#4  0xb44cf042 in g_main_context_iterate (dispatch=1, block=-1269970352, context=0xac2051f8, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3143
#5  g_main_context_iterate (context=0xac2051f8, block=-1269970352, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#6  0xb44cf201 in g_main_context_iteration (context=0xac2051f8, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#7  0xb622d8e7 in QEventDispatcherGlib::processEvents (this=0xac205320, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0xb61f950d in QEventLoop::processEvents (this=0xacb4e240, flags=...) at kernel/qeventloop.cpp:149
#9  0xb61f97a9 in QEventLoop::exec (this=0xacb4e240, flags=...) at kernel/qeventloop.cpp:204
#10 0xb60e294c in QThread::exec (this=0x9a87440) at thread/qthread.cpp:501
#11 0xb61d6b5d in QInotifyFileSystemWatcherEngine::run (this=0x9a87440) at io/qfilesystemwatcher_inotify.cpp:248
#12 0xb60e5de0 in QThreadPrivate::start (arg=0x9a87440) at thread/qthread_unix.cpp:298
#13 0xb5861d4c in start_thread (arg=0xacb4eb40) at pthread_create.c:308
#14 0xb5ebface in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb1491740 (LWP 3774)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x9e43a28, hm=<error reading variable: Cannot access memory at address 0x31>, sc=49, rp=<error reading variable: Cannot access memory at address 0x31>, pu=112, db=<error reading variable: Cannot access memory at address 0x31>, contentLength=-1246727748) at access/qnetworkaccesshttpbackend.cpp:827
#8  0xb5b0037d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x9e43a28, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xa84d1d28) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0xb620cc01 in QMetaCallEvent::placeMetaCall (this=0xa84d69f8, object=0x9e43a28) at kernel/qobject.cpp:525
#10 0xb6215c7b in QObject::event (this=0x9e43a28, e=0xa84d69f8) at kernel/qobject.cpp:1195
#11 0xb6495ed4 in notify_helper (e=0xa84d69f8, receiver=0x9e43a28, this=0x9182b40) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x9182b40, receiver=0x9e43a28, e=0xa84d69f8) at kernel/qapplication.cpp:4531
#13 0xb649b30d in QApplication::notify (this=0xa84d69f8, receiver=0x9e43a28, e=0xa84d69f8) at kernel/qapplication.cpp:4288
#14 0xb74f8401 in KApplication::notify (this=0xbfcc787c, receiver=0x9e43a28, event=0xa84d69f8) at ../../kdeui/kernel/kapplication.cpp:311
#15 0xb61fa97e in QCoreApplication::notifyInternal (this=0xbfcc787c, receiver=0x9e43a28, event=0xa84d69f8) at kernel/qcoreapplication.cpp:876
#16 0xb61fead8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9137150) at kernel/qcoreapplication.cpp:1500
#18 0xb61fee0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0xb622d494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x9178568) at kernel/qeventdispatcher_glib.cpp:279
#21 0xb44ced86 in g_main_dispatch (context=0x9182670) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2539
#22 g_main_context_dispatch (context=0x9182670) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3075
#23 0xb44cf125 in g_main_context_iterate (dispatch=1, block=-1269970352, context=0x9182670, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3146
#24 g_main_context_iterate (context=0x9182670, block=-1269970352, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#25 0xb44cf201 in g_main_context_iteration (context=0x9182670, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#26 0xb622d887 in QEventDispatcherGlib::processEvents (this=0x9178910, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0xb654eaaa in QGuiEventDispatcherGlib::processEvents (this=0x9178910, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0xb61f950d in QEventLoop::processEvents (this=0xbfcc77a4, flags=...) at kernel/qeventloop.cpp:149
#29 0xb61f97a9 in QEventLoop::exec (this=0xbfcc77a4, flags=...) at kernel/qeventloop.cpp:204
#30 0xb61feeba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#31 0xb6493a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#32 0x0804a266 in main (argc=<error reading variable: Cannot access memory at address 0x3>, argv=<error reading variable: Cannot access memory at address 0x7>) at ../../kmail/main.cpp:145

Possible duplicates by query: bug 303629, bug 303493, bug 303406, bug 303317, bug 303050.

Reported using DrKonqi
Comment 1 Patrick Carabin 2012-08-05 13:59:29 UTC
Created attachment 72970 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.1

- What I was doing when the application crashed:
after the bug 304586, i restarted  kmail, and when i tried this ( other ) message, a got a dump. I assume they are linked?

-- Backtrace (Reduced):
#8  QSharedDataPointer (o=..., this=0xbfdae948) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbfdae948, other=...) at access/qabstractnetworkcache.cpp:137
#10 0xb5aa6a4f in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xb16b8c0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0xb5aa827e in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xb16b8c0, hm=..., sc=-1236254775, rp=..., pu=255, db=..., contentLength=-5353546593896078287) at access/qnetworkaccesshttpbackend.cpp:828
[...]
Comment 2 Patrick Carabin 2012-08-05 13:59:29 UTC
Created attachment 72971 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.1

- What I was doing when the application crashed:
after the bug 304586, i restarted  kmail, and when i tried this ( other ) message, a got a dump. I assume they are linked?

-- Backtrace (Reduced):
#8  QSharedDataPointer (o=..., this=0xbfdae948) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbfdae948, other=...) at access/qabstractnetworkcache.cpp:137
#10 0xb5aa6a4f in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xb16b8c0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0xb5aa827e in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xb16b8c0, hm=..., sc=-1236254775, rp=..., pu=255, db=..., contentLength=-5353546593896078287) at access/qnetworkaccesshttpbackend.cpp:828
[...]
Comment 3 Jekyll Wu 2012-08-05 14:59:13 UTC

*** This bug has been marked as a duplicate of bug 286307 ***