Bug 304996 - kmail crashed whilst deleting multiple IMAP messages from gmail
Summary: kmail crashed whilst deleting multiple IMAP messages from gmail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-11 22:55 UTC by Russ Hay
Modified: 2012-08-12 00:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Hay 2012-08-11 22:55:36 UTC
Application: kmail (4.10 pre)
KDE Platform Version: 4.8.95 (4.8.95) "release 1"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Kmail crashes immediately after deleting multiple messages from a gmail IMAP account.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6af66cd780 (LWP 4613))]

Thread 10 (Thread 0x7f6ad82f1700 (LWP 4712)):
#0  0x00007f6af17f6e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6ae7c09c12 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f6ae85a81a0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007f6ae7c09c49 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f6ad79d8700 (LWP 4713)):
#0  0x00007f6af17f611f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f6aeb93e1fa in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6aeb93eb02 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6aeb93efa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f6af504ce36 in QEventDispatcherGlib::processEvents (this=0x7f6ad00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f6af501c842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6af501ca97 in QEventLoop::exec (this=0x7f6ad79d7e00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f6af4f1c5f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0xaba420) at thread/qthread_unix.cpp:307
#9  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f6ad5ebd700 (LWP 7306)):
#0  0x00007f6af17f71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6af4f1fa8f in wait (time=30000, this=0x1701150) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1c760d8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6af4f12e9f in QThreadPoolThread::run (this=0x1779ba0) at concurrent/qthreadpool.cpp:141
#4  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0x1779ba0) at thread/qthread_unix.cpp:307
#5  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f6a8f771700 (LWP 7322)):
#0  0x00007f6af17f71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6af4f1fa8f in wait (time=30000, this=0xda9660) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xda9608, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6af4f12e9f in QThreadPoolThread::run (this=0xdbdb10) at concurrent/qthreadpool.cpp:141
#4  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0xdbdb10) at thread/qthread_unix.cpp:307
#5  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f6a8e809700 (LWP 7336)):
#0  0x00007f6af17f71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6af4f1fa8f in wait (time=30000, this=0x7f6a840061c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a84006168, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6af4f12e9f in QThreadPoolThread::run (this=0x7f6a84006490) at concurrent/qthreadpool.cpp:141
#4  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0x7f6a84006490) at thread/qthread_unix.cpp:307
#5  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f6a8e008700 (LWP 7338)):
#0  0x00007f6af17f71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6af4f1fa8f in wait (time=30000, this=0x7f6a840061c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a84006168, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6af4f12e9f in QThreadPoolThread::run (this=0x7f6a84009e60) at concurrent/qthreadpool.cpp:141
#4  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0x7f6a84009e60) at thread/qthread_unix.cpp:307
#5  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f6a8d670700 (LWP 7369)):
#0  0x00007f6af17f71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6af4f1fa8f in wait (time=30000, this=0x7f6a840061c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a84006168, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6af4f12e9f in QThreadPoolThread::run (this=0x7f6a84014ff0) at concurrent/qthreadpool.cpp:141
#4  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0x7f6a84014ff0) at thread/qthread_unix.cpp:307
#5  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f6a8cbd8700 (LWP 7385)):
#0  0x00007f6af17f71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6af4f1fa8f in wait (time=30000, this=0x7f6a840061c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a84006168, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6af4f12e9f in QThreadPoolThread::run (this=0x7f6a84005b40) at concurrent/qthreadpool.cpp:141
#4  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0x7f6a84005b40) at thread/qthread_unix.cpp:307
#5  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f6a73fff700 (LWP 7387)):
#0  0x00007f6af17f71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6af4f1fa8f in wait (time=30000, this=0x7f6a840061c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a84006168, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6af4f12e9f in QThreadPoolThread::run (this=0x7f6a8400cd80) at concurrent/qthreadpool.cpp:141
#4  0x00007f6af4f1f61b in QThreadPrivate::start (arg=0x7f6a8400cd80) at thread/qthread_unix.cpp:307
#5  0x00007f6af17f2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6af39ee10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f6af66cd780 (LWP 4613)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x23a8920, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#7  0x00007f6af2a3e509 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x23a8920, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f6af5036e06 in QObject::event (this=0x23a8920, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f6af43a0fe4 in notify_helper (e=0x7f6a840008c0, receiver=0x23a8920, this=0x6b32d0) at kernel/qapplication.cpp:4551
#10 QApplicationPrivate::notify_helper (this=0x6b32d0, receiver=0x23a8920, e=0x7f6a840008c0) at kernel/qapplication.cpp:4523
#11 0x00007f6af43a5db3 in QApplication::notify (this=0x7fffa71f0800, receiver=0x23a8920, e=0x7f6a840008c0) at kernel/qapplication.cpp:4412
#12 0x00007f6af60e57b6 in KApplication::notify (this=0x7fffa71f0800, receiver=0x23a8920, event=0x7f6a840008c0) at /usr/src/debug/kdelibs-4.8.95_20120629/kdeui/kernel/kapplication.cpp:311
#13 0x00007f6af501dd0c in QCoreApplication::notifyInternal (this=0x7fffa71f0800, receiver=0x23a8920, event=0x7f6a840008c0) at kernel/qcoreapplication.cpp:915
#14 0x00007f6af50215ba in sendEvent (event=0x7f6a840008c0, receiver=0x23a8920) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b740) at kernel/qcoreapplication.cpp:1539
#16 0x00007f6af504c9a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x68c380) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f6aeb93e5dd in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f6aeb93edd8 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f6aeb93efa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f6af504cdcf in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f6af444469e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f6af501c842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f6af501ca97 in QEventLoop::exec (this=0x7fffa71f06d0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f6af50218b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#26 0x0000000000402df3 in ?? ()
#27 0x00007f6af393423d in __libc_start_main () from /lib64/libc.so.6
#28 0x00000000004032d5 in _start ()

Possible duplicates by query: bug 304586, bug 303629, bug 303493, bug 303406, bug 303317.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-12 00:53:32 UTC

*** This bug has been marked as a duplicate of bug 286307 ***