Bug 303406 - Kmail crashes when attempting to view Gmail IMAP Inbox
Summary: Kmail crashes when attempting to view Gmail IMAP Inbox
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-12 12:55 UTC by benedict.soares
Modified: 2012-07-12 13:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description benedict.soares 2012-07-12 12:55:46 UTC
Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Before the crash I was viewing messages in a different IMAP Inbox.
Clicking on the Inbox icon for Gmail causes an instant crash.
This happens roughly once a day when being used all working day.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f46647347c0 (LWP 2226))]

Thread 5 (Thread 0x7f4642383700 (LWP 2547)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4656a17dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f4656a17f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f465f553e9a in start_thread (arg=0x7f4642383700) at pthread_create.c:308
#4  0x00007f4661a844bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f4641a82700 (LWP 2548)):
#0  0x00007f4661a78b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f465a324036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f465a324164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f466240f426 in QEventDispatcherGlib::processEvents (this=0x7f463c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f46623dec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f46623deed7 in QEventLoop::exec (this=0x7f4641a81dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f46622ddfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f46622e0fcb in QThreadPrivate::start (arg=0x16b3130) at thread/qthread_unix.cpp:298
#8  0x00007f465f553e9a in start_thread (arg=0x7f4641a82700) at pthread_create.c:308
#9  0x00007f4661a844bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f45fa91e700 (LWP 2563)):
#0  0x00007fff7d3ec8de in ?? ()
#1  0x00007f46593a115d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f4662337bb4 in do_gettime (frac=0x7f45fa91db58, sec=0x7f45fa91db50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f466240fb8d in QTimerInfoList::updateCurrentTime (this=0x7f45ec002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f466240fec3 in QTimerInfoList::timerWait (this=0x7f45ec002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f466240e97c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f45fa91dc2c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f466240ea25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f465a323846 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f465a323f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f465a324164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f466240f426 in QEventDispatcherGlib::processEvents (this=0x7f45ec0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f46623dec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f46623deed7 in QEventLoop::exec (this=0x7f45fa91dd90, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f46622ddfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f46623be9ff in QInotifyFileSystemWatcherEngine::run (this=0x1989ad0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f46622e0fcb in QThreadPrivate::start (arg=0x1989ad0) at thread/qthread_unix.cpp:298
#17 0x00007f465f553e9a in start_thread (arg=0x7f45fa91e700) at pthread_create.c:308
#18 0x00007f4661a844bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f45f9f0e700 (LWP 5476)):
#0  0x00007f4661a78b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f465a324036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f465a324164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f466240f426 in QEventDispatcherGlib::processEvents (this=0x7f45f0314db0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f46623dec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f46623deed7 in QEventLoop::exec (this=0x7f45f9f0dd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f46622ddfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f46623be9ff in QInotifyFileSystemWatcherEngine::run (this=0x87c70a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f46622e0fcb in QThreadPrivate::start (arg=0x87c70a0) at thread/qthread_unix.cpp:298
#9  0x00007f465f553e9a in start_thread (arg=0x7f45f9f0e700) at pthread_create.c:308
#10 0x00007f4661a844bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f46647347c0 (LWP 2226)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff7d302d70) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff7d303080) at access/qabstractnetworkcache.cpp:240
#8  0x00007f4660a2c7bc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x7f32b50, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007f4660a2df14 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x7f32b50, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007f4660ab9709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x7f32b50, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007f46623f9446 in QObject::event (this=0x7f32b50, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x00007f4662902894 in notify_helper (e=0x7f45cc008480, receiver=0x7f32b50, this=0x11bf390) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x11bf390, receiver=0x7f32b50, e=0x7f45cc008480) at kernel/qapplication.cpp:4531
#14 0x00007f4662907713 in QApplication::notify (this=0x7fff7d303b80, receiver=0x7f32b50, e=0x7f45cc008480) at kernel/qapplication.cpp:4420
#15 0x00007f46641439e6 in KApplication::notify (this=0x7fff7d303b80, receiver=0x7f32b50, event=0x7f45cc008480) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007f46623dfe9c in QCoreApplication::notifyInternal (this=0x7fff7d303b80, receiver=0x7f32b50, event=0x7f45cc008480) at kernel/qcoreapplication.cpp:876
#17 0x00007f46623e3c6a in sendEvent (event=0x7f45cc008480, receiver=0x7f32b50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x116b220) at kernel/qcoreapplication.cpp:1500
#19 0x00007f466240ef93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007f465a323d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f465a3240a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f465a324164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f466240f3bf in QEventDispatcherGlib::processEvents (this=0x116cb00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f46629aad5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f46623dec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f46623deed7 in QEventLoop::exec (this=0x7fff7d303a60, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f46623e3f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000402bd3 in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:145

Possible duplicates by query: bug 295746, bug 291499, bug 289946, bug 289179, bug 286307.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-12 13:10:04 UTC

*** This bug has been marked as a duplicate of bug 286307 ***