Bug 305532 - KMail crashes when selecting large amount of emails to delete
Summary: KMail crashes when selecting large amount of emails to delete
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-21 03:55 UTC by Graeme.McGeorge
Modified: 2012-08-21 04:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graeme.McGeorge 2012-08-21 03:55:17 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic i686
Distribution: Linux Mint 13 Maya

-- Information about the crash:
- What I was doing when the application crashed: I selected 157 emails in the Deleted Items when KMail crashed

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7702980 (LWP 2328))]

Thread 3 (Thread 0xb5876b40 (LWP 2329)):
#0  0x00425416 in __kernel_vsyscall ()
#1  0x00dac96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x01a7a3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x057ea263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0x057ea37f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0x00da8d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x01a6cace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb4f55b40 (LWP 2330)):
#0  0x00425416 in __kernel_vsyscall ()
#1  0x01a5e380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x02227a7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0221a0ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0221a201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00a198e7 in QEventDispatcherGlib::processEvents (this=0xb4600468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x009e550d in QEventLoop::processEvents (this=0xb4f55270, flags=...) at kernel/qeventloop.cpp:149
#7  0x009e57a9 in QEventLoop::exec (this=0xb4f55270, flags=...) at kernel/qeventloop.cpp:204
#8  0x008ce94c in QThread::exec (this=0x9cea920) at thread/qthread.cpp:501
#9  0x008cea3b in QThread::run (this=0x9cea920) at thread/qthread.cpp:568
#10 0x008d1de0 in QThreadPrivate::start (arg=0x9cea920) at thread/qthread_unix.cpp:298
#11 0x00da8d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x01a6cace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7702980 (LWP 2328)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xb49c128, hm=<error reading variable: Cannot access memory at address 0x31>, sc=49, rp=<error reading variable: Cannot access memory at address 0x31>, pu=92, db=<error reading variable: Cannot access memory at address 0x31>, contentLength=-4259806788) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x0218137d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xb49c128, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xb2f1080) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x009f8c01 in QMetaCallEvent::placeMetaCall (this=0xb381120, object=0xb49c128) at kernel/qobject.cpp:525
#10 0x00a01c7b in QObject::event (this=0xb49c128, e=0xb381120) at kernel/qobject.cpp:1195
#11 0x00fe9ed4 in notify_helper (e=0xb381120, receiver=0xb49c128, this=0x9b47ad8) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x9b47ad8, receiver=0xb49c128, e=0xb381120) at kernel/qapplication.cpp:4531
#13 0x00fef30d in QApplication::notify (this=0xb381120, receiver=0xb49c128, e=0xb381120) at kernel/qapplication.cpp:4288
#14 0x00613401 in KApplication::notify (this=0xbff62264, receiver=0xb49c128, event=0xb381120) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x009e697e in QCoreApplication::notifyInternal (this=0xbff62264, receiver=0xb49c128, event=0xb381120) at kernel/qcoreapplication.cpp:876
#16 0x009eaad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9b1fab8) at kernel/qcoreapplication.cpp:1500
#18 0x009eae0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0x00a19494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x9b46748) at kernel/qeventdispatcher_glib.cpp:279
#21 0x02219d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0x0221a125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x0221a201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0x00a19887 in QEventDispatcherGlib::processEvents (this=0x9b20800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x010a2aaa in QGuiEventDispatcherGlib::processEvents (this=0x9b20800, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x009e550d in QEventLoop::processEvents (this=0xbff621c4, flags=...) at kernel/qeventloop.cpp:149
#27 0x009e57a9 in QEventLoop::exec (this=0xbff621c4, flags=...) at kernel/qeventloop.cpp:204
#28 0x009eaeba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x00fe7a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#30 0x0804ac91 in main (argc=<error reading variable: Cannot access memory at address 0x3>, argv=<error reading variable: Cannot access memory at address 0x7>) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 305201, bug 303896, bug 303882, bug 303694, bug 303295.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-21 04:24:46 UTC

*** This bug has been marked as a duplicate of bug 286307 ***