Bug 303896 - Kmail 2 crashes when reading emails fast
Summary: Kmail 2 crashes when reading emails fast
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-21 18:32 UTC by Frits Spieker
Modified: 2012-07-22 00:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frits Spieker 2012-07-21 18:32:09 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) "release 513"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: clicking through the headers of emails fast (one email after the other) made KMail crash.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5f57de8760 (LWP 2634))]

Thread 3 (Thread 0x7f5f3f192700 (LWP 2635)):
#0  0x00007f5f4fc6be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5f54600c12 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f5f54f9f1a0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007f5f54600c49 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007f5f4fc67f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f5f552f210d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f5f3e891700 (LWP 2636)):
#0  0x00007f5f4fc6a01e in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f5f4f757e91 in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f5f4f75899a in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f5f4f758f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f5f55a60e36 in QEventDispatcherGlib::processEvents (this=0x7f5f380008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f5f55a30842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f5f55a30a97 in QEventLoop::exec (this=0x7f5f3e890e20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f5f559305f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f5f5593361b in QThreadPrivate::start (arg=0x63bbd0) at thread/qthread_unix.cpp:307
#9  0x00007f5f4fc67f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f5f552f210d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f5f57de8760 (LWP 2634)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3e8c7f0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#7  0x00007f5f50c34509 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3e8c7f0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f5f55a4ae06 in QObject::event (this=0x3e8c7f0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f5f5644afe4 in notify_helper (e=0x7f5edc00c8b0, receiver=0x3e8c7f0, this=0x648f80) at kernel/qapplication.cpp:4551
#10 QApplicationPrivate::notify_helper (this=0x648f80, receiver=0x3e8c7f0, e=0x7f5edc00c8b0) at kernel/qapplication.cpp:4523
#11 0x00007f5f5644fdb3 in QApplication::notify (this=0x7fff69621020, receiver=0x3e8c7f0, e=0x7f5edc00c8b0) at kernel/qapplication.cpp:4412
#12 0x00007f5f57191746 in KApplication::notify (this=0x7fff69621020, receiver=0x3e8c7f0, event=0x7f5edc00c8b0) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#13 0x00007f5f55a31d0c in QCoreApplication::notifyInternal (this=0x7fff69621020, receiver=0x3e8c7f0, event=0x7f5edc00c8b0) at kernel/qcoreapplication.cpp:915
#14 0x00007f5f55a355ba in sendEvent (event=0x7f5edc00c8b0, receiver=0x3e8c7f0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60dc00) at kernel/qcoreapplication.cpp:1539
#16 0x00007f5f55a609a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x6450d0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f5f4f75858d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f5f4f758d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f5f4f758f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f5f55a60dcf in QEventDispatcherGlib::processEvents (this=0x60d4c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f5f564ee69e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f5f55a30842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f5f55a30a97 in QEventLoop::exec (this=0x7fff69620fb0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f5f55a358b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#26 0x0000000000403919 in main (argc=1, argv=0x7fff69621648) at /usr/src/debug/kdepim-4.8.4/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 303882, bug 303694, bug 303295, bug 303035, bug 302692.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-22 00:29:23 UTC

*** This bug has been marked as a duplicate of bug 286307 ***