Bug 303882 - kmail kontact crash on view and delete html mail / message
Summary: kmail kontact crash on view and delete html mail / message
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-21 10:35 UTC by Sorush Nazari
Modified: 2012-07-21 14:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sorush Nazari 2012-07-21 10:35:42 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I was viewing the mails / deleting them. All html and after a few or just one delete crash happens.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0377a5c7c0 (LWP 3725))]

Thread 4 (Thread 0x7f035affd700 (LWP 3726)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0374262dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f0374262f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f036f728e9a in start_thread (arg=0x7f035affd700) at pthread_create.c:308
#4  0x00007f0374f944bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f035a6fc700 (LWP 3727)):
#0  0x00007f0374f88b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f036f25bff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f036f25c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0375709426 in QEventDispatcherGlib::processEvents (this=0x7f03540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f03756d8c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f03756d8ed7 in QEventLoop::exec (this=0x7f035a6fbdc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f03755d7fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f03755dafcb in QThreadPrivate::start (arg=0x216f770) at thread/qthread_unix.cpp:298
#8  0x00007f036f728e9a in start_thread (arg=0x7f035a6fc700) at pthread_create.c:308
#9  0x00007f0374f944bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f030c023700 (LWP 3742)):
#0  0x00007fff7c74f98f in clock_gettime ()
#1  0x00007f036da8c15d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f0375631bb4 in do_gettime (frac=0x7f030c022b58, sec=0x7f030c022b50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f0375709b8d in QTimerInfoList::updateCurrentTime (this=0x7f0304002660) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f0375709ec3 in QTimerInfoList::timerWait (this=0x7f0304002660, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f037570897c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f030c022c2c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f0375708a25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f036f25b71e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f036f25bf1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f036f25c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f0375709426 in QEventDispatcherGlib::processEvents (this=0x7f03040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f03756d8c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f03756d8ed7 in QEventLoop::exec (this=0x7f030c022d90, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f03755d7fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f03756b89ff in QInotifyFileSystemWatcherEngine::run (this=0x2d92d80) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f03755dafcb in QThreadPrivate::start (arg=0x2d92d80) at thread/qthread_unix.cpp:298
#17 0x00007f036f728e9a in start_thread (arg=0x7f030c023700) at pthread_create.c:308
#18 0x00007f0374f944bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0377a5c7c0 (LWP 3725)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4015ef0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f03705fe709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4015ef0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f03756f3446 in QObject::event (this=0x4015ef0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f03760cf894 in notify_helper (e=0x7f02f80052c0, receiver=0x4015ef0, this=0x1fe17c0) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1fe17c0, receiver=0x4015ef0, e=0x7f02f80052c0) at kernel/qapplication.cpp:4531
#11 0x00007f03760d4713 in QApplication::notify (this=0x7fff7c71be40, receiver=0x4015ef0, e=0x7f02f80052c0) at kernel/qapplication.cpp:4420
#12 0x00007f0376e08bb6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#13 0x00007f03756d9e9c in QCoreApplication::notifyInternal (this=0x7fff7c71be40, receiver=0x4015ef0, event=0x7f02f80052c0) at kernel/qcoreapplication.cpp:876
#14 0x00007f03756ddc6a in sendEvent (event=0x7f02f80052c0, receiver=0x4015ef0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1f9a380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f0375708f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f036f25bc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f036f25c060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f036f25c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f03757093bf in QEventDispatcherGlib::processEvents (this=0x1f9bc10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f0376177d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f03756d8c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f03756d8ed7 in QEventLoop::exec (this=0x7fff7c71bdd0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f03756ddf67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in ?? ()
#27 0x00007f0374ec376d in __libc_start_main (main=0x402b40, argc=1, ubp_av=0x7fff7c71c468, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7c71c458) at libc-start.c:226
#28 0x0000000000403b61 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 303694, bug 303295, bug 303035, bug 302692, bug 302641.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-21 14:04:30 UTC

*** This bug has been marked as a duplicate of bug 286307 ***