Bug 303694 - KMail crashed after deleting message
Summary: KMail crashed after deleting message
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-17 17:46 UTC by util
Modified: 2012-07-17 19:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description util 2012-07-17 17:46:39 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
   Deleting message from inbox, while KMail started an automatic mail check at the same time
- Unusual behavior I noticed:
   None. Everything fine up until I deleted the message.
- Custom settings of the application:
   Incoming new mail is filtered and forwarded to different folders.  This seems to have caused problems before.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4462ac77c0 (LWP 2587))]

Thread 4 (Thread 0x7f444605b700 (LWP 2588)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f445f2c3dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f445f2c3f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f445a787e9a in start_thread (arg=0x7f444605b700) at pthread_create.c:308
#4  0x00007f445fff54bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f444575a700 (LWP 2589)):
#0  0x00007fff1f3ff8de in ?? ()
#1  0x00007f4458aeb15d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f4460692bb4 in do_gettime (frac=0x7f4445759ba8, sec=0x7f4445759ba0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f446076ab8d in QTimerInfoList::updateCurrentTime (this=0x7f4440002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f446076aec3 in QTimerInfoList::timerWait (this=0x7f4440002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f446076997c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f4445759c5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f445a2ba846 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f445a2baf5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f445a2bb164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f446076a426 in QEventDispatcherGlib::processEvents (this=0x7f44400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f4460739c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f4460739ed7 in QEventLoop::exec (this=0x7f4445759dc0, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f4460638fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f446063bfcb in QThreadPrivate::start (arg=0x1656e50) at thread/qthread_unix.cpp:298
#15 0x00007f445a787e9a in start_thread (arg=0x7f444575a700) at pthread_create.c:308
#16 0x00007f445fff54bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f43f5314700 (LWP 2634)):
#0  0x00007f445a789f69 in __pthread_mutex_lock (mutex=0x7f43ec00c0d0) at pthread_mutex_lock.c:92
#1  0x00007f445a2f65a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f445a2bab4e in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f445a2bafd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f445a2bb164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f446076a426 in QEventDispatcherGlib::processEvents (this=0x7f43ec0013e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f4460739c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4460739ed7 in QEventLoop::exec (this=0x7f43f5313d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4460638fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f44607199ff in QInotifyFileSystemWatcherEngine::run (this=0x29772e0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f446063bfcb in QThreadPrivate::start (arg=0x29772e0) at thread/qthread_unix.cpp:298
#11 0x00007f445a787e9a in start_thread (arg=0x7f43f5314700) at pthread_create.c:308
#12 0x00007f445fff54bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4462ac77c0 (LWP 2587)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x458e6d0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f445b65d709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x458e6d0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f4460754446 in QObject::event (this=0x458e6d0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f4461135894 in notify_helper (e=0x7f43e000b390, receiver=0x458e6d0, this=0x1529ec0) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1529ec0, receiver=0x458e6d0, e=0x7f43e000b390) at kernel/qapplication.cpp:4531
#11 0x00007f446113a713 in QApplication::notify (this=0x7fff1f2bf780, receiver=0x458e6d0, e=0x7f43e000b390) at kernel/qapplication.cpp:4420
#12 0x00007f4461e6f9e6 in KApplication::notify (this=0x7fff1f2bf780, receiver=0x458e6d0, event=0x7f43e000b390) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f446073ae9c in QCoreApplication::notifyInternal (this=0x7fff1f2bf780, receiver=0x458e6d0, event=0x7f43e000b390) at kernel/qcoreapplication.cpp:876
#14 0x00007f446073ec6a in sendEvent (event=0x7f43e000b390, receiver=0x458e6d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x14ef380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f4460769f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f445a2bad53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f445a2bb0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f445a2bb164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f446076a3bf in QEventDispatcherGlib::processEvents (this=0x14f0c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f44611ddd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f4460739c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f4460739ed7 in QEventLoop::exec (this=0x7fff1f2bf710, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f446073ef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in ?? ()
#27 0x00007f445ff2476d in __libc_start_main (main=0x402b40, argc=1, ubp_av=0x7fff1f2bfda8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff1f2bfd98) at libc-start.c:226
#28 0x0000000000403b61 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 303295, bug 303035, bug 302692, bug 302641, bug 302394.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-17 19:29:52 UTC

*** This bug has been marked as a duplicate of bug 286307 ***