Bug 305201 - Kmail crash when opening email
Summary: Kmail crash when opening email
Status: RESOLVED FIXED
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.9.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-15 14:18 UTC by Otter
Modified: 2012-08-18 07:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Otter 2012-08-15 14:18:29 UTC
Application: kontact (4.9)
KDE Platform Version: 4.9.00 "release 558"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
updated to KDE 4.9 last night.  Trying Kmail for first time in since April.  Opened two email without issue.  Created filters for those two emails based on "from".  tried to open third email when I received this crash.  Have repeated the process three times.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f67577e5760 (LWP 15970))]

Thread 3 (Thread 0x7f673f3d4700 (LWP 15971)):
#0  0x00007f674f624e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6753ff7c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f6753ff7c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f673eabb700 (LWP 15972)):
#0  0x00007f6754cdfff3 in poll () from /lib64/libc.so.6
#1  0x00007f674f111ae8 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f674f111fa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6755457e36 in QEventDispatcherGlib::processEvents (this=0x7f67380008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6755427842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6755427a97 in QEventLoop::exec (this=0x7f673eabae20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f67553275f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f675532a61b in QThreadPrivate::start (arg=0x63c230) at thread/qthread_unix.cpp:307
#8  0x00007f674f620f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6754ce910d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f67577e5760 (LWP 15970)):
[KCrash Handler]
#6  QList (l=..., this=0x7fffa47629d0) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fffa4762ce0) at access/qabstractnetworkcache.cpp:240
#8  0x00007f675055fb1c in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x24f4700, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1020
#9  0x00007f6750561274 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x24f4700, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:829
#10 0x00007f67505ed509 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x24f4700, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007f6755441e06 in QObject::event (this=0x24f4700, e=<optimized out>) at kernel/qobject.cpp:1204
#12 0x00007f6755e41fe4 in notify_helper (e=0x7f66ec00c0b0, receiver=0x24f4700, this=0x639f60) at kernel/qapplication.cpp:4551
#13 QApplicationPrivate::notify_helper (this=0x639f60, receiver=0x24f4700, e=0x7f66ec00c0b0) at kernel/qapplication.cpp:4523
#14 0x00007f6755e46db3 in QApplication::notify (this=0x7fffa4763760, receiver=0x24f4700, e=0x7f66ec00c0b0) at kernel/qapplication.cpp:4412
#15 0x00007f6756b881b6 in KApplication::notify (this=0x7fffa4763760, receiver=0x24f4700, event=0x7f66ec00c0b0) at /usr/src/debug/kdelibs-4.9.0/kdeui/kernel/kapplication.cpp:311
#16 0x00007f6755428d0c in QCoreApplication::notifyInternal (this=0x7fffa4763760, receiver=0x24f4700, event=0x7f66ec00c0b0) at kernel/qcoreapplication.cpp:915
#17 0x00007f675542c5ba in sendEvent (event=0x7f66ec00c0b0, receiver=0x24f4700) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60d850) at kernel/qcoreapplication.cpp:1539
#19 0x00007f67554579a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x64d0f0) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007f674f1115dd in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f674f111dd8 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f674f111fa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f6755457dcf in QEventDispatcherGlib::processEvents (this=0x60d110, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f6755ee569e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f6755427842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f6755427a97 in QEventLoop::exec (this=0x7fffa47636f0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f675542c8b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#29 0x00000000004038c9 in ?? ()
#30 0x00007f6754c2f23d in __libc_start_main () from /lib64/libc.so.6
#31 0x0000000000403e31 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 302641, bug 300045, bug 299897, bug 298427, bug 297174.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-08-15 14:21:47 UTC
fixed in 4.9/4.8.5
Comment 2 Jekyll Wu 2012-08-15 14:24:05 UTC
(In reply to comment #1)
> fixed in 4.9/4.8.5

But the reporter is using 4.9 ...