Bug 303295 - K-mail or Kontact crash
Summary: K-mail or Kontact crash
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-10 12:46 UTC by Ralf Gulich
Modified: 2012-07-10 12:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Gulich 2012-07-10 12:46:59 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
I have the following problem since I began KUbuntu 12:04 K-Mail or KDE Kontact Version 4.8.4. When changing the mailboxes and call plunges K-Mail or Contact at irregular intervals so about 3 times a day from. My e-mail, I call from different mailboxes from IMAP. Before that I had with 11:04 these problems. Am I doing something wrong or what I have configured wrong or is there a bug in KDE.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6ecd6437c0 (LWP 2701))]

Thread 4 (Thread 0x7f6eb08f6700 (LWP 2702)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f6ec9e3cdec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f6ec9e3cf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f6ec5300e9a in start_thread (arg=0x7f6eb08f6700) at pthread_create.c:308
#4  0x00007f6ecab6e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6eaffd5700 (LWP 2703)):
#0  0x00007f6ecab62b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6ec4e34036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6ec4e34164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6ecb2e3426 in QEventDispatcherGlib::processEvents (this=0x7f6ea80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6ecb2b2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6ecb2b2ed7 in QEventLoop::exec (this=0x7f6eaffd4dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6ecb1b1fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f6ecb1b4fcb in QThreadPrivate::start (arg=0x1281150) at thread/qthread_unix.cpp:298
#8  0x00007f6ec5300e9a in start_thread (arg=0x7f6eaffd5700) at pthread_create.c:308
#9  0x00007f6ecab6e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6e623e8700 (LWP 2920)):
#0  0x00007f6ec5302f69 in __pthread_mutex_lock (mutex=0x7f6e5c002b80) at pthread_mutex_lock.c:92
#1  0x00007f6ec4e6f5a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6ec4e33914 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6ec4e33faa in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6ec4e34164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6ecb2e3426 in QEventDispatcherGlib::processEvents (this=0x7f6e5c002930, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6ecb2b2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6ecb2b2ed7 in QEventLoop::exec (this=0x7f6e623e7d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6ecb1b1fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f6ecb2929ff in QInotifyFileSystemWatcherEngine::run (this=0x22c5890) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f6ecb1b4fcb in QThreadPrivate::start (arg=0x22c5890) at thread/qthread_unix.cpp:298
#11 0x00007f6ec5300e9a in start_thread (arg=0x7f6e623e8700) at pthread_create.c:308
#12 0x00007f6ecab6e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6ecd6437c0 (LWP 2701)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x466e7d0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f6ec61d6709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x466e7d0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f6ecb2cd446 in QObject::event (this=0x466e7d0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f6ecbcae894 in notify_helper (e=0x7f6e4c034640, receiver=0x466e7d0, this=0x11434e0) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x11434e0, receiver=0x466e7d0, e=0x7f6e4c034640) at kernel/qapplication.cpp:4531
#11 0x00007f6ecbcb3713 in QApplication::notify (this=0x7fff96b5b0e0, receiver=0x466e7d0, e=0x7f6e4c034640) at kernel/qapplication.cpp:4420
#12 0x00007f6ecc9e89e6 in KApplication::notify (this=0x7fff96b5b0e0, receiver=0x466e7d0, event=0x7f6e4c034640) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f6ecb2b3e9c in QCoreApplication::notifyInternal (this=0x7fff96b5b0e0, receiver=0x466e7d0, event=0x7f6e4c034640) at kernel/qcoreapplication.cpp:876
#14 0x00007f6ecb2b7c6a in sendEvent (event=0x7f6e4c034640, receiver=0x466e7d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x110c380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f6ecb2e2f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f6ec4e33d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f6ec4e340a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f6ec4e34164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f6ecb2e33bf in QEventDispatcherGlib::processEvents (this=0x110dc10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f6ecbd56d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f6ecb2b2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f6ecb2b2ed7 in QEventLoop::exec (this=0x7fff96b5b070, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f6ecb2b7f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in main (argc=1, argv=0x7fff96b5b708) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 303035, bug 302692, bug 302641, bug 302394, bug 302233.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-10 12:52:57 UTC

*** This bug has been marked as a duplicate of bug 286307 ***