Bug 297174 - KMail crashing when selecting or deselecting HTML mails with external references
Summary: KMail crashing when selecting or deselecting HTML mails with external references
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-31 12:03 UTC by Ingo Heeskens
Modified: 2012-03-31 12:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Heeskens 2012-03-31 12:03:07 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Selecting a HTML mail with external references enabled => crash
Selecting a HTML mail with external references disabled, manual loading of external references, selecting another mail => crash

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe1793c87c0 (LWP 29538))]

Thread 4 (Thread 0x7fe15dc50700 (LWP 29539)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe175bf0c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fe175bf0d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fe1713bdefc in start_thread (arg=0x7fe15dc50700) at pthread_create.c:304
#4  0x00007fe17690059d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe15d337700 (LWP 29540)):
#0  0x00007fe170eeafb3 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fe170eebdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe170eec429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe17706ec26 in QEventDispatcherGlib::processEvents (this=0xdf2a10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe17703e402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe17703e657 in QEventLoop::exec (this=0x7fe15d336dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe176f3e067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe176f4108b in QThreadPrivate::start (arg=0xdf20d0) at thread/qthread_unix.cpp:298
#8  0x00007fe1713bdefc in start_thread (arg=0x7fe15d337700) at pthread_create.c:304
#9  0x00007fe17690059d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe107fff700 (LWP 29550)):
#0  0x00007fe1768f4473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe170eebf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe170eec429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe17706ec26 in QEventDispatcherGlib::processEvents (this=0x20ab460, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe17703e402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe17703e657 in QEventLoop::exec (this=0x7fe107ffed90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe176f3e067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe17701e17f in QInotifyFileSystemWatcherEngine::run (this=0x219dfc0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe176f4108b in QThreadPrivate::start (arg=0x219dfc0) at thread/qthread_unix.cpp:298
#9  0x00007fe1713bdefc in start_thread (arg=0x7fe107fff700) at pthread_create.c:304
#10 0x00007fe17690059d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe1793c87c0 (LWP 29538)):
[KCrash Handler]
#6  0x00007fe17216f732 in node_copy (src=<optimized out>, to=0x44ae660, from=0x3be11a858, this=0x7fff98909790) at ../../include/QtCore/../../src/corelib/tools/qlist.h:399
#7  QList<QPair<QByteArray, QByteArray> >::detach_helper (this=0x7fff98909790, alloc=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:711
#8  0x00007fe1721ae82d in detach_helper (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:725
#9  QList (this=<optimized out>, l=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#10 QList (l=<optimized out>, this=<optimized out>) at access/qabstractnetworkcache.cpp:238
#11 QNetworkCacheMetaData::rawHeaders (this=<optimized out>) at access/qabstractnetworkcache.cpp:240
#12 0x00007fe1721915ac in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x31e78a0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#13 0x00007fe172192d04 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x31e78a0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#14 0x00007fe17221e299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x31e78a0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#15 0x00007fe177058bc6 in QObject::event (this=0x31e78a0, e=<optimized out>) at kernel/qobject.cpp:1195
#16 0x00007fe177a33104 in notify_helper (e=0x7fe1581400e0, receiver=0x31e78a0, this=0xc0f320) at kernel/qapplication.cpp:4555
#17 QApplicationPrivate::notify_helper (this=0xc0f320, receiver=0x31e78a0, e=0x7fe1581400e0) at kernel/qapplication.cpp:4527
#18 0x00007fe177a37f83 in QApplication::notify (this=0x7fff9890a520, receiver=0x31e78a0, e=0x7fe1581400e0) at kernel/qapplication.cpp:4416
#19 0x00007fe1787659a6 in KApplication::notify (this=0x7fff9890a520, receiver=0x31e78a0, event=0x7fe1581400e0) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007fe17703f61c in QCoreApplication::notifyInternal (this=0x7fff9890a520, receiver=0x31e78a0, event=0x7fe1581400e0) at kernel/qcoreapplication.cpp:876
#21 0x00007fe1770433ea in sendEvent (event=0x7fe1581400e0, receiver=0x31e78a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xbd5380) at kernel/qcoreapplication.cpp:1500
#23 0x00007fe17706e793 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#25 0x00007fe170eeba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fe170eec258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fe170eec429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fe17706ebbf in QEventDispatcherGlib::processEvents (this=0xbd6c10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00007fe177ad828e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007fe17703e402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007fe17703e657 in QEventLoop::exec (this=0x7fff9890a4b0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007fe1770436e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x0000000000403629 in main (argc=1, argv=0x7fff9890ab48) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 296624, bug 296617, bug 296485, bug 296009, bug 295112.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-31 12:19:40 UTC

*** This bug has been marked as a duplicate of bug 286307 ***