Bug 302641 - Still happening in KDE 4.9 Beta
Summary: Still happening in KDE 4.9 Beta
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-27 14:45 UTC by James Cain
Modified: 2012-06-27 15:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Email that caused the last crash (31.94 KB, application/mbox)
2012-06-27 14:56 UTC, James Cain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Cain 2012-06-27 14:45:38 UTC
Application: kontact (4.9 beta2)
KDE Platform Version: 4.8.90 (4.8.90)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: Loading an HTML email. Emails always crash from this same sender. I will try to attach the HTML from this particular email in hopes that an answer can be found...

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f60082f27c0 (LWP 5432))]

Thread 5 (Thread 0x7f5feb877700 (LWP 5433)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f6004aeddec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f60054b6de0) at wtf/FastMalloc.cpp:2495
#2  0x00007f6004aedf19 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f5ffffa1e9a in start_thread (arg=0x7f5feb877700) at pthread_create.c:308
#4  0x00007f600581f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f5feaf76700 (LWP 5434)):
#0  0x00007fff8be78971 in clock_gettime ()
#1  0x00007f5ffe30515d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f6005ebcbb4 in do_gettime (frac=0x7f5feaf75ba8, sec=0x7f5feaf75ba0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f6005f94b8d in QTimerInfoList::updateCurrentTime (this=0x7f5fe4002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f6005f94ec3 in QTimerInfoList::timerWait (this=0x7f5fe4002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f6005f9397c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f5feaf75c5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f5fffad4846 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f5fffad4f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f5fffad5164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f6005f94426 in QEventDispatcherGlib::processEvents (this=0x7f5fe40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f6005f63c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f6005f63ed7 in QEventLoop::exec (this=0x7f5feaf75dc0, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f6005e62fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f6005e65fcb in QThreadPrivate::start (arg=0x24571e0) at thread/qthread_unix.cpp:298
#15 0x00007f5ffffa1e9a in start_thread (arg=0x7f5feaf76700) at pthread_create.c:308
#16 0x00007f600581f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5f9d676700 (LWP 5440)):
#0  0x00007f5ffffa505d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f5f98000a60) at pthread_mutex_unlock.c:290
#2  0x00007f5fffb105d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5fffad516e in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6005f94426 in QEventDispatcherGlib::processEvents (this=0x7f5f980008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f6005f63c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6005f63ed7 in QEventLoop::exec (this=0x7f5f9d675d90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f6005e62fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f6005f439ff in QInotifyFileSystemWatcherEngine::run (this=0x2c59770) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f6005e65fcb in QThreadPrivate::start (arg=0x2c59770) at thread/qthread_unix.cpp:298
#10 0x00007f5ffffa1e9a in start_thread (arg=0x7f5f9d676700) at pthread_create.c:308
#11 0x00007f600581f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5f8d3d9700 (LWP 6208)):
#0  0x00007f5fffb10599 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5fffad501b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5fffad5164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6005f94426 in QEventDispatcherGlib::processEvents (this=0x7f5f74003720, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6005f63c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6005f63ed7 in QEventLoop::exec (this=0x7f5f8d3d8dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6005e62fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f6005e65fcb in QThreadPrivate::start (arg=0x2e74b70) at thread/qthread_unix.cpp:298
#8  0x00007f5ffffa1e9a in start_thread (arg=0x7f5f8d3d9700) at pthread_create.c:308
#9  0x00007f600581f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f60082f27c0 (LWP 5432)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff8be705d0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff8be708e0) at access/qabstractnetworkcache.cpp:240
#8  0x00007f6000dea7bc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x512fd30, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007f6000debf14 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x512fd30, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007f6000e77709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x512fd30, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007f6005f7e446 in QObject::event (this=0x512fd30, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x00007f600695f894 in notify_helper (e=0x7f5f6c009590, receiver=0x512fd30, this=0x244c0a0) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x244c0a0, receiver=0x512fd30, e=0x7f5f6c009590) at kernel/qapplication.cpp:4531
#14 0x00007f6006964713 in QApplication::notify (this=0x7fff8be71330, receiver=0x512fd30, e=0x7f5f6c009590) at kernel/qapplication.cpp:4420
#15 0x00007f60076999e6 in KApplication::notify (this=0x7fff8be71330, receiver=0x512fd30, event=0x7f5f6c009590) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007f6005f64e9c in QCoreApplication::notifyInternal (this=0x7fff8be71330, receiver=0x512fd30, event=0x7f5f6c009590) at kernel/qcoreapplication.cpp:876
#17 0x00007f6005f68c6a in sendEvent (event=0x7f5f6c009590, receiver=0x512fd30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2411380) at kernel/qcoreapplication.cpp:1500
#19 0x00007f6005f93f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007f5fffad4d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f5fffad50a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f5fffad5164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f6005f943bf in QEventDispatcherGlib::processEvents (this=0x2412c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f6006a07d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f6005f63c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f6005f63ed7 in QEventLoop::exec (this=0x7fff8be712c0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f6005f68f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403629 in ?? ()
#30 0x00007f600574e76d in __libc_start_main (main=0x402b40, argc=1, ubp_av=0x7fff8be71958, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8be71948) at libc-start.c:226
#31 0x0000000000403b61 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 300045, bug 299897, bug 298427, bug 297174, bug 296624.

Reported using DrKonqi
Comment 1 James Cain 2012-06-27 14:56:33 UTC
Created attachment 72169 [details]
Email that caused the last crash

Emails almost always crash from this sender
Comment 2 Laurent Montel 2012-06-27 15:16:32 UTC
I close it as duplicate...
Still happend => already open...

*** This bug has been marked as a duplicate of bug 286307 ***