Bug 299897 - kmail crash in QList called from QNetworkCacheMetaData::rawHeaders
Summary: kmail crash in QList called from QNetworkCacheMetaData::rawHeaders
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-12 17:22 UTC by p92
Modified: 2012-05-14 09:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p92 2012-05-12 17:22:01 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I was rapidly deleting unread mails from my inbox folder when kontact crashed just before displaying the next unread one.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa2cedad7c0 (LWP 3326))]

Thread 4 (Thread 0x7fa2b28d1700 (LWP 3406)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa2cb5abdec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7fa2cbf74de0) at wtf/FastMalloc.cpp:2495
#2  0x00007fa2cb5abf19 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007fa2c6a72e9a in start_thread (arg=0x7fa2b28d1700) at pthread_create.c:308
#4  0x00007fa2cc2dd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa2b1fb0700 (LWP 3408)):
#0  0x00007fa2cc2eb0c0 in pthread_mutex_lock (mutex=0x7fa2ac000a60) at forward.c:182
#1  0x00007fa2c65e1561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa2c65a6110 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa2cca52426 in QEventDispatcherGlib::processEvents (this=0x7fa2ac0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fa2cca21c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa2cca21ed7 in QEventLoop::exec (this=0x7fa2b1fafdc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fa2cc920fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fa2cc923fcb in QThreadPrivate::start (arg=0xfb2a10) at thread/qthread_unix.cpp:298
#8  0x00007fa2c6a72e9a in start_thread (arg=0x7fa2b1fb0700) at pthread_create.c:308
#9  0x00007fa2cc2dd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa263e11700 (LWP 3913)):
#0  0x00007fa2cc2d00bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fa2c65e088f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa2c65a5abd in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa2c65a5f96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa2c65a6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa2cca52426 in QEventDispatcherGlib::processEvents (this=0x7fa25c003b30, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fa2cca21c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fa2cca21ed7 in QEventLoop::exec (this=0x7fa263e10d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fa2cc920fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fa2cca019ff in QInotifyFileSystemWatcherEngine::run (this=0x12041b0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fa2cc923fcb in QThreadPrivate::start (arg=0x12041b0) at thread/qthread_unix.cpp:298
#11 0x00007fa2c6a72e9a in start_thread (arg=0x7fa263e11700) at pthread_create.c:308
#12 0x00007fa2cc2dd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa2cedad7c0 (LWP 3326)):
[KCrash Handler]
#6  QList (l=..., this=0x7fffad6600c0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fffad6603d0) at access/qabstractnetworkcache.cpp:240
#8  0x00007fa2c78bb7bc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x5080a60, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007fa2c78bcf14 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x5080a60, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007fa2c7948709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x5080a60, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007fa2cca3c446 in QObject::event (this=0x5080a60, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x00007fa2cd417894 in notify_helper (e=0x7fa254054710, receiver=0x5080a60, this=0xe255e0) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0xe255e0, receiver=0x5080a60, e=0x7fa254054710) at kernel/qapplication.cpp:4531
#14 0x00007fa2cd41c713 in QApplication::notify (this=0x7fffad660e20, receiver=0x5080a60, e=0x7fa254054710) at kernel/qapplication.cpp:4420
#15 0x00007fa2ce150b46 in KApplication::notify (this=0x7fffad660e20, receiver=0x5080a60, event=0x7fa254054710) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007fa2cca22e9c in QCoreApplication::notifyInternal (this=0x7fffad660e20, receiver=0x5080a60, event=0x7fa254054710) at kernel/qcoreapplication.cpp:876
#17 0x00007fa2cca26c6a in sendEvent (event=0x7fa254054710, receiver=0x5080a60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xdea380) at kernel/qcoreapplication.cpp:1500
#19 0x00007fa2cca51f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007fa2c65a5c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fa2c65a6060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fa2c65a6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fa2cca523bf in QEventDispatcherGlib::processEvents (this=0xdebc10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007fa2cd4bfd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fa2cca21c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007fa2cca21ed7 in QEventLoop::exec (this=0x7fffad660db0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007fa2cca26f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403629 in main (argc=3, argv=0x7fffad661448) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 298427, bug 297174, bug 296624, bug 296617, bug 296485.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-05-14 09:39:21 UTC

*** This bug has been marked as a duplicate of bug 286307 ***