Bug 300045 - rare crash opening an email
Summary: rare crash opening an email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-15 02:20 UTC by Rory Griffin
Modified: 2012-05-15 06:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rory Griffin 2012-05-15 02:20:18 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
reading emails down the list in kmail mailbox.  This is not a regualr occurrence.  It did happen suddenly clicking on the email to read.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb10a5db7c0 (LWP 3902))]

Thread 4 (Thread 0x7fb0ed90a700 (LWP 3903)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb106de3dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fb106de3f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fb1022aae9a in start_thread (arg=0x7fb0ed90a700) at pthread_create.c:308
#4  0x00007fb107b154bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb0ed009700 (LWP 3904)):
#0  0x00007fb107b09b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb101dddff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb101dde124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb10828a426 in QEventDispatcherGlib::processEvents (this=0x7fb0e80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fb108259c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb108259ed7 in QEventLoop::exec (this=0x7fb0ed008dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb108158fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fb10815bfcb in QThreadPrivate::start (arg=0xafed50) at thread/qthread_unix.cpp:298
#8  0x00007fb1022aae9a in start_thread (arg=0x7fb0ed009700) at pthread_create.c:308
#9  0x00007fb107b154bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb097fff700 (LWP 3915)):
#0  0x00007fb107b09b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb101dddff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb101dde124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb10828a426 in QEventDispatcherGlib::processEvents (this=0x7fb0900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fb108259c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb108259ed7 in QEventLoop::exec (this=0x7fb097ffed90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb108158fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fb1082399ff in QInotifyFileSystemWatcherEngine::run (this=0x34ffd30) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb10815bfcb in QThreadPrivate::start (arg=0x34ffd30) at thread/qthread_unix.cpp:298
#9  0x00007fb1022aae9a in start_thread (arg=0x7fb097fff700) at pthread_create.c:308
#10 0x00007fb107b154bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb10a5db7c0 (LWP 3902)):
[KCrash Handler]
#6  QList (l=..., this=0x7ffffa08b4a0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7ffffa08b7b0) at access/qabstractnetworkcache.cpp:240
#8  0x00007fb1030f37bc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x6593fa0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007fb1030f4f14 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x6593fa0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007fb103180709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x6593fa0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007fb108274446 in QObject::event (this=0x6593fa0, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x00007fb108c4f894 in notify_helper (e=0x7fb07800f7e0, receiver=0x6593fa0, this=0xaf63f0) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0xaf63f0, receiver=0x6593fa0, e=0x7fb07800f7e0) at kernel/qapplication.cpp:4531
#14 0x00007fb108c54713 in QApplication::notify (this=0x7ffffa08c200, receiver=0x6593fa0, e=0x7fb07800f7e0) at kernel/qapplication.cpp:4420
#15 0x00007fb109988b46 in KApplication::notify (this=0x7ffffa08c200, receiver=0x6593fa0, event=0x7fb07800f7e0) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007fb10825ae9c in QCoreApplication::notifyInternal (this=0x7ffffa08c200, receiver=0x6593fa0, event=0x7fb07800f7e0) at kernel/qcoreapplication.cpp:876
#17 0x00007fb10825ec6a in sendEvent (event=0x7fb07800f7e0, receiver=0x6593fa0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xac0380) at kernel/qcoreapplication.cpp:1500
#19 0x00007fb108289f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007fb101dddc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fb101dde060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fb101dde124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fb10828a3bf in QEventDispatcherGlib::processEvents (this=0xac1c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007fb108cf7d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fb108259c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007fb108259ed7 in QEventLoop::exec (this=0x7ffffa08c190, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007fb10825ef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403629 in main (argc=1, argv=0x7ffffa08c828) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 299897, bug 298427, bug 297174, bug 296624, bug 296617.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-15 06:16:54 UTC

*** This bug has been marked as a duplicate of bug 286307 ***