Bug 303035 - kontact crashes
Summary: kontact crashes
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-04 20:43 UTC by Jeff gibbs
Modified: 2012-07-04 20:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff gibbs 2012-07-04 20:43:24 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Kontact crashes while browsing gmail as an IMAP account. Other imap accounts in Kontact work normally

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb21da980 (LWP 2546))]

Thread 5 (Thread 0xafc00b40 (LWP 2547)):
#0  0xb77b1424 in __kernel_vsyscall ()
#1  0xb39e596b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb60ed3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb586b263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb586b37f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb39e1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb60dface in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xaf2dfb40 (LWP 2548)):
#0  0xb39e4c64 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb60ed634 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb394e410 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb390e865 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb390efaf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb390f201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb642f8e7 in QEventDispatcherGlib::processEvents (this=0xae900468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb63fb50d in QEventLoop::processEvents (this=0xaf2df270, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63fb7a9 in QEventLoop::exec (this=0xaf2df270, flags=...) at kernel/qeventloop.cpp:204
#9  0xb62e494c in QThread::exec (this=0x8cf8f98) at thread/qthread.cpp:501
#10 0xb62e4a3b in QThread::run (this=0x8cf8f98) at thread/qthread.cpp:568
#11 0xb62e7de0 in QThreadPrivate::start (arg=0x8cf8f98) at thread/qthread_unix.cpp:298
#12 0xb39e1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb60dface in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xabe04b40 (LWP 2565)):
#0  0xb62e6d8f in get_thread_data () at thread/qthread_unix.cpp:174
#1  QThreadData::current () at thread/qthread_unix.cpp:200
#2  0xb642f067 in postEventSourcePrepare (s=0xab500da8, timeout=0xabe040bc) at kernel/qeventdispatcher_glib.cpp:256
#3  0xb390e872 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb390efaf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb390f201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb642f8e7 in QEventDispatcherGlib::processEvents (this=0xab500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb63fb50d in QEventLoop::processEvents (this=0xabe04240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63fb7a9 in QEventLoop::exec (this=0xabe04240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb62e494c in QThread::exec (this=0x937a648) at thread/qthread.cpp:501
#10 0xb63d8b5d in QInotifyFileSystemWatcherEngine::run (this=0x937a648) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb62e7de0 in QThreadPrivate::start (arg=0x937a648) at thread/qthread_unix.cpp:298
#12 0xb39e1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb60dface in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xacc16b40 (LWP 2621)):
#0  0xb77b1424 in __kernel_vsyscall ()
#1  0xb39e5d13 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb60ed434 in pthread_cond_timedwait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb62e82df in wait (time=30000, this=0x962c150) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0x962c578, mutex=0x962c574, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0xb62da474 in QThreadPoolThread::run (this=0x962cf40) at concurrent/qthreadpool.cpp:141
#6  0xb62e7de0 in QThreadPrivate::start (arg=0x962cf40) at thread/qthread_unix.cpp:298
#7  0xb39e1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb60dface in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb21da980 (LWP 2546)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xad0ade0, hm=<error reading variable: Cannot access memory at address 0x31>, sc=49, rp=<error reading variable: Cannot access memory at address 0x31>, pu=120, db=<error reading variable: Cannot access memory at address 0x31>, contentLength=-1279344196) at access/qnetworkaccesshttpbackend.cpp:827
#8  0xb3be537d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xad0ade0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xac328838) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0xb640ec01 in QMetaCallEvent::placeMetaCall (this=0xac337d10, object=0xad0ade0) at kernel/qobject.cpp:525
#10 0xb6417c7b in QObject::event (this=0xad0ade0, e=0xac337d10) at kernel/qobject.cpp:1195
#11 0xb6969ed4 in notify_helper (e=0xac337d10, receiver=0xad0ade0, this=0x8be7f20) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x8be7f20, receiver=0xad0ade0, e=0xac337d10) at kernel/qapplication.cpp:4531
#13 0xb696f30d in QApplication::notify (this=0xac337d10, receiver=0xad0ade0, e=0xac337d10) at kernel/qapplication.cpp:4288
#14 0xb74ef401 in KApplication::notify (this=0xbfeacc74, receiver=0xad0ade0, event=0xac337d10) at ../../kdeui/kernel/kapplication.cpp:311
#15 0xb63fc97e in QCoreApplication::notifyInternal (this=0xbfeacc74, receiver=0xad0ade0, event=0xac337d10) at kernel/qcoreapplication.cpp:876
#16 0xb6400ad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8bbfab8) at kernel/qcoreapplication.cpp:1500
#18 0xb6400e0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0xb642f494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x8beb058) at kernel/qeventdispatcher_glib.cpp:279
#21 0xb390ed86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0xb390f125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb390f201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb642f887 in QEventDispatcherGlib::processEvents (this=0x8bc0800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0xb6a22aaa in QGuiEventDispatcherGlib::processEvents (this=0x8bc0800, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0xb63fb50d in QEventLoop::processEvents (this=0xbfeacbd4, flags=...) at kernel/qeventloop.cpp:149
#27 0xb63fb7a9 in QEventLoop::exec (this=0xbfeacbd4, flags=...) at kernel/qeventloop.cpp:204
#28 0xb6400eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0xb6967a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#30 0x0804ac91 in main (argc=<error reading variable: Cannot access memory at address 0x3>, argv=<error reading variable: Cannot access memory at address 0x7>) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 302692, bug 302641, bug 302394, bug 302233, bug 301949.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-04 20:45:12 UTC

*** This bug has been marked as a duplicate of bug 286307 ***