Bug 302692 - Kmail krashafter deleting an email and reading next email with links
Summary: Kmail krashafter deleting an email and reading next email with links
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-28 11:18 UTC by Alan House
Modified: 2012-07-03 07:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan House 2012-06-28 11:18:47 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.2
Operating System: Linux 3.4.3-1.fc17.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

Deleted a "text" email, krashed while loading an email from Walgreens with rich text and links.

Why is this still happening? Does not happen with the openSUSE version. Can't this group fix the problem. Tell me how to get the fix, not just "this is a duplicate". This group is supposed to help - well???????

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fd5313ae880 (LWP 23407))]

Thread 3 (Thread 0x7fd525b4f700 (LWP 23408)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00000030c361677d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x30c40009a0) at wtf/FastMalloc.cpp:2495
#2  0x00000030c3616889 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x0000003f42407d14 in start_thread (arg=0x7fd525b4f700) at pthread_create.c:309
#4  0x0000003f420f199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fd52524e700 (LWP 23409)):
#0  0x0000003f420e8eef in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003bb80479b4 in g_main_context_poll (n_fds=1, fds=0x7fd5200029c0, timeout=5626, context=0x7fd5200009a0, priority=<optimized out>) at gmain.c:3440
#2  g_main_context_iterate (context=context@entry=0x7fd5200009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3141
#3  0x0000003bb8047ad4 in g_main_context_iteration (context=0x7fd5200009a0, may_block=1) at gmain.c:3207
#4  0x0000003cfbda4506 in QEventDispatcherGlib::processEvents (this=0x7fd5200008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003cfbd7513f in QEventLoop::processEvents (this=this@entry=0x7fd52524dd20, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003cfbd753c8 in QEventLoop::exec (this=0x7fd52524dd20, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003cfbc78650 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003cfbc7b5eb in QThreadPrivate::start (arg=0x2507210) at thread/qthread_unix.cpp:307
#9  0x0000003f42407d14 in start_thread (arg=0x7fd52524e700) at pthread_create.c:309
#10 0x0000003f420f199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fd5313ae880 (LWP 23407)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x45b0680, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#7  0x00000030bbce8b8a in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x45b0680, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:90
#8  0x0000003cfbd8acee in QObject::event (this=0x45b0680, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00000039b73ca37c in QApplicationPrivate::notify_helper (this=this@entry=0x2507de0, receiver=receiver@entry=0x45b0680, e=e@entry=0x7fd4cc016020) at kernel/qapplication.cpp:4551
#10 0x00000039b73ce7fa in QApplication::notify (this=0x7fff7b3f5340, receiver=0x45b0680, e=0x7fd4cc016020) at kernel/qapplication.cpp:4412
#11 0x00000030bc845a56 in KApplication::notify (this=0x7fff7b3f5340, receiver=0x45b0680, event=0x7fd4cc016020) at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#12 0x0000003cfbd763ee in QCoreApplication::notifyInternal (this=0x7fff7b3f5340, receiver=receiver@entry=0x45b0680, event=event@entry=0x7fd4cc016020) at kernel/qcoreapplication.cpp:915
#13 0x0000003cfbd79ea1 in sendEvent (event=0x7fd4cc016020, receiver=0x45b0680) at kernel/qcoreapplication.h:231
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x24c45e0) at kernel/qcoreapplication.cpp:1539
#15 0x0000003cfbda4353 in sendPostedEvents () at kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=s@entry=0x24fb8f0) at kernel/qeventdispatcher_glib.cpp:279
#17 0x0000003bb80476e5 in g_main_dispatch (context=0x250bae0) at gmain.c:2539
#18 g_main_context_dispatch (context=context@entry=0x250bae0) at gmain.c:3075
#19 0x0000003bb8047a18 in g_main_context_iterate (context=context@entry=0x250bae0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3146
#20 0x0000003bb8047ad4 in g_main_context_iteration (context=0x250bae0, may_block=1) at gmain.c:3207
#21 0x0000003cfbda44e6 in QEventDispatcherGlib::processEvents (this=0x24c5ec0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00000039b746a2ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#23 0x0000003cfbd7513f in QEventLoop::processEvents (this=this@entry=0x7fff7b3f51b0, flags=...) at kernel/qeventloop.cpp:149
#24 0x0000003cfbd753c8 in QEventLoop::exec (this=0x7fff7b3f51b0, flags=...) at kernel/qeventloop.cpp:204
#25 0x0000003cfbd7a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#26 0x0000000000403459 in ?? ()
#27 0x0000003f42021735 in __libc_start_main (main=0x402c60, argc=1, ubp_av=0x7fff7b3f5488, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7b3f5478) at libc-start.c:226
#28 0x0000000000403991 in _start ()

Possible duplicates by query: bug 302641, bug 302394, bug 302233, bug 301949, bug 301652.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-03 07:57:55 UTC

*** This bug has been marked as a duplicate of bug 286307 ***