Bug 302394 - Kontact crashed while working through my mails
Summary: Kontact crashed while working through my mails
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-23 10:35 UTC by Kai Krakow
Modified: 2012-07-03 08:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Krakow 2012-06-23 10:35:25 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.4.2-gentoo-r1 x86_64
Distribution: "Gentoo Base System release 2.1"

-- Information about the crash:
- What I was doing when the application crashed:

Part of my workflow is to check all my mail folders, selecting multiple mails with ctrl+click and move them to the correct folders if my automatic sorting filter did it wrong. This is usually a pretty quick procedure: select a few mails within seconds, point, click, drag to another folder. Usually, when I then select the next folder, Kontacts can become unresponsive for a few seconds. Sometimes when this happens, the result is a crash.

I suspect from the behaviour this is probably a timing or locking issue when accessing the resources and internal data structures I moved around.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa0f22d0780 (LWP 8423))]

Thread 3 (Thread 0x7fa0d72d8700 (LWP 8424)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0eea51744 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/qt4/libQtWebKit.so.4
#2  0x00007fa0ea029d0c in start_thread (arg=0x7fa0d72d8700) at pthread_create.c:301
#3  0x00007fa0ef7a1d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fa0d69d7700 (LWP 8426)):
#0  0x00007fa0ef798e93 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa0e8e69da3 in g_main_context_poll (n_fds=1, fds=0x126ed90, timeout=-1, context=0x126e330, priority=<optimized out>) at gmain.c:3402
#2  g_main_context_iterate (context=0x126e330, block=1, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x00007fa0e8e6a271 in g_main_context_iteration (context=0x126e330, may_block=1) at gmain.c:3152
#4  0x00007fa0f0c13e86 in QEventDispatcherGlib::processEvents (this=0x126dec0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fa0f0be3b32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa0f0be3ded in QEventLoop::exec (this=0x7fa0d69d6e00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa0f0ae0108 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fa0f0ae278b in QThreadPrivate::start (arg=0x126d7e0) at thread/qthread_unix.cpp:298
#9  0x00007fa0ea029d0c in start_thread (arg=0x7fa0d69d7700) at pthread_create.c:301
#10 0x00007fa0ef7a1d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fa0f22d0780 (LWP 8423)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fa0eaf61d46 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x7fa080095ab0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x00007fa0eafe5115 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x7fa080095ab0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x00007fa0f0bf97a6 in QObject::event (this=0x7fa080095ab0, e=<optimized out>) at kernel/qobject.cpp:1195
#10 0x00007fa0eff3b974 in QApplicationPrivate::notify_helper (this=0x1255120, receiver=0x7fa080095ab0, e=0x45a3170) at kernel/qapplication.cpp:4554
#11 0x00007fa0eff4059d in QApplication::notify (this=<optimized out>, receiver=0x7fa080095ab0, e=0x45a3170) at kernel/qapplication.cpp:4415
#12 0x00007fa0f1686986 in KApplication::notify (this=0x7fff4acdda50, receiver=0x7fa080095ab0, event=0x45a3170) at /var/tmp/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#13 0x00007fa0f0be4b0c in QCoreApplication::notifyInternal (this=0x7fff4acdda50, receiver=0x7fa080095ab0, event=0x45a3170) at kernel/qcoreapplication.cpp:876
#14 0x00007fa0f0be80f0 in sendEvent (event=0x45a3170, receiver=0x7fa080095ab0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<optimized out>, data=0x1220830) at kernel/qcoreapplication.cpp:1500
#16 0x00007fa0f0c13c93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fa0e8e6988f in g_main_dispatch (context=0x12574e0) at gmain.c:2441
#19 g_main_context_dispatch (context=0x12574e0) at gmain.c:3011
#20 0x00007fa0e8e6a098 in g_main_context_iterate (context=0x12574e0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3089
#21 0x00007fa0e8e6a271 in g_main_context_iteration (context=0x12574e0, may_block=1) at gmain.c:3152
#22 0x00007fa0f0c13e2f in QEventDispatcherGlib::processEvents (this=0x12200c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007fa0effe1d1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007fa0f0be3b32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007fa0f0be3ded in QEventLoop::exec (this=0x7fff4acdd9a0, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007fa0f0be858b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x000000000040449f in main (argc=1, argv=0x7fff4acde078) at /var/tmp/portage/kde-base/kontact-4.8.3/work/kontact-4.8.3/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 301652, bug 301949.

Possible duplicates by query: bug 302233, bug 301949, bug 301652, bug 301319, bug 301168.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-03 08:12:22 UTC

*** This bug has been marked as a duplicate of bug 286307 ***