Bug 302233 - Kontact crashes when deleting email
Summary: Kontact crashes when deleting email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-20 12:26 UTC by Darryl
Modified: 2012-07-03 08:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darryl 2012-06-20 12:26:27 UTC
Application: kontact (4.9 beta2)
KDE Platform Version: 4.8.90 (4.8.90)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Sometimes when I delete an email message, Kontact will crash. I'm currently running Version 4.9 beta2 on KDE Platform Version 4.8.90 (4.8.90),  Kubuntu 12.04

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3db3c117c0 (LWP 10433))]

Thread 4 (Thread 0x7f3d967a5700 (LWP 10556)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3db0417dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f3db0417f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f3dab8cbe9a in start_thread (arg=0x7f3d967a5700) at pthread_create.c:308
#4  0x00007f3db11494bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3d95ea4700 (LWP 10559)):
#0  0x00007f3db113db03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3dab3ff036 in g_main_context_poll (n_fds=1, fds=0x7f3d900029c0, timeout=7677, context=0x7f3d900009a0, priority=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3440
#2  g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x7f3d900009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3141
#3  g_main_context_iterate (context=0x7f3d900009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#4  0x00007f3dab3ff164 in g_main_context_iteration (context=0x7f3d900009a0, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#5  0x00007f3db18be426 in QEventDispatcherGlib::processEvents (this=0x7f3d900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f3db188dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3db188ded7 in QEventLoop::exec (this=0x7f3d95ea3dc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3db178cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f3db178ffcb in QThreadPrivate::start (arg=0x1269130) at thread/qthread_unix.cpp:298
#10 0x00007f3dab8cbe9a in start_thread (arg=0x7f3d95ea4700) at pthread_create.c:308
#11 0x00007f3db11494bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3d47f06700 (LWP 10730)):
#0  0x00007f3db113db03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3dab3ff036 in g_main_context_poll (n_fds=1, fds=0x7f3d400029b0, timeout=-1, context=0x7f3d400009a0, priority=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3440
#2  g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x7f3d400009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3141
#3  g_main_context_iterate (context=0x7f3d400009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#4  0x00007f3dab3ff164 in g_main_context_iteration (context=0x7f3d400009a0, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#5  0x00007f3db18be426 in QEventDispatcherGlib::processEvents (this=0x7f3d400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f3db188dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3db188ded7 in QEventLoop::exec (this=0x7f3d47f05d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3db178cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f3db186d9ff in QInotifyFileSystemWatcherEngine::run (this=0x1cfbe80) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f3db178ffcb in QThreadPrivate::start (arg=0x1cfbe80) at thread/qthread_unix.cpp:298
#11 0x00007f3dab8cbe9a in start_thread (arg=0x7f3d47f06700) at pthread_create.c:308
#12 0x00007f3db11494bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3db3c117c0 (LWP 10433)):
[KCrash Handler]
#6  0x0000000000000002 in ?? ()
#7  0x00007f3dac715eef in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3406290, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x00007f3dac7a1709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3406290, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x00007f3db18a8446 in QObject::event (this=0x3406290, e=<optimized out>) at kernel/qobject.cpp:1195
#10 0x00007f3db2289894 in notify_helper (e=0x7f3d1c0050a0, receiver=0x3406290, this=0x11ec350) at kernel/qapplication.cpp:4559
#11 QApplicationPrivate::notify_helper (this=0x11ec350, receiver=0x3406290, e=0x7f3d1c0050a0) at kernel/qapplication.cpp:4531
#12 0x00007f3db228e713 in QApplication::notify (this=0x7fff5775cb50, receiver=0x3406290, e=0x7f3d1c0050a0) at kernel/qapplication.cpp:4420
#13 0x00007f3db2fc39e6 in KApplication::notify (this=0x7fff5775cb50, receiver=0x3406290, event=0x7f3d1c0050a0) at ../../kdeui/kernel/kapplication.cpp:311
#14 0x00007f3db188ee9c in QCoreApplication::notifyInternal (this=0x7fff5775cb50, receiver=0x3406290, event=0x7f3d1c0050a0) at kernel/qcoreapplication.cpp:876
#15 0x00007f3db1892c6a in sendEvent (event=0x7f3d1c0050a0, receiver=0x3406290) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x11b6380) at kernel/qcoreapplication.cpp:1500
#17 0x00007f3db18bdf93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007f3dab3fed53 in g_main_dispatch (context=0x11ee520) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2539
#20 g_main_context_dispatch (context=0x11ee520) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3075
#21 0x00007f3dab3ff0a0 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x11ee520, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3146
#22 g_main_context_iterate (context=0x11ee520, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#23 0x00007f3dab3ff164 in g_main_context_iteration (context=0x11ee520, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#24 0x00007f3db18be3bf in QEventDispatcherGlib::processEvents (this=0x11b7c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f3db2331d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f3db188dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f3db188ded7 in QEventLoop::exec (this=0x7fff5775cae0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f3db1892f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403629 in main (argc=1, argv=0x7fff5775d178) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 301949, bug 301652, bug 301319, bug 301168, bug 300856.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-03 08:18:59 UTC

*** This bug has been marked as a duplicate of bug 286307 ***