Bug 301949 - Kontact crashes while selecting e-mails quickly
Summary: Kontact crashes while selecting e-mails quickly
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-15 07:38 UTC by jolay
Modified: 2012-07-03 08:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jolay 2012-06-15 07:38:26 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) "release 6"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: 

Very common operation : Quick multiple selection with Shift + Arrow Right
(I was on a DIMAP account)

1. Open all e-mail groups in kmail, then click one e-mail
2. Hold Shift key
3. Use Arrow key to multiselect next e-mails

Doing that TOO QUICKLY will crash kontact. Using Arrow key slowly should be fine...
That may be related to the "real time" display of the content of the selected e-mail (the corresponding panel does not gracefully abort loading the previous e-mail ?)

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fbacad11760 (LWP 28647))]

Thread 3 (Thread 0x7fbab1e9c700 (LWP 28648)):
#0  0x00007fbac2b9ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbac752ec12 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7fbac7ecd1a0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007fbac752ec49 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007fbac2b96f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbac822010d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fbab1583700 (LWP 28649)):
#0  0x00007fbac8216ff3 in poll () from /lib64/libc.so.6
#1  0x00007fbac2687a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fbac2687f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbac898ee36 in QEventDispatcherGlib::processEvents (this=0x7fbaac0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fbac895e842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbac895ea97 in QEventLoop::exec (this=0x7fbab1582e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbac885e5f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fbac886161b in QThreadPrivate::start (arg=0x7aa6c0) at thread/qthread_unix.cpp:307
#8  0x00007fbac2b96f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fbac822010d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fbacad11760 (LWP 28647)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x363e620, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#7  0x00007fbac3b62509 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x363e620, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fbac8978e06 in QObject::event (this=0x363e620, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007fbac9378fe4 in notify_helper (e=0x7fba5801f920, receiver=0x363e620, this=0x63f3d0) at kernel/qapplication.cpp:4551
#10 QApplicationPrivate::notify_helper (this=0x63f3d0, receiver=0x363e620, e=0x7fba5801f920) at kernel/qapplication.cpp:4523
#11 0x00007fbac937ddb3 in QApplication::notify (this=0x7fff055ed240, receiver=0x363e620, e=0x7fba5801f920) at kernel/qapplication.cpp:4412
#12 0x00007fbaca0bf746 in KApplication::notify (this=0x7fff055ed240, receiver=0x363e620, event=0x7fba5801f920) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#13 0x00007fbac895fd0c in QCoreApplication::notifyInternal (this=0x7fff055ed240, receiver=0x363e620, event=0x7fba5801f920) at kernel/qcoreapplication.cpp:915
#14 0x00007fbac89635ba in sendEvent (event=0x7fba5801f920, receiver=0x363e620) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60dc70) at kernel/qcoreapplication.cpp:1539
#16 0x00007fbac898e9a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x64a1d0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fbac268758d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007fbac2687d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007fbac2687f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fbac898edcf in QEventDispatcherGlib::processEvents (this=0x60d530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fbac941c69e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fbac895e842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fbac895ea97 in QEventLoop::exec (this=0x7fff055ed1d0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fbac89638b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#26 0x0000000000403919 in ?? ()
#27 0x00007fbac816623d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

This bug may be a duplicate of or related to bug 301652, bug 286307.

Possible duplicates by query: bug 301652, bug 301319, bug 301168, bug 300856, bug 300490.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-03 08:15:44 UTC

*** This bug has been marked as a duplicate of bug 286307 ***