Bug 301652 - Kontact crashes while deleting/selecting or scrolling through Mails
Summary: Kontact crashes while deleting/selecting or scrolling through Mails
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-11 14:52 UTC by Christian
Modified: 2012-07-03 08:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.92 KB, text/plain)
2012-06-14 15:39 UTC, Jessie A. Morris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2012-06-11 14:52:22 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

First I scrolled through new Mails. After a few seconds the Programm crashed
Then opened it again, selected a few Mail and wanted to delete them. Kontact crashed

Same if I only read Mails and scroll down...

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8d947fb7c0 (LWP 2877))]

Thread 4 (Thread 0x7f8d77bc1700 (LWP 2878)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8d90ff8dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f8d90ff8f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f8d8c4bee9a in start_thread (arg=0x7f8d77bc1700) at pthread_create.c:308
#4  0x00007f8d91d2a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f8d772a8700 (LWP 2879)):
#0  0x00007fffc05f78de in ?? ()
#1  0x00007f8d8a82215d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f8d923c7bb4 in do_gettime (frac=0x7f8d772a7be8, sec=0x7f8d772a7be0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f8d9249fb8d in QTimerInfoList::updateCurrentTime (this=0x7f8d70002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f8d9249f841 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x00007f8d8bff1a33 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f8d8bff1f96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f8d8bff2124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f8d9249f426 in QEventDispatcherGlib::processEvents (this=0x7f8d700008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f8d9246ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f8d9246eed7 in QEventLoop::exec (this=0x7f8d772a7dc0, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f8d9236dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f8d92370fcb in QThreadPrivate::start (arg=0x1af1940) at thread/qthread_unix.cpp:298
#15 0x00007f8d8c4bee9a in start_thread (arg=0x7f8d772a8700) at pthread_create.c:308
#16 0x00007f8d91d2a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f8d23b7c700 (LWP 2901)):
#0  0x00007f8d91d1eb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8d8bff1ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8d8bff2124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8d9249f426 in QEventDispatcherGlib::processEvents (this=0x7f8d1c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f8d9246ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8d9246eed7 in QEventLoop::exec (this=0x7f8d23b7bd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8d9236dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f8d9244e9ff in QInotifyFileSystemWatcherEngine::run (this=0x2ad9980) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8d92370fcb in QThreadPrivate::start (arg=0x2ad9980) at thread/qthread_unix.cpp:298
#9  0x00007f8d8c4bee9a in start_thread (arg=0x7f8d23b7c700) at pthread_create.c:308
#10 0x00007f8d91d2a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8d947fb7c0 (LWP 2877)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x5fd7f10, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f8d8d394709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x5fd7f10, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f8d92489446 in QObject::event (this=0x5fd7f10, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f8d92e65894 in notify_helper (e=0x7f8d10007750, receiver=0x5fd7f10, this=0x190f050) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x190f050, receiver=0x5fd7f10, e=0x7f8d10007750) at kernel/qapplication.cpp:4531
#11 0x00007f8d92e6a713 in QApplication::notify (this=0x7fffc04386c0, receiver=0x5fd7f10, e=0x7f8d10007750) at kernel/qapplication.cpp:4420
#12 0x00007f8d93b9ebb6 in KApplication::notify (this=0x7fffc04386c0, receiver=0x5fd7f10, event=0x7f8d10007750) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f8d9246fe9c in QCoreApplication::notifyInternal (this=0x7fffc04386c0, receiver=0x5fd7f10, event=0x7f8d10007750) at kernel/qcoreapplication.cpp:876
#14 0x00007f8d92473c6a in sendEvent (event=0x7f8d10007750, receiver=0x5fd7f10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x18d7380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f8d9249ef93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f8d8bff1c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f8d8bff2060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f8d8bff2124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f8d9249f3bf in QEventDispatcherGlib::processEvents (this=0x18d8c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f8d92f0dd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f8d9246ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f8d9246eed7 in QEventLoop::exec (this=0x7fffc0438650, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f8d92473f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in main (argc=1, argv=0x7fffc0438ce8) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 300478.

Possible duplicates by query: bug 301319, bug 301168, bug 300856, bug 300490, bug 300478.

Reported using DrKonqi
Comment 1 Jessie A. Morris 2012-06-14 15:39:38 UTC
Created attachment 71831 [details]
New crash information added by DrKonqi

kontact (4.8.3) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:

I also selected an email to read, and Kontact crashed. I re-opened Kontact, selected an email, and it crashed again.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4aedc50, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fa5b97c5709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4aedc50, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fa5be8ba446 in QObject::event (this=0x4aedc50, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fa5bf296894 in notify_helper (e=0x7fa55000d1d0, receiver=0x4aedc50, this=0x231b3a0) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x231b3a0, receiver=0x4aedc50, e=0x7fa55000d1d0) at kernel/qapplication.cpp:4531
Comment 2 Jekyll Wu 2012-07-03 08:13:48 UTC

*** This bug has been marked as a duplicate of bug 286307 ***