Bug 296624 - KMail crash on selecting mail
Summary: KMail crash on selecting mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-23 12:56 UTC by Thomas Tanghus
Modified: 2012-03-26 10:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Tanghus 2012-03-23 12:56:59 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

It happens *very* often, when I either select a mail or delete one so a new mail is selected, that I get this crash.
This morning I went through around 100 mails and I had around 10 crashes.
The reports I've marked as possible dupes have very similar backtraces, but not exactly so I chose to create a new report.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f608c12c7c0 (LWP 3483))]

Thread 4 (Thread 0x7f6070a24700 (LWP 3484)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f6088963c2c in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f608931a220) at wtf/FastMalloc.cpp:2495
#2  0x00007f6088963d59 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f6084130efc in start_thread (arg=0x7f6070a24700) at pthread_create.c:304
#4  0x00007f608967359d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6070123700 (LWP 3485)):
#0  0x00007f60841341fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1f7c528) at pthread_mutex_unlock.c:290
#2  0x00007f6083c5ed79 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6083c5f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6089de1c06 in QEventDispatcherGlib::processEvents (this=0x1f7c0f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f6089db13e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6089db1637 in QEventLoop::exec (this=0x7f6070122dc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f6089cb1067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f6089cb408b in QThreadPrivate::start (arg=0x1d98060) at thread/qthread_unix.cpp:298
#9  0x00007f6084130efc in start_thread (arg=0x7f6070123700) at pthread_create.c:304
#10 0x00007f608967359d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6024bce700 (LWP 3496)):
#0  0x00007f6084133034 in __pthread_mutex_lock (mutex=0x2cfea68) at pthread_mutex_lock.c:61
#1  0x00007f6083c5e023 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6083c5edfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6083c5f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6089de1c06 in QEventDispatcherGlib::processEvents (this=0x2cef1d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f6089db13e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6089db1637 in QEventLoop::exec (this=0x7f6024bcdd90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f6089cb1067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f6089d9117f in QInotifyFileSystemWatcherEngine::run (this=0x1fe3910) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f6089cb408b in QThreadPrivate::start (arg=0x1fe3910) at thread/qthread_unix.cpp:298
#10 0x00007f6084130efc in start_thread (arg=0x7f6024bce700) at pthread_create.c:304
#11 0x00007f608967359d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f608c12c7c0 (LWP 3483)):
[KCrash Handler]
#6  0x00007f6084ee2732 in node_copy (src=<optimized out>, to=0x3ac3618, from=0x228b2218, this=0x7fff377faa20) at ../../include/QtCore/../../src/corelib/tools/qlist.h:399
#7  QList<QPair<QByteArray, QByteArray> >::detach_helper (this=0x7fff377faa20, alloc=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:711
#8  0x00007f6084f2182d in detach_helper (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:725
#9  QList (this=<optimized out>, l=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#10 QList (l=<optimized out>, this=<optimized out>) at access/qabstractnetworkcache.cpp:238
#11 QNetworkCacheMetaData::rawHeaders (this=<optimized out>) at access/qabstractnetworkcache.cpp:240
#12 0x00007f6084f045ac in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x47c0170, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#13 0x00007f6084f05d04 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x47c0170, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#14 0x00007f6084f91299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x47c0170, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#15 0x00007f6089dcbba6 in QObject::event (this=0x47c0170, e=<optimized out>) at kernel/qobject.cpp:1195
#16 0x00007f608a7a6104 in notify_helper (e=0x3bdee10, receiver=0x47c0170, this=0x1d8f0c0) at kernel/qapplication.cpp:4555
#17 QApplicationPrivate::notify_helper (this=0x1d8f0c0, receiver=0x47c0170, e=0x3bdee10) at kernel/qapplication.cpp:4527
#18 0x00007f608a7aaf83 in QApplication::notify (this=0x7fff377fb7b0, receiver=0x47c0170, e=0x3bdee10) at kernel/qapplication.cpp:4416
#19 0x00007f608b4d89a6 in KApplication::notify (this=0x7fff377fb7b0, receiver=0x47c0170, event=0x3bdee10) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f6089db25fc in QCoreApplication::notifyInternal (this=0x7fff377fb7b0, receiver=0x47c0170, event=0x3bdee10) at kernel/qcoreapplication.cpp:876
#21 0x00007f6089db63ca in sendEvent (event=0x3bdee10, receiver=0x47c0170) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1d58380) at kernel/qcoreapplication.cpp:1500
#23 0x00007f6089de1773 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#25 0x00007f6083c5ea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f6083c5f258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f6083c5f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f6089de1b9f in QEventDispatcherGlib::processEvents (this=0x1d59c10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00007f608a84b21e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f6089db13e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f6089db1637 in QEventLoop::exec (this=0x7fff377fb740, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007f6089db66c7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x0000000000403629 in main (argc=1, argv=0x7fff377fbdd8) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 296617, bug 296485.

Possible duplicates by query: bug 296617, bug 296485, bug 296009, bug 295112, bug 294125.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-03-26 06:24:18 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 2 Thomas Tanghus 2012-03-26 10:56:59 UTC
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 286307 ***

Are you positive this is a dupe? To me the backtrace doesn't look like any of the ones in 286307.