Bug 301168 - kontact crashed when closing an email
Summary: kontact crashed when closing an email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-04 18:17 UTC by FranJPR
Modified: 2012-06-04 18:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FranJPR 2012-06-04 18:17:45 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I was reading an email, I closed it and then kontact crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb2188980 (LWP 1666))]

Thread 4 (Thread 0xafb7ab40 (LWP 1686)):
#0  0xb775c424 in __kernel_vsyscall ()
#1  0xb399396b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb60993dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb5817263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb581737f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb398fd4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb608bace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xaf251b40 (LWP 1687)):
#0  0xb38fc3bf in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb38bc755 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb38bcf6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb38bd1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb63db8e7 in QEventDispatcherGlib::processEvents (this=0xae900468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb63a750d in QEventLoop::processEvents (this=0xaf251270, flags=...) at kernel/qeventloop.cpp:149
#6  0xb63a77a9 in QEventLoop::exec (this=0xaf251270, flags=...) at kernel/qeventloop.cpp:204
#7  0xb629094c in QThread::exec (this=0x9dbca28) at thread/qthread.cpp:501
#8  0xb6290a3b in QThread::run (this=0x9dbca28) at thread/qthread.cpp:568
#9  0xb6293de0 in QThreadPrivate::start (arg=0x9dbca28) at thread/qthread_unix.cpp:298
#10 0xb398fd4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb608bace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xab8dab40 (LWP 2486)):
#0  0xb3889e70 in pthread_mutex_unlock@plt () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb38fc3d0 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb38bca66 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb38bd002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb38bd1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63db8e7 in QEventDispatcherGlib::processEvents (this=0xa482cd0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63a750d in QEventLoop::processEvents (this=0xab8da240, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63a77a9 in QEventLoop::exec (this=0xab8da240, flags=...) at kernel/qeventloop.cpp:204
#8  0xb629094c in QThread::exec (this=0xa090cb0) at thread/qthread.cpp:501
#9  0xb6384b5d in QInotifyFileSystemWatcherEngine::run (this=0xa090cb0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6293de0 in QThreadPrivate::start (arg=0xa090cb0) at thread/qthread_unix.cpp:298
#11 0xb398fd4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb608bace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb2188980 (LWP 1666)):
[KCrash Handler]
#7  0x08890000 in ?? ()
#8  0xb3afc254 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xb9d9c98, hm=..., sc=-1081493144, rp=..., pu=false, db=..., contentLength=-1279680068) at access/qnetworkaccesshttpbackend.cpp:827
#9  0xb3b9337d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xb9d9c98, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xac81a820) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#10 0xb63bac01 in QMetaCallEvent::placeMetaCall (this=0xac81a7d8, object=0xb9d9c98) at kernel/qobject.cpp:525
#11 0xb63c3c7b in QObject::event (this=0xb9d9c98, e=0xac81a7d8) at kernel/qobject.cpp:1195
#12 0xb6910ed4 in notify_helper (e=0xac81a7d8, receiver=0xb9d9c98, this=0x9db44e8) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x9db44e8, receiver=0xb9d9c98, e=0xac81a7d8) at kernel/qapplication.cpp:4531
#14 0xb691630d in QApplication::notify (this=0xac81a7d8, receiver=0xb9d9c98, e=0xac81a7d8) at kernel/qapplication.cpp:4288
#15 0xb7495b61 in KApplication::notify (this=0xbf89c1e4, receiver=0xb9d9c98, event=0xac81a7d8) at ../../kdeui/kernel/kapplication.cpp:311
#16 0xb63a897e in QCoreApplication::notifyInternal (this=0xbf89c1e4, receiver=0xb9d9c98, event=0xac81a7d8) at kernel/qcoreapplication.cpp:876
#17 0xb63acad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9d8aab8) at kernel/qcoreapplication.cpp:1500
#19 0xb63ace0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#20 0xb63db494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x9db7580) at kernel/qeventdispatcher_glib.cpp:279
#22 0xb38bccda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb38bd0e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb38bd1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb63db887 in QEventDispatcherGlib::processEvents (this=0x9d8b818, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0xb69c9aaa in QGuiEventDispatcherGlib::processEvents (this=0x9d8b818, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0xb63a750d in QEventLoop::processEvents (this=0xbf89c144, flags=...) at kernel/qeventloop.cpp:149
#28 0xb63a77a9 in QEventLoop::exec (this=0xbf89c144, flags=...) at kernel/qeventloop.cpp:204
#29 0xb63aceba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0xb690ea74 in QApplication::exec () at kernel/qapplication.cpp:3820
#31 0x0804ac91 in main (argc=<error reading variable: Cannot access memory at address 0x3>, argv=<error reading variable: Cannot access memory at address 0x7>) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 300856, bug 300490, bug 300478, bug 300406, bug 300398.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-04 18:33:18 UTC

*** This bug has been marked as a duplicate of bug 286307 ***