Bug 301319 - Kontact-kmail crashed
Summary: Kontact-kmail crashed
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 05:05 UTC by Pieyre Philippe
Modified: 2012-06-07 06:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pieyre Philippe 2012-06-07 05:05:25 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.3.6-desktop-2.mga2 i686
Distribution: "Mageia 2"

-- Information about the crash:
- What I was doing when the application crashed: Sometime when i try to delete a email, some other time when i try to move the email from the inbox to an other place

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i686/libthread_db.so.1".
[Current thread is 1 (Thread 0xb20c6710 (LWP 2587))]

Thread 3 (Thread 0xb0e85b70 (LWP 2589)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb3b6925b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb608793c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libc.so.6
#3  0xb58058cb in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb58059ef in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb3b65a37 in start_thread () from /lib/i686/libpthread.so.0
#6  0xb607998e in clone () from /lib/i686/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xb055cb70 (LWP 2590)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb606efee in poll () from /lib/i686/libc.so.6
#2  0xb3a9083b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb3a82e2e in ?? () from /lib/libglib-2.0.so.0
#4  0xb3a82f81 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb63b6207 in QEventDispatcherGlib::processEvents (this=0xafc00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb638240d in QEventLoop::processEvents (this=0xb055c2d0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63826a9 in QEventLoop::exec (this=0xb055c2d0, flags=...) at kernel/qeventloop.cpp:204
#8  0xb626c67c in QThread::exec (this=0x9401eb0) at thread/qthread.cpp:501
#9  0xb626c76b in QThread::run (this=0x9401eb0) at thread/qthread.cpp:568
#10 0xb626fb60 in QThreadPrivate::start (arg=0x9401eb0) at thread/qthread_unix.cpp:298
#11 0xb3b65a37 in start_thread () from /lib/i686/libpthread.so.0
#12 0xb607998e in clone () from /lib/i686/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb20c6710 (LWP 2587)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xa63c008, hm=) at access/qnetworkaccesshttpbackend.cpp:827
#8  0xb3d1df7d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xa63c008, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xa4a1e98) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0xb6395421 in QMetaCallEvent::placeMetaCall (this=0xa4a1f18, object=0xa63c008) at kernel/qobject.cpp:525
#10 0xb639e57b in QObject::event (this=0xa63c008, e=0xa4a1f18) at kernel/qobject.cpp:1195
#11 0xb68b2cf4 in notify_helper (e=0xa4a1f18, receiver=0xa63c008, this=0x92f3608) at kernel/qapplication.cpp:4554
#12 QApplicationPrivate::notify_helper (this=0x92f3608, receiver=0xa63c008, e=0xa4a1f18) at kernel/qapplication.cpp:4526
#13 0xb68b8103 in QApplication::notify (this=0xa4a1f18, receiver=0xa63c008, e=0xa4a1f18) at kernel/qapplication.cpp:4283
#14 0xb7393741 in KApplication::notify (this=0xbfd331d4, receiver=0xa63c008, event=0xa4a1f18) at /usr/src/debug/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#15 0xb638389e in QCoreApplication::notifyInternal (this=0xbfd331d4, receiver=0xa63c008, event=0xa4a1f18) at kernel/qcoreapplication.cpp:876
#16 0xb63874c8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x92c7a98) at kernel/qcoreapplication.cpp:1500
#18 0xb63877fc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0xb63b5db4 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x92f0880) at kernel/qeventdispatcher_glib.cpp:279
#21 0xb3a82a9a in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0xb3a82ea5 in ?? () from /lib/libglib-2.0.so.0
#23 0xb3a82f81 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0xb63b61a7 in QEventDispatcherGlib::processEvents (this=0x92c87e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0xb696665a in QGuiEventDispatcherGlib::processEvents (this=0x92c87e0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0xb638240d in QEventLoop::processEvents (this=0xbfd33134, flags=...) at kernel/qeventloop.cpp:149
#27 0xb63826a9 in QEventLoop::exec (this=0xbfd33134, flags=...) at kernel/qeventloop.cpp:204
#28 0xb63878aa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0xb68b0b64 in QApplication::exec () at kernel/qapplication.cpp:3815
#30 0x0804ad01 in main (argc=) at /usr/src/debug/kdepim-4.8.2/kontact/src/main.cpp:218

Possible duplicates by query: bug 301168, bug 300856, bug 300490, bug 300478, bug 300406.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-06-07 06:02:27 UTC

*** This bug has been marked as a duplicate of bug 286307 ***