Bug 300856 - Kontact crashed when I try to delete email
Summary: Kontact crashed when I try to delete email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-30 09:06 UTC by Francesco
Modified: 2012-06-04 18:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco 2012-05-30 09:06:08 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.4.0-030400-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

 crashed when I try to delete email 
Application: Kontact (kontact), signal: Segmentation fault

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fde01cfa7c0 (LWP 8430))]

Thread 10 (Thread 0x7fddfa90c700 (LWP 8431)):
#0  0x0000003b5fee6b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003b61a47ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x0000003b61a4845a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fddfa91198b in ?? () from /usr/lib/x86_64-linux-gnu/gio/modules/libdconfsettings.so
#4  0x0000003b61a699a5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x0000003b60607e9a in start_thread (arg=0x7fddfa90c700) at pthread_create.c:308
#6  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fddfa0e1700 (LWP 8432)):
#0  0x0000003b6060b05d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7fddf4010300) at pthread_mutex_unlock.c:290
#2  0x0000003b61a83591 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x0000003b61a476dd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x0000003b61a47f1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x0000003b61a4845a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fddfed812c6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#7  0x0000003b61a699a5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x0000003b60607e9a in start_thread (arg=0x7fddfa0e1700) at pthread_create.c:308
#9  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fdde7d72700 (LWP 8434)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003dd25cbdec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x0000003dd25cbf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x0000003b60607e9a in start_thread (arg=0x7fdde7d72700) at pthread_create.c:308
#4  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fdde7471700 (LWP 8435)):
#0  0x0000003b5fee6b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003b61a47ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x0000003b61a48124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x0000003b6b7aa426 in QEventDispatcherGlib::processEvents (this=0x7fdde00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x0000003b6b779c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003b6b779ed7 in QEventLoop::exec (this=0x7fdde7470dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003b6b678fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x0000003b6b67bfcb in QThreadPrivate::start (arg=0x23d27d0) at thread/qthread_unix.cpp:298
#8  0x0000003b60607e9a in start_thread (arg=0x7fdde7471700) at pthread_create.c:308
#9  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fdd97a93700 (LWP 8440)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x0000003b6b67c43f in wait (time=30000, this=0x2d21e60) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2d21e08, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003b6b66f5bf in QThreadPoolThread::run (this=0x2d35d50) at concurrent/qthreadpool.cpp:141
#4  0x0000003b6b67bfcb in QThreadPrivate::start (arg=0x2d35d50) at thread/qthread_unix.cpp:298
#5  0x0000003b60607e9a in start_thread (arg=0x7fdd97a93700) at pthread_create.c:308
#6  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fdd967fc700 (LWP 8451)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x0000003b6b67c43f in wait (time=30000, this=0x362e5d0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x362e548, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003b6b66f5bf in QThreadPoolThread::run (this=0x362fd50) at concurrent/qthreadpool.cpp:141
#4  0x0000003b6b67bfcb in QThreadPrivate::start (arg=0x362fd50) at thread/qthread_unix.cpp:298
#5  0x0000003b60607e9a in start_thread (arg=0x7fdd967fc700) at pthread_create.c:308
#6  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fdd94814700 (LWP 8538)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x0000003b6b67c43f in wait (time=30000, this=0x7fdd8c0066a0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fdd8c006648, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003b6b66f5bf in QThreadPoolThread::run (this=0x7fdd8c006970) at concurrent/qthreadpool.cpp:141
#4  0x0000003b6b67bfcb in QThreadPrivate::start (arg=0x7fdd8c006970) at thread/qthread_unix.cpp:298
#5  0x0000003b60607e9a in start_thread (arg=0x7fdd94814700) at pthread_create.c:308
#6  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fdd87bf4700 (LWP 8539)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x0000003b6b67c43f in wait (time=30000, this=0x7fdd8c0066a0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fdd8c006648, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003b6b66f5bf in QThreadPoolThread::run (this=0x7fdd8c00aa90) at concurrent/qthreadpool.cpp:141
#4  0x0000003b6b67bfcb in QThreadPrivate::start (arg=0x7fdd8c00aa90) at thread/qthread_unix.cpp:298
#5  0x0000003b60607e9a in start_thread (arg=0x7fdd87bf4700) at pthread_create.c:308
#6  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fdd871f3700 (LWP 8572)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x0000003b6b67c43f in wait (time=30000, this=0x7fdd8c0066a0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fdd8c006648, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003b6b66f5bf in QThreadPoolThread::run (this=0x7fddf0011620) at concurrent/qthreadpool.cpp:141
#4  0x0000003b6b67bfcb in QThreadPrivate::start (arg=0x7fddf0011620) at thread/qthread_unix.cpp:298
#5  0x0000003b60607e9a in start_thread (arg=0x7fdd871f3700) at pthread_create.c:308
#6  0x0000003b5fef24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fde01cfa7c0 (LWP 8430)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4e07940, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x0000003b6c0fa709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4e07940, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003b6b794446 in QObject::event (this=0x4e07940, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x0000003b6fbcb894 in notify_helper (e=0x7fdd8c00dc80, receiver=0x4e07940, this=0x23c6b00) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x23c6b00, receiver=0x4e07940, e=0x7fdd8c00dc80) at kernel/qapplication.cpp:4531
#11 0x0000003b6fbd0713 in QApplication::notify (this=0x7fffaf943d20, receiver=0x4e07940, e=0x7fdd8c00dc80) at kernel/qapplication.cpp:4420
#12 0x0000003328636bb6 in KApplication::notify (this=0x7fffaf943d20, receiver=0x4e07940, event=0x7fdd8c00dc80) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x0000003b6b77ae9c in QCoreApplication::notifyInternal (this=0x7fffaf943d20, receiver=0x4e07940, event=0x7fdd8c00dc80) at kernel/qcoreapplication.cpp:876
#14 0x0000003b6b77ec6a in sendEvent (event=0x7fdd8c00dc80, receiver=0x4e07940) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2390380) at kernel/qcoreapplication.cpp:1500
#16 0x0000003b6b7a9f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003b61a47c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x0000003b61a48060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x0000003b61a48124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x0000003b6b7aa3bf in QEventDispatcherGlib::processEvents (this=0x2391c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x0000003b6fc73d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x0000003b6b779c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x0000003b6b779ed7 in QEventLoop::exec (this=0x7fffaf943cb0, flags=...) at kernel/qeventloop.cpp:204
#25 0x0000003b6b77ef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in main (argc=1, argv=0x7fffaf944348) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 300490, bug 300478, bug 300406, bug 300398, bug 300192.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-04 18:33:06 UTC

*** This bug has been marked as a duplicate of bug 286307 ***