Bug 300490 - KMail crashes when replying to an email
Summary: KMail crashes when replying to an email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Chakra Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-23 07:31 UTC by Joachim Wilke
Modified: 2012-05-23 10:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Wilke 2012-05-23 07:31:14 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2-CHAKRA x86_64
Distribution: "Chakra Linux"

-- Information about the crash:
- What I was doing when the application crashed:
* Have an HTML mail open
* Press 'R' to reply to this mail
* KMail chrashes
* After restart, KMail opens with its main window _and_ the window to write the reply, however the lines of the quoted mail are broken shorter than normal

The crash does not seem to be reproducible.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5c99487780 (LWP 13310))]

Thread 3 (Thread 0x7f5c7d539700 (LWP 13311)):
#0  0x00007f5c90e39aa4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f5c95890b6d in WTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib/libQtWebKit.so.4
#2  0x00007f5c95890c79 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib/libQtWebKit.so.4
#3  0x00007f5c90e35ede in start_thread () from /lib/libpthread.so.0
#4  0x00007f5c965dc60d in clone () from /lib/libc.so.6

Thread 2 (Thread 0x7f5c7cc38700 (LWP 13312)):
#0  0x00007f5c9085f670 in pthread_mutex_unlock@plt () from /usr/lib/libglib-2.0.so.0
#1  0x00007f5c908c8861 in g_mutex_unlock () from /usr/lib/libglib-2.0.so.0
#2  0x00007f5c9088cfd3 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#3  0x00007f5c9088d7db in ?? () from /usr/lib/libglib-2.0.so.0
#4  0x00007f5c9088d9e4 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0x00007f5c96d9d51a in QEventDispatcherGlib::processEvents (this=0x7f5c780008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f5c96d5dea0 in QEventLoop::processEvents (this=0x7f5c7cc37d90, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f5c96d5e034 in QEventLoop::exec (this=0x7f5c7cc37d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f5c96c23723 in QThread::exec (this=0x1702410) at thread/qthread.cpp:501
#9  0x00007f5c96c238d0 in QThread::run (this=0x1702410) at thread/qthread.cpp:568
#10 0x00007f5c96c260a8 in QThreadPrivate::start (arg=0x1702410) at thread/qthread_unix.cpp:298
#11 0x00007f5c90e35ede in start_thread () from /lib/libpthread.so.0
#12 0x00007f5c965dc60d in clone () from /lib/libc.so.6

Thread 1 (Thread 0x7f5c99487780 (LWP 13310)):
[KCrash Handler]
#6  0x00007f5c91da2980 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xa7a6e80, hm=..., sc=304, rp=..., pu=false, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f5c91e32055 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xa7a6e80, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x7f5c18006fb0) at .moc/debug-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f5c96d78867 in QMetaCallEvent::placeMetaCall (this=0x7f5c18007a00, object=0xa7a6e80) at kernel/qobject.cpp:525
#9  0x00007f5c96d79af9 in QObject::event (this=0xa7a6e80, e=0x7f5c18007a00) at kernel/qobject.cpp:1195
#10 0x00007f5c977e769a in QApplicationPrivate::notify_helper (this=0x1557c00, receiver=0xa7a6e80, e=0x7f5c18007a00) at kernel/qapplication.cpp:4554
#11 0x00007f5c977e4b96 in QApplication::notify (this=0x7fff7816b3b0, receiver=0xa7a6e80, e=0x7f5c18007a00) at kernel/qapplication.cpp:3936
#12 0x00007f5c98849e06 in KApplication::notify (this=0x7fff7816b3b0, receiver=0xa7a6e80, event=0x7f5c18007a00) at /chakra/desktop-testing/kdelibs/src/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#13 0x00007f5c96d60710 in QCoreApplication::notifyInternal (this=0x7fff7816b3b0, receiver=0xa7a6e80, event=0x7f5c18007a00) at kernel/qcoreapplication.cpp:876
#14 0x00007f5c96d643a7 in QCoreApplication::sendEvent (receiver=0xa7a6e80, event=0x7f5c18007a00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 0x00007f5c96d61750 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x14fc930) at kernel/qcoreapplication.cpp:1500
#16 0x00007f5c96d6136d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#17 0x00007f5c96d9dc5b in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#18 0x00007f5c96d9cc41 in postEventSourceDispatch (s=0x15547f0) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007f5c9088d55a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0x00007f5c9088d920 in ?? () from /usr/lib/libglib-2.0.so.0
#21 0x00007f5c9088d9e4 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#22 0x00007f5c96d9d4f7 in QEventDispatcherGlib::processEvents (this=0x14fddf0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007f5c978c35aa in QGuiEventDispatcherGlib::processEvents (this=0x14fddf0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007f5c96d60b2c in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:1063
#25 0x00007f5c347cc6e7 in Message::KMeditor::ensureCursorVisible (this=0xb8b6cc0) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/messagecomposer/kmeditor.cpp:551
#26 0x00007f5c347cc77d in Message::KMeditor::setCursorPositionFromStart (this=0xb8b6cc0, pos=970) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/messagecomposer/kmeditor.cpp:488
#27 0x00007f5c347bc595 in Message::ComposerViewBase::setMessage (this=0xd260ca0, msg=...) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/messagecomposer/composerviewbase.cpp:186
#28 0x00007f5c3510ee75 in KMComposeWin::setMsg (this=0x223ded0, newMsg=..., mayAutoSign=true, allowDecryption=<optimized out>, isModified=false) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kmail/kmcomposewin.cpp:1481
#29 0x00007f5c35112335 in KMComposeWin::KMComposeWin (this=0x223ded0, aMsg=..., context=<optimized out>, id=<optimized out>, textSelection=<optimized out>, customTemplate=<optimized out>, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kmail/kmcomposewin.cpp:453
#30 0x00007f5c351132f5 in KMComposeWin::create (msg=..., context=KMail::Composer::Reply, identity=0, textSelection=..., customTemplate=...) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kmail/kmcomposewin.cpp:168
#31 0x00007f5c350add89 in KMReplyCommand::execute (this=0x8152fb0) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kmail/kmcommands.cpp:818
#32 0x00007f5c350ace31 in KMCommand::slotPostTransfer (this=0x8152fb0, result=KMCommand::OK) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kmail/kmcommands.cpp:268
#33 0x00007f5c96d7f059 in QMetaObject::activate (sender=0x8152fb0, m=0x7f5c353b5ee0, local_signal_index=0, argv=0x7fff7816a410) at kernel/qobject.cpp:3547
#34 0x00007f5c350acc3e in KMCommand::messagesTransfered (this=<optimized out>, _t1=KMCommand::OK) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kmail/kmcommands.moc:117
#35 0x00007f5c350b15ba in KMCommand::slotJobFinished (this=0x8152fb0) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kmail/kmcommands.cpp:378
#36 0x00007f5c96d7f059 in QMetaObject::activate (sender=0x12a96310, m=0x7f5c975d3c20, local_signal_index=3, argv=0x7fff7816a5a0) at kernel/qobject.cpp:3547
#37 0x00007f5c9724f552 in KJob::result (this=<optimized out>, _t1=0x12a96310) at /chakra/desktop-testing/kdelibs/src/build/kdecore/kjob.moc:208
#38 0x00007f5c9724f590 in KJob::emitResult (this=0x12a96310) at /chakra/desktop-testing/kdelibs/src/kdelibs-4.8.3/kdecore/jobs/kjob.cpp:318
#39 0x00007f5c96d78867 in QMetaCallEvent::placeMetaCall (this=0xb8e8fb0, object=0x12a96310) at kernel/qobject.cpp:525
#40 0x00007f5c96d79af9 in QObject::event (this=0x12a96310, e=0xb8e8fb0) at kernel/qobject.cpp:1195
#41 0x00007f5c977e769a in QApplicationPrivate::notify_helper (this=0x1557c00, receiver=0x12a96310, e=0xb8e8fb0) at kernel/qapplication.cpp:4554
#42 0x00007f5c977e4b96 in QApplication::notify (this=0x7fff7816b3b0, receiver=0x12a96310, e=0xb8e8fb0) at kernel/qapplication.cpp:3936
#43 0x00007f5c98849e06 in KApplication::notify (this=0x7fff7816b3b0, receiver=0x12a96310, event=0xb8e8fb0) at /chakra/desktop-testing/kdelibs/src/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#44 0x00007f5c96d60710 in QCoreApplication::notifyInternal (this=0x7fff7816b3b0, receiver=0x12a96310, event=0xb8e8fb0) at kernel/qcoreapplication.cpp:876
#45 0x00007f5c96d643a7 in QCoreApplication::sendEvent (receiver=0x12a96310, event=0xb8e8fb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#46 0x00007f5c96d61750 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x14fc930) at kernel/qcoreapplication.cpp:1500
#47 0x00007f5c96d6136d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#48 0x00007f5c96d9dc5b in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#49 0x00007f5c96d9cc41 in postEventSourceDispatch (s=0x15547f0) at kernel/qeventdispatcher_glib.cpp:279
#50 0x00007f5c9088d55a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#51 0x00007f5c9088d920 in ?? () from /usr/lib/libglib-2.0.so.0
#52 0x00007f5c9088d9e4 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#53 0x00007f5c96d9d4f7 in QEventDispatcherGlib::processEvents (this=0x14fddf0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#54 0x00007f5c978c35aa in QGuiEventDispatcherGlib::processEvents (this=0x14fddf0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x00007f5c96d5dea0 in QEventLoop::processEvents (this=0x7fff7816b200, flags=...) at kernel/qeventloop.cpp:149
#56 0x00007f5c96d5e034 in QEventLoop::exec (this=0x7fff7816b200, flags=...) at kernel/qeventloop.cpp:204
#57 0x00007f5c96d60da6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#58 0x00007f5c977e4780 in QApplication::exec () at kernel/qapplication.cpp:3815
#59 0x0000000000403329 in main (argc=1, argv=0x7fff7816b4f8) at /chakra/desktop-testing/kdepim/src/kdepim-4.8.3/kontact/src/main.cpp:218

Possible duplicates by query: bug 300478, bug 300406, bug 300398, bug 300192, bug 300046.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-23 10:28:35 UTC

*** This bug has been marked as a duplicate of bug 286307 ***