Bug 300478 - Crash When Deleting Email
Summary: Crash When Deleting Email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-23 01:28 UTC by David Anderson
Modified: 2012-05-29 14:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.81 KB, text/plain)
2012-05-29 14:48 UTC, Ed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Anderson 2012-05-23 01:28:53 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I deleted an email, and as the focus moved to next email, the program crashed.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76cc980 (LWP 2044))]

Thread 4 (Thread 0xb58fbb40 (LWP 2053)):
#0  0x00f80416 in __kernel_vsyscall ()
#1  0x008aa96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00e403dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x02c71263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0x02c7137f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0x008a6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00e32ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xb4fdab40 (LWP 2054)):
#0  0x008d7dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x08bc2315 in do_gettime (frac=0xb4fda040, sec=0xb4fda038) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x08cac226 in QTimerInfoList::updateCurrentTime (this=0xb4602074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x08cabe16 in timerSourceCheckHelper (src=0xb4602040) at kernel/qeventdispatcher_glib.cpp:150
#5  timerSourceCheckHelper (src=0xb4602040) at kernel/qeventdispatcher_glib.cpp:144
#6  0x034dfa6b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x034e0002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x034e01c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x08cab8e7 in QEventDispatcherGlib::processEvents (this=0xb4600468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0x08c7750d in QEventLoop::processEvents (this=0xb4fda270, flags=...) at kernel/qeventloop.cpp:149
#11 0x08c777a9 in QEventLoop::exec (this=0xb4fda270, flags=...) at kernel/qeventloop.cpp:204
#12 0x08b6094c in QThread::exec (this=0xa066ca8) at thread/qthread.cpp:501
#13 0x08b60a3b in QThread::run (this=0xa066ca8) at thread/qthread.cpp:568
#14 0x08b63de0 in QThreadPrivate::start (arg=0xa066ca8) at thread/qthread_unix.cpp:298
#15 0x008a6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0x00e32ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xafc03b40 (LWP 2104)):
#0  0x008d7dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x08bc2315 in do_gettime (frac=0xafc02fb0, sec=0xafc02fa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x08cac226 in QTimerInfoList::updateCurrentTime (this=0xae9f684) at kernel/qeventdispatcher_unix.cpp:343
#4  0x08cac57a in QTimerInfoList::timerWait (this=0xae9f684, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0x08caae23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xafc030bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x08caaebd in timerSourcePrepare (source=0xae9f650, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x034df762 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x034dff6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x034e01c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x08cab8e7 in QEventDispatcherGlib::processEvents (this=0xae9e1f8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x08c7750d in QEventLoop::processEvents (this=0xafc03240, flags=...) at kernel/qeventloop.cpp:149
#12 0x08c777a9 in QEventLoop::exec (this=0xafc03240, flags=...) at kernel/qeventloop.cpp:204
#13 0x08b6094c in QThread::exec (this=0xab09200) at thread/qthread.cpp:501
#14 0x08c54b5d in QInotifyFileSystemWatcherEngine::run (this=0xab09200) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x08b63de0 in QThreadPrivate::start (arg=0xab09200) at thread/qthread_unix.cpp:298
#16 0x008a6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00e32ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb76cc980 (LWP 2044)):
[KCrash Handler]
#7  0x06d6e21d in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xbbba340, hm=<error reading variable: Cannot access memory at address 0x8bffef0e>, sc=-1946161394, rp=<error reading variable: Cannot access memory at address 0x8bffef0e>, pu=184, db=..., contentLength=-4179574340) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x06e0537d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xbbba340, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xb46079e0) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x08c8ac01 in QMetaCallEvent::placeMetaCall (this=0xb4607920, object=0xbbba340) at kernel/qobject.cpp:525
#10 0x08c93c7b in QObject::event (this=0xbbba340, e=0xb4607920) at kernel/qobject.cpp:1195
#11 0x010bbed4 in notify_helper (e=0xb4607920, receiver=0xbbba340, this=0x9f31028) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x9f31028, receiver=0xbbba340, e=0xb4607920) at kernel/qapplication.cpp:4531
#13 0x010c130d in QApplication::notify (this=0xb4607920, receiver=0xbbba340, e=0xb4607920) at kernel/qapplication.cpp:4288
#14 0x00af1b21 in KApplication::notify (this=0xbff38ac4, receiver=0xbbba340, event=0xb4607920) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x08c7897e in QCoreApplication::notifyInternal (this=0xbff38ac4, receiver=0xbbba340, event=0xb4607920) at kernel/qcoreapplication.cpp:876
#16 0x08c7cad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9effab8) at kernel/qcoreapplication.cpp:1500
#18 0x08c7ce0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0x08cab494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x9f2d6b8) at kernel/qeventdispatcher_glib.cpp:279
#21 0x034dfcda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0x034e00e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x034e01c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0x08cab887 in QEventDispatcherGlib::processEvents (this=0x9f00800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x01174aaa in QGuiEventDispatcherGlib::processEvents (this=0x9f00800, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x08c7750d in QEventLoop::processEvents (this=0xbff38a24, flags=...) at kernel/qeventloop.cpp:149
#27 0x08c777a9 in QEventLoop::exec (this=0xbff38a24, flags=...) at kernel/qeventloop.cpp:204
#28 0x08c7ceba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x010b9a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#30 0x0804ac91 in main (argc=<error reading variable: Cannot access memory at address 0x3>, argv=<error reading variable: Cannot access memory at address 0x7>) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 300406, bug 300398, bug 300192, bug 300046, bug 300045.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-23 03:46:44 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 2 Ed 2012-05-29 14:48:48 UTC
Created attachment 71429 [details]
New crash information added by DrKonqi

kontact (4.8.2) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

- What I was doing when the application crashed:
Deleting email from inbox.  As the cursor advanced the program crashed.

-- Backtrace (Reduced):
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x9cc3a18, hm=<error reading variable: Cannot access memory at address 0x41>, sc=65, rp=<error reading variable: Cannot access memory at address 0x41>, pu=124, db=<error reading variable: Cannot access memory at address 0x41>, contentLength=-4260089412) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x0213c37d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x9cc3a18, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xb4713c30) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
[...]
#10 0x01c01c7b in QObject::event (this=0x9cc3a18, e=0xb4713e98) at kernel/qobject.cpp:1195
#11 0x010d1ed4 in notify_helper (e=0xb4713e98, receiver=0x9cc3a18, this=0x83e3328) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x83e3328, receiver=0x9cc3a18, e=0xb4713e98) at kernel/qapplication.cpp:4531