Bug 300406 - Clicking on a new email
Summary: Clicking on a new email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 19:40 UTC by Ruairi Hickey
Modified: 2012-05-23 03:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruairi Hickey 2012-05-21 19:40:32 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
Kontact was opened and I clicked on an unread HTML email - Kontact then crashed

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9be138a7c0 (LWP 3525))]

Thread 4 (Thread 0x7f9bc491a700 (LWP 3526)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9bddb7cdec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f9bddb7cf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f9bd9042e9a in start_thread (arg=0x7f9bc491a700) at pthread_create.c:308
#4  0x00007f9bde8ae4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9bc4119700 (LWP 3527)):
#0  0x00007f9bde8a2b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9bd8b75ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9bd8b76124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9bdf023426 in QEventDispatcherGlib::processEvents (this=0x7f9bbc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9bdeff2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9bdeff2ed7 in QEventLoop::exec (this=0x7f9bc4118dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9bdeef1fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9bdeef4fcb in QThreadPrivate::start (arg=0x225ed20) at thread/qthread_unix.cpp:298
#8  0x00007f9bd9042e9a in start_thread (arg=0x7f9bc4119700) at pthread_create.c:308
#9  0x00007f9bde8ae4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9b7540c700 (LWP 3536)):
#0  0x00007f9bd8bb1591 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f9bd8b75b59 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9bd8b76060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9bd8b76124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f9bdf023426 in QEventDispatcherGlib::processEvents (this=0x7f9b680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f9bdeff2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f9bdeff2ed7 in QEventLoop::exec (this=0x7f9b7540bd90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f9bdeef1fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f9bdefd29ff in QInotifyFileSystemWatcherEngine::run (this=0x2b60220) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f9bdeef4fcb in QThreadPrivate::start (arg=0x2b60220) at thread/qthread_unix.cpp:298
#10 0x00007f9bd9042e9a in start_thread (arg=0x7f9b7540c700) at pthread_create.c:308
#11 0x00007f9bde8ae4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9be138a7c0 (LWP 3525)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4214ef0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f9bd9f18709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4214ef0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f9bdf00d446 in QObject::event (this=0x4214ef0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f9bdf9e9894 in notify_helper (e=0x7f9b5c01e100, receiver=0x4214ef0, this=0x20cd970) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x20cd970, receiver=0x4214ef0, e=0x7f9b5c01e100) at kernel/qapplication.cpp:4531
#11 0x00007f9bdf9ee713 in QApplication::notify (this=0x7fff89cae270, receiver=0x4214ef0, e=0x7f9b5c01e100) at kernel/qapplication.cpp:4420
#12 0x00007f9be0722bb6 in KApplication::notify (this=0x7fff89cae270, receiver=0x4214ef0, event=0x7f9b5c01e100) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f9bdeff3e9c in QCoreApplication::notifyInternal (this=0x7fff89cae270, receiver=0x4214ef0, event=0x7f9b5c01e100) at kernel/qcoreapplication.cpp:876
#14 0x00007f9bdeff7c6a in sendEvent (event=0x7f9b5c01e100, receiver=0x4214ef0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2098380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f9bdf022f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f9bd8b75c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f9bd8b76060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f9bd8b76124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f9bdf0233bf in QEventDispatcherGlib::processEvents (this=0x2099c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f9bdfa91d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f9bdeff2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f9bdeff2ed7 in QEventLoop::exec (this=0x7fff89cae200, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f9bdeff7f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in main (argc=1, argv=0x7fff89cae898) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 300398, bug 300192, bug 300046, bug 300045, bug 299897.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-23 03:46:20 UTC

*** This bug has been marked as a duplicate of bug 286307 ***