Bug 300398 - Crashes regularly when selecting mail
Summary: Crashes regularly when selecting mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 18:09 UTC by Sam Gleske
Modified: 2012-05-22 06:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Gleske 2012-05-21 18:09:51 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I'm accessing KMail through Kontact.  It crashes when doing most actions which view the mail in the preview pane (i.e. select multiple messages, view a single message, delete a message which shows another message in the preview pane).

This doesn't happen every time but it does happen when selecting around 5 messages.  So after reading 5 messages it crashes pretty consistently.

- Custom settings of the application:

I have IMAPS set up and the mail I attempt to review is through IMAP.  I also have LDAP for contacts set up though I don't think it's related.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb21ac980 (LWP 7522))]

Thread 6 (Thread 0xafb9bb40 (LWP 7523)):
#0  0xb7786424 in __kernel_vsyscall ()
#1  0xb39b596b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb60ba3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb5838263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb583837f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb39b1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb60acace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xaf27ab40 (LWP 7524)):
#0  0xb7786424 in __kernel_vsyscall ()
#1  0xb609e380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb38eca3b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb38df06e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb38df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63fc8e7 in QEventDispatcherGlib::processEvents (this=0xae900468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63c850d in QEventLoop::processEvents (this=0xaf27a270, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63c87a9 in QEventLoop::exec (this=0xaf27a270, flags=...) at kernel/qeventloop.cpp:204
#8  0xb62b194c in QThread::exec (this=0x8ee4778) at thread/qthread.cpp:501
#9  0xb62b1a3b in QThread::run (this=0x8ee4778) at thread/qthread.cpp:568
#10 0xb62b4de0 in QThreadPrivate::start (arg=0x8ee4778) at thread/qthread_unix.cpp:298
#11 0xb39b1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb60acace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xaa951b40 (LWP 7539)):
#0  0xb7786424 in __kernel_vsyscall ()
#1  0xb609c17b in read () from /lib/i386-linux-gnu/libc.so.6
#2  0xb391d66e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb38deaf0 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb38df002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb38df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb63fc8e7 in QEventDispatcherGlib::processEvents (this=0xaa000468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb63c850d in QEventLoop::processEvents (this=0xaa951240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63c87a9 in QEventLoop::exec (this=0xaa951240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb62b194c in QThread::exec (this=0xa302d90) at thread/qthread.cpp:501
#10 0xb63a5b5d in QInotifyFileSystemWatcherEngine::run (this=0xa302d90) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb62b4de0 in QThreadPrivate::start (arg=0xa302d90) at thread/qthread_unix.cpp:298
#12 0xb39b1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb60acace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xac1b7b40 (LWP 7564)):
#0  0xb3703dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb6313315 in do_gettime (frac=0xac1b6fb0, sec=0xac1b6fa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb63fd226 in QTimerInfoList::updateCurrentTime (this=0xab8035b4) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb63fd57a in QTimerInfoList::timerWait (this=0xab8035b4, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb63fbe23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xac1b70bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb63fbebd in timerSourcePrepare (source=0xab803580, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb38de762 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb38def6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb38df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb63fc8e7 in QEventDispatcherGlib::processEvents (this=0xab802460, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb63c850d in QEventLoop::processEvents (this=0xac1b7240, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63c87a9 in QEventLoop::exec (this=0xac1b7240, flags=...) at kernel/qeventloop.cpp:204
#13 0xb62b194c in QThread::exec (this=0xa9dfa68) at thread/qthread.cpp:501
#14 0xb63a5b5d in QInotifyFileSystemWatcherEngine::run (this=0xa9dfa68) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb62b4de0 in QThreadPrivate::start (arg=0xa9dfa68) at thread/qthread_unix.cpp:298
#16 0xb39b1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb60acace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa2bfeb40 (LWP 8428)):
#0  0xb7786424 in __kernel_vsyscall ()
#1  0xb39b596b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb60ba3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb62b5350 in wait (time=4294967295, this=0xa3810d98) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0xa3810d8c, mutex=0xa3810d88, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb62b0b6a in QSemaphore::acquire (this=0xa2bfc658, n=1) at thread/qsemaphore.cpp:144
#6  0xb63e0b7f in QMetaObject::activate (sender=0xd61a4c0, m=0xb3c054e4, local_signal_index=2, argv=0xa2bfc690) at kernel/qobject.cpp:3525
#7  0xb3bb6455 in QHttpThreadDelegate::sslErrors (this=0xd61a4c0, _t1=..., _t2=0xa2bfc6cf, _t3=0xa2bfc6c8) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:192
#8  0xb3b44f60 in QHttpThreadDelegate::sslErrorsSlot (this=0xd61a4c0, errors=...) at access/qhttpthreaddelegate.cpp:536
#9  0xb3bb6e27 in QHttpThreadDelegate::qt_static_metacall (_o=0xd61a4c0, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xa2bfc838) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:127
#10 0xb63e06b1 in QMetaObject::activate (sender=0xa380d870, m=0xb3c04ed0, local_signal_index=0, argv=0xa2bfc838) at kernel/qobject.cpp:3547
#11 0xb3bb4475 in QHttpNetworkReply::sslErrors (this=0xa380d870, _t1=...) at .moc/release-shared/moc_qhttpnetworkreply_p.cpp:132
#12 0xb3b06f9c in QHttpNetworkConnectionChannel::_q_sslErrors (this=0xa380f0ec, errors=...) at access/qhttpnetworkconnectionchannel.cpp:1163
#13 0xb63e06b1 in QMetaObject::activate (sender=0xa38023b0, m=0xb3c04d78, local_signal_index=2, argv=0xa2bfc938) at kernel/qobject.cpp:3547
#14 0xb3ba02e5 in QSslSocket::sslErrors (this=0xa38023b0, _t1=...) at .moc/release-shared/moc_qsslsocket.cpp:163
#15 0xb3bab3c4 in QSslSocketBackendPrivate::startHandshake (this=0xa380f498) at ssl/qsslsocket_openssl.cpp:1367
#16 0xb3bad070 in QSslSocketBackendPrivate::transmit (this=0xa380f498) at ssl/qsslsocket_openssl.cpp:1108
#17 0xb3ba01a8 in QSslSocketPrivate::_q_readyReadSlot (this=0xa380f498) at ssl/qsslsocket.cpp:2205
#18 0xb3ba60a3 in qt_static_metacall (_a=0xa2bfdbe0, _id=15, _o=0xa38023b0, _c=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:98
#19 QSslSocket::qt_static_metacall (_o=0xa38023b0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xa2bfdbe0) at .moc/release-shared/moc_qsslsocket.cpp:77
#20 0xb63e06b1 in QMetaObject::activate (sender=0xa380da88, m=0xb6526a58, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#21 0xb6430b25 in QIODevice::readyRead (this=0xa380da88) at .moc/release-shared/moc_qiodevice.cpp:105
#22 0xb3b81a83 in QAbstractSocketPrivate::canReadNotification (this=0xa380da98) at socket/qabstractsocket.cpp:654
#23 0xb3b6f8f9 in QAbstractSocketEngine::readNotification (this=0xa380de30) at socket/qabstractsocketengine.cpp:168
#24 0xb3b8a68b in event (this=0xa3835038, e=<optimized out>) at socket/qnativesocketengine.cpp:1151
#25 QReadNotifier::event (this=0xa3835038, e=0xa2bfe074) at socket/qnativesocketengine.cpp:1148
#26 0xb6931ed4 in notify_helper (e=0xa2bfe074, receiver=0xa3835038, this=0x8db88e8) at kernel/qapplication.cpp:4559
#27 QApplicationPrivate::notify_helper (this=0x8db88e8, receiver=0xa3835038, e=0xa2bfe074) at kernel/qapplication.cpp:4531
#28 0xb693730d in QApplication::notify (this=0xa2bfe074, receiver=0xa3835038, e=0xa2bfe074) at kernel/qapplication.cpp:4288
#29 0xb74b6b21 in KApplication::notify (this=0xbfbc3944, receiver=0xa3835038, event=0xa2bfe074) at ../../kdeui/kernel/kapplication.cpp:311
#30 0xb63c997e in QCoreApplication::notifyInternal (this=0xbfbc3944, receiver=0xa3835038, event=0xa2bfe074) at kernel/qcoreapplication.cpp:876
#31 0xb63fbf48 in sendEvent (event=0xa2bfe074, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 socketNotifierSourceDispatch (source=0xa380f9a8) at kernel/qeventdispatcher_glib.cpp:110
#33 0xb38decda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb38df0e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb38df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb63fc887 in QEventDispatcherGlib::processEvents (this=0xa380f948, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#37 0xb63c850d in QEventLoop::processEvents (this=0xa2bfe270, flags=...) at kernel/qeventloop.cpp:149
#38 0xb63c87a9 in QEventLoop::exec (this=0xa2bfe270, flags=...) at kernel/qeventloop.cpp:204
#39 0xb62b194c in QThread::exec (this=0xc5be828) at thread/qthread.cpp:501
#40 0xb62b1a3b in QThread::run (this=0xc5be828) at thread/qthread.cpp:568
#41 0xb62b4de0 in QThreadPrivate::start (arg=0xc5be828) at thread/qthread_unix.cpp:298
#42 0xb39b1d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#43 0xb60acace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb21ac980 (LWP 7522)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xc9cac18, hm=<error reading variable: Cannot access memory at address 0x5f0035>, sc=6225973, rp=<error reading variable: Cannot access memory at address 0x5f0035>, pu=92, db=<error reading variable: Cannot access memory at address 0x5f0035>, contentLength=-1279540804) at access/qnetworkaccesshttpbackend.cpp:827
#8  0xb3bb537d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xc9cac18, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xa3814f70) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0xb63dbc01 in QMetaCallEvent::placeMetaCall (this=0xa3814b08, object=0xc9cac18) at kernel/qobject.cpp:525
#10 0xb63e4c7b in QObject::event (this=0xc9cac18, e=0xa3814b08) at kernel/qobject.cpp:1195
#11 0xb6931ed4 in notify_helper (e=0xa3814b08, receiver=0xc9cac18, this=0x8db88e8) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x8db88e8, receiver=0xc9cac18, e=0xa3814b08) at kernel/qapplication.cpp:4531
#13 0xb693730d in QApplication::notify (this=0xa3814b08, receiver=0xc9cac18, e=0xa3814b08) at kernel/qapplication.cpp:4288
#14 0xb74b6b21 in KApplication::notify (this=0xbfbc3944, receiver=0xc9cac18, event=0xa3814b08) at ../../kdeui/kernel/kapplication.cpp:311
#15 0xb63c997e in QCoreApplication::notifyInternal (this=0xbfbc3944, receiver=0xc9cac18, event=0xa3814b08) at kernel/qcoreapplication.cpp:876
#16 0xb63cdad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8d90ab8) at kernel/qcoreapplication.cpp:1500
#18 0xb63cde0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0xb63fc494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x8dbb080) at kernel/qeventdispatcher_glib.cpp:279
#21 0xb38decda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0xb38df0e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb38df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb63fc887 in QEventDispatcherGlib::processEvents (this=0x8d91800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0xb69eaaaa in QGuiEventDispatcherGlib::processEvents (this=0x8d91800, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0xb63c850d in QEventLoop::processEvents (this=0xbfbc38a4, flags=...) at kernel/qeventloop.cpp:149
#27 0xb63c87a9 in QEventLoop::exec (this=0xbfbc38a4, flags=...) at kernel/qeventloop.cpp:204
#28 0xb63cdeba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0xb692fa74 in QApplication::exec () at kernel/qapplication.cpp:3820
#30 0x0804ac91 in ?? ()
#31 0xb5fdb4d3 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#32 0x0804b1a1 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 300192, bug 300046, bug 300045, bug 299897, bug 299652.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-22 06:48:43 UTC

*** This bug has been marked as a duplicate of bug 286307 ***