Bug 300192 - Kontact crashed when reviewing a mail.
Summary: Kontact crashed when reviewing a mail.
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-17 11:40 UTC by JR
Modified: 2012-05-17 12:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JR 2012-05-17 11:40:14 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Selecting an email while it gets loaded in the review area.
- Unusual behavior I noticed:
It always crashed after looking through a few mails.
This behavior is new in Kontact of Kubuntu 12.04.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb27a5027c0 (LWP 2019))]

Thread 4 (Thread 0x7fb25d8c7700 (LWP 2020)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb276cf6dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fb276cf6f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fb2721bde9a in start_thread (arg=0x7fb25d8c7700) at pthread_create.c:308
#4  0x00007fb277a284bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb25cfa6700 (LWP 2021)):
#0  0x00007fb2721c105d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7fb258000a60) at pthread_mutex_unlock.c:290
#2  0x00007fb271d2c591 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb271cf0fea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb271cf1124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fb27819d426 in QEventDispatcherGlib::processEvents (this=0x7fb2580008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fb27816cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb27816ced7 in QEventLoop::exec (this=0x7fb25cfa5dc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fb27806bfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fb27806efcb in QThreadPrivate::start (arg=0x22f7470) at thread/qthread_unix.cpp:298
#10 0x00007fb2721bde9a in start_thread (arg=0x7fb25cfa6700) at pthread_create.c:308
#11 0x00007fb277a284bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb208e0b700 (LWP 2279)):
#0  0x00007fb2721c105d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7fb200000a60) at pthread_mutex_unlock.c:290
#2  0x00007fb271d2c591 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb271cf0fa9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb271cf1124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fb27819d426 in QEventDispatcherGlib::processEvents (this=0x7fb2000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fb27816cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb27816ced7 in QEventLoop::exec (this=0x7fb208e0ad90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fb27806bfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fb27814c9ff in QInotifyFileSystemWatcherEngine::run (this=0x2e05670) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fb27806efcb in QThreadPrivate::start (arg=0x2e05670) at thread/qthread_unix.cpp:298
#11 0x00007fb2721bde9a in start_thread (arg=0x7fb208e0b700) at pthread_create.c:308
#12 0x00007fb277a284bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb27a5027c0 (LWP 2019)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x44b2300, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fb273093709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x44b2300, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fb278187446 in QObject::event (this=0x44b2300, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fb278b62894 in notify_helper (e=0x7fb1e8007560, receiver=0x44b2300, this=0x2142c20) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x2142c20, receiver=0x44b2300, e=0x7fb1e8007560) at kernel/qapplication.cpp:4531
#11 0x00007fb278b67713 in QApplication::notify (this=0x7fffd16a5690, receiver=0x44b2300, e=0x7fb1e8007560) at kernel/qapplication.cpp:4420
#12 0x00007fb27989bb46 in KApplication::notify (this=0x7fffd16a5690, receiver=0x44b2300, event=0x7fb1e8007560) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007fb27816de9c in QCoreApplication::notifyInternal (this=0x7fffd16a5690, receiver=0x44b2300, event=0x7fb1e8007560) at kernel/qcoreapplication.cpp:876
#14 0x00007fb278171c6a in sendEvent (event=0x7fb1e8007560, receiver=0x44b2300) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x210a380) at kernel/qcoreapplication.cpp:1500
#16 0x00007fb27819cf93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fb271cf0c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fb271cf1060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fb271cf1124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fb27819d3bf in QEventDispatcherGlib::processEvents (this=0x210bc10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fb278c0ad5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fb27816cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fb27816ced7 in QEventLoop::exec (this=0x7fffd16a5620, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fb278171f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in main (argc=1, argv=0x7fffd16a5cb8) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 300046, bug 300045, bug 299897, bug 299652, bug 299423.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-05-17 12:56:25 UTC

*** This bug has been marked as a duplicate of bug 286307 ***