Bug 300046 - Crash when selecting email in mailbox
Summary: Crash when selecting email in mailbox
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-15 02:28 UTC by Rory Griffin
Modified: 2012-05-15 06:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rory Griffin 2012-05-15 02:28:12 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Holding shift key and down arrow to create list of emails (to delete when done)

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f41e25cf7c0 (LWP 4466))]

Thread 8 (Thread 0x7f41c58fe700 (LWP 4467)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f41dedd7dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f41dedd7f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f41da29ee9a in start_thread (arg=0x7f41c58fe700) at pthread_create.c:308
#4  0x00007f41dfb094bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f41c4ffd700 (LWP 4468)):
#0  0x00007f41dfafdb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f41d9dd1ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f41d9dd2124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f41e027e426 in QEventDispatcherGlib::processEvents (this=0x7f41c00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f41e024dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f41e024ded7 in QEventLoop::exec (this=0x7f41c4ffcdc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f41e014cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f41e014ffcb in QThreadPrivate::start (arg=0x1edec90) at thread/qthread_unix.cpp:298
#8  0x00007f41da29ee9a in start_thread (arg=0x7f41c4ffd700) at pthread_create.c:308
#9  0x00007f41dfb094bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f417709f700 (LWP 4471)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f41e015043f in wait (time=30000, this=0x2635060) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2635008, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f41e01435bf in QThreadPoolThread::run (this=0x2646f00) at concurrent/qthreadpool.cpp:141
#4  0x00007f41e014ffcb in QThreadPrivate::start (arg=0x2646f00) at thread/qthread_unix.cpp:298
#5  0x00007f41da29ee9a in start_thread (arg=0x7f417709f700) at pthread_create.c:308
#6  0x00007f41dfb094bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f416ffff700 (LWP 4478)):
#0  0x00007f41dfafc0bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f41d9e0c88f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f41d9dd1abd in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f41d9dd1f96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f41d9dd2124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f41e027e426 in QEventDispatcherGlib::processEvents (this=0x7f41680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f41e024dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f41e024ded7 in QEventLoop::exec (this=0x7f416fffed90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f41e014cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f41e022d9ff in QInotifyFileSystemWatcherEngine::run (this=0x4357e80) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f41e014ffcb in QThreadPrivate::start (arg=0x4357e80) at thread/qthread_unix.cpp:298
#11 0x00007f41da29ee9a in start_thread (arg=0x7f416ffff700) at pthread_create.c:308
#12 0x00007f41dfb094bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f416db99700 (LWP 4481)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f41e015043f in wait (time=30000, this=0x7f41640066b0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f4164006658, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f41e01435bf in QThreadPoolThread::run (this=0x7f4164006980) at concurrent/qthreadpool.cpp:141
#4  0x00007f41e014ffcb in QThreadPrivate::start (arg=0x7f4164006980) at thread/qthread_unix.cpp:298
#5  0x00007f41da29ee9a in start_thread (arg=0x7f416db99700) at pthread_create.c:308
#6  0x00007f41dfb094bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f41577fe700 (LWP 4653)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f41e015043f in wait (time=30000, this=0x7f41640066b0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f4164006658, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f41e01435bf in QThreadPoolThread::run (this=0x7f415000d520) at concurrent/qthreadpool.cpp:141
#4  0x00007f41e014ffcb in QThreadPrivate::start (arg=0x7f415000d520) at thread/qthread_unix.cpp:298
#5  0x00007f41da29ee9a in start_thread (arg=0x7f41577fe700) at pthread_create.c:308
#6  0x00007f41dfb094bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4157fff700 (LWP 4657)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f41e015043f in wait (time=30000, this=0x498a5a0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x496a1f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f41e01435bf in QThreadPoolThread::run (this=0x49a21e0) at concurrent/qthreadpool.cpp:141
#4  0x00007f41e014ffcb in QThreadPrivate::start (arg=0x49a21e0) at thread/qthread_unix.cpp:298
#5  0x00007f41da29ee9a in start_thread (arg=0x7f4157fff700) at pthread_create.c:308
#6  0x00007f41dfb094bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f41e25cf7c0 (LWP 4466)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x7ccacb0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f41db174709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x7ccacb0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f41e0268446 in QObject::event (this=0x7ccacb0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f41e0c43894 in notify_helper (e=0x7f416003dba0, receiver=0x7ccacb0, this=0x1edbfd0) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1edbfd0, receiver=0x7ccacb0, e=0x7f416003dba0) at kernel/qapplication.cpp:4531
#11 0x00007f41e0c48713 in QApplication::notify (this=0x7fffe2330640, receiver=0x7ccacb0, e=0x7f416003dba0) at kernel/qapplication.cpp:4420
#12 0x00007f41e197cb46 in KApplication::notify (this=0x7fffe2330640, receiver=0x7ccacb0, event=0x7f416003dba0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f41e024ee9c in QCoreApplication::notifyInternal (this=0x7fffe2330640, receiver=0x7ccacb0, event=0x7f416003dba0) at kernel/qcoreapplication.cpp:876
#14 0x00007f41e0252c6a in sendEvent (event=0x7f416003dba0, receiver=0x7ccacb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1ea1380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f41e027df93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f41d9dd1c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f41d9dd2060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f41d9dd2124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f41e027e3bf in QEventDispatcherGlib::processEvents (this=0x1ea2c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f41e0cebd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f41e024dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f41e024ded7 in QEventLoop::exec (this=0x7fffe23305d0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f41e0252f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in main (argc=1, argv=0x7fffe2330c68) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 300045, bug 299897, bug 299652, bug 299423, bug 299397.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-15 06:16:32 UTC

*** This bug has been marked as a duplicate of bug 286307 ***