Bug 299652 - crash when spamassassin run with kmail
Summary: crash when spamassassin run with kmail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-08 21:02 UTC by bruno noreve
Modified: 2012-05-09 12:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bruno noreve 2012-05-08 21:02:08 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
crash when spamassassin run with kmail ( sorry i'm french )
Lors de l'utilisation en courrier non sollicité, au changement de message, plantage de Kmail.
Spamassassin est utilisé et a été configuré par l'assistant courrier non sollicité de Kmail.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb216c980 (LWP 9940))]

Thread 5 (Thread 0xaf988b40 (LWP 9941)):
#0  0xb774b424 in __kernel_vsyscall ()
#1  0xb397596b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb607a3dc in __pthread_cond_wait (cond=0xb5f29a30, mutex=0xb5f29a18) at forward.c:139
#3  0xb57f8263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb57f837f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb3971d4c in start_thread (arg=0xaf988b40) at pthread_create.c:308
#6  0xb606cace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 4 (Thread 0xaf05fb40 (LWP 9942)):
#0  0xb774b424 in __kernel_vsyscall ()
#1  0xb605e380 in __GI___poll (fds=0xae700df0, nfds=1, timeout=8356) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb38aca3b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb389f06e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb389f1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63bc8e7 in QEventDispatcherGlib::processEvents (this=0xae700468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb638850d in QEventLoop::processEvents (this=0xaf05f270, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63887a9 in QEventLoop::exec (this=0xaf05f270, flags=...) at kernel/qeventloop.cpp:204
#8  0xb627194c in QThread::exec (this=0x98c2ab0) at thread/qthread.cpp:501
#9  0xb6271a3b in QThread::run (this=0x98c2ab0) at thread/qthread.cpp:568
#10 0xb6274de0 in QThreadPrivate::start (arg=0x98c2ab0) at thread/qthread_unix.cpp:298
#11 0xb3971d4c in start_thread (arg=0xaf05fb40) at pthread_create.c:308
#12 0xb606cace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xa95aab40 (LWP 10007)):
#0  __pthread_mutex_unlock (mutex=0xa2099a8) at pthread_mutex_unlock.c:290
#1  0xb607a634 in pthread_mutex_unlock (mutex=0xa2099a8) at forward.c:184
#2  0xb38de3d0 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb389e0de in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb389ef18 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb389f1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb63bc8e7 in QEventDispatcherGlib::processEvents (this=0xa2036a8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb638850d in QEventLoop::processEvents (this=0xa95aa240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63887a9 in QEventLoop::exec (this=0xa95aa240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb627194c in QThread::exec (this=0xa200d38) at thread/qthread.cpp:501
#10 0xb6365b5d in QInotifyFileSystemWatcherEngine::run (this=0xa200d38) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb6274de0 in QThreadPrivate::start (arg=0xa200d38) at thread/qthread_unix.cpp:298
#12 0xb3971d4c in start_thread (arg=0xa95aab40) at pthread_create.c:308
#13 0xb606cace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xac912b40 (LWP 13424)):
#0  0xb3974c2d in __pthread_mutex_unlock_usercnt (mutex=0xac002120, decr=1) at pthread_mutex_unlock.c:36
#1  0xb607a634 in pthread_mutex_unlock (mutex=0xac002120) at forward.c:184
#2  0xb38de3d0 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb389ea66 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb389f002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb389f1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb63bc8e7 in QEventDispatcherGlib::processEvents (this=0xac002110, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb638850d in QEventLoop::processEvents (this=0xac912240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63887a9 in QEventLoop::exec (this=0xac912240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb627194c in QThread::exec (this=0xa361150) at thread/qthread.cpp:501
#10 0xb6365b5d in QInotifyFileSystemWatcherEngine::run (this=0xa361150) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb6274de0 in QThreadPrivate::start (arg=0xa361150) at thread/qthread_unix.cpp:298
#12 0xb3971d4c in start_thread (arg=0xac912b40) at pthread_create.c:308
#13 0xb606cace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb216c980 (LWP 9940)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xafcbb90, hm=<error reading variable: Cannot access memory at address 0x31>, sc=49, rp=<error reading variable: Cannot access memory at address 0x31>, pu=104, db=<error reading variable: Cannot access memory at address 0x31>, contentLength=3015164348) at access/qnetworkaccesshttpbackend.cpp:805
#8  0xb3b7537d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xafcbb90, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xac02f890) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0xb639bc01 in QMetaCallEvent::placeMetaCall (this=0xac01be30, object=0xafcbb90) at kernel/qobject.cpp:525
#10 0xb63a4c7b in QObject::event (this=0xafcbb90, e=0xac01be30) at kernel/qobject.cpp:1195
#11 0xb68f1ed4 in notify_helper (e=0xac01be30, receiver=0xafcbb90, this=0x97b7490) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x97b7490, receiver=0xafcbb90, e=0xac01be30) at kernel/qapplication.cpp:4531
#13 0xb68f730d in QApplication::notify (this=0xac01be30, receiver=0xafcbb90, e=0xac01be30) at kernel/qapplication.cpp:4288
#14 0xb7476b21 in KApplication::notify (this=0xbfd02544, receiver=0xafcbb90, event=0xac01be30) at ../../kdeui/kernel/kapplication.cpp:311
#15 0xb638997e in QCoreApplication::notifyInternal (this=0xbfd02544, receiver=0xafcbb90, event=0xac01be30) at kernel/qcoreapplication.cpp:876
#16 0xb638dad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9784ab8) at kernel/qcoreapplication.cpp:1500
#18 0xb638de0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0xb63bc494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x97b7910) at kernel/qeventdispatcher_glib.cpp:279
#21 0xb389ecda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0xb389f0e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb389f1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb63bc887 in QEventDispatcherGlib::processEvents (this=0x9785818, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0xb69aaaaa in QGuiEventDispatcherGlib::processEvents (this=0x9785818, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0xb638850d in QEventLoop::processEvents (this=0xbfd024a4, flags=...) at kernel/qeventloop.cpp:149
#27 0xb63887a9 in QEventLoop::exec (this=0xbfd024a4, flags=...) at kernel/qeventloop.cpp:204
#28 0xb638deba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0xb68efa74 in QApplication::exec () at kernel/qapplication.cpp:3820
#30 0x0804ac91 in main (argc=<error reading variable: Cannot access memory at address 0xc7>, argv=<error reading variable: Cannot access memory at address 0xcb>) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 299423, bug 299397, bug 299323, bug 299242, bug 298807.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-05-09 12:57:41 UTC

*** This bug has been marked as a duplicate of bug 286307 ***