Bug 299423 - Kontact crashes when deleting email
Summary: Kontact crashes when deleting email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-05 07:16 UTC by Darryl
Modified: 2012-05-09 09:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.68 KB, text/plain)
2012-05-07 15:34 UTC, Daniel Rendall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darryl 2012-05-05 07:16:57 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
When I delete some emails, Kontact will crash. I am pretty sure this may be a duplicate of bugs already reported, but just in case it is not I decided to report this.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f841cc1e7c0 (LWP 3628))]

Thread 4 (Thread 0x7f8400168700 (LWP 3629)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f841942bdec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f841942bf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f84148f1e9a in start_thread (arg=0x7f8400168700) at pthread_create.c:308
#4  0x00007f841a15d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f83ff867700 (LWP 3630)):
#0  g_main_context_query (context=0x7f83f80009a0, max_priority=2147483647, timeout=0x7f83ff866cac, fds=0x7f83f80029c0, n_fds=1) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:2878
#1  0x00007f8414424f6a in g_main_context_iterate (dispatch=1, block=1, context=0x7f83f80009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3105
#2  g_main_context_iterate (context=0x7f83f80009a0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3060
#3  0x00007f8414425124 in g_main_context_iteration (context=0x7f83f80009a0, may_block=1) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3184
#4  0x00007f841a8d2426 in QEventDispatcherGlib::processEvents (this=0x7f83f80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f841a8a1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f841a8a1ed7 in QEventLoop::exec (this=0x7f83ff866dc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f841a7a0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f841a7a3fcb in QThreadPrivate::start (arg=0x19afc10) at thread/qthread_unix.cpp:298
#9  0x00007f84148f1e9a in start_thread (arg=0x7f83ff867700) at pthread_create.c:308
#10 0x00007f841a15d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f83ab37b700 (LWP 3842)):
#0  __pthread_mutex_lock (mutex=0x7f839c000a60) at pthread_mutex_lock.c:50
#1  0x00007f8414460561 in g_mutex_lock (mutex=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gthread-posix.c:208
#2  0x00007f84144248c8 in g_main_context_check (context=0x7f839c0009a0, max_priority=2147483647, fds=0x7f839c002bb0, n_fds=1) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:2946
#3  0x00007f8414424f96 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x7f839c0009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3120
#4  g_main_context_iterate (context=0x7f839c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3060
#5  0x00007f8414425124 in g_main_context_iteration (context=0x7f839c0009a0, may_block=1) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3184
#6  0x00007f841a8d2426 in QEventDispatcherGlib::processEvents (this=0x7f839c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f841a8a1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f841a8a1ed7 in QEventLoop::exec (this=0x7f83ab37ad90, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f841a7a0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x00007f841a8819ff in QInotifyFileSystemWatcherEngine::run (this=0x1f798a0) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x00007f841a7a3fcb in QThreadPrivate::start (arg=0x1f798a0) at thread/qthread_unix.cpp:298
#12 0x00007f84148f1e9a in start_thread (arg=0x7f83ab37b700) at pthread_create.c:308
#13 0x00007f841a15d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f841cc1e7c0 (LWP 3628)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x38f4e20, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f84157c7709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x38f4e20, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f841a8bc446 in QObject::event (this=0x38f4e20, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f841b298894 in notify_helper (e=0x7f83a0024cf0, receiver=0x38f4e20, this=0x17fb130) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x17fb130, receiver=0x38f4e20, e=0x7f83a0024cf0) at kernel/qapplication.cpp:4531
#11 0x00007f841b29d713 in QApplication::notify (this=0x7fffe956cee0, receiver=0x38f4e20, e=0x7f83a0024cf0) at kernel/qapplication.cpp:4420
#12 0x00007f841bfd1bb6 in KApplication::notify (this=0x7fffe956cee0, receiver=0x38f4e20, event=0x7f83a0024cf0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f841a8a2e9c in QCoreApplication::notifyInternal (this=0x7fffe956cee0, receiver=0x38f4e20, event=0x7f83a0024cf0) at kernel/qcoreapplication.cpp:876
#14 0x00007f841a8a6c6a in sendEvent (event=0x7f83a0024cf0, receiver=0x38f4e20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x17c0380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f841a8d1f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f8414424c9a in g_main_dispatch (context=0x17fc700) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:2515
#19 g_main_context_dispatch (context=0x17fc700) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3052
#20 0x00007f8414425060 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x17fc700, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3123
#21 g_main_context_iterate (context=0x17fc700, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3060
#22 0x00007f8414425124 in g_main_context_iteration (context=0x17fc700, may_block=1) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3184
#23 0x00007f841a8d23bf in QEventDispatcherGlib::processEvents (this=0x17c1c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007f841b340d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f841a8a1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f841a8a1ed7 in QEventLoop::exec (this=0x7fffe956ce70, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007f841a8a6f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x0000000000403629 in main (argc=1, argv=0x7fffe956d508) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 299397, bug 299323, bug 299242, bug 298807, bug 298609.

Reported using DrKonqi
Comment 1 Daniel Rendall 2012-05-07 15:34:25 UTC
Created attachment 70926 [details]
New crash information added by DrKonqi

kontact (4.8.2) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

- What I was doing when the application crashed:

Deleting about 300 messages from my inbox. I'd successfully deleted some messages (in chunks of several hundred) already.

-- Backtrace (Reduced):
#7  0x021cb005 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xb968718, hm=<error reading variable: Cannot access memory at address 0x800ce4bb>, sc=-2146638661, rp=<error reading variable: Cannot access memory at address 0x800ce4bb>, pu=4, db=..., contentLength=36082108) at access/qnetworkaccesshttpbackend.cpp:805
#8  0x0226237d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xb968718, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xb2409d70) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
[...]
#10 0x0693cc7b in QObject::event (this=0xb968718, e=0xb241a1b8) at kernel/qobject.cpp:1195
#11 0x01128ed4 in notify_helper (e=0xb241a1b8, receiver=0xb968718, this=0x999f3a0) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x999f3a0, receiver=0xb968718, e=0xb241a1b8) at kernel/qapplication.cpp:4531
Comment 2 Laurent Montel 2012-05-09 09:37:55 UTC

*** This bug has been marked as a duplicate of bug 286307 ***