Bug 299397 - Kontact crash whenn I select an other e-mail (Kubuntu 12.04)
Summary: Kontact crash whenn I select an other e-mail (Kubuntu 12.04)
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 18:54 UTC by pierre_metzner
Modified: 2012-05-09 12:58 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.40 KB, text/plain)
2012-05-05 09:56 UTC, Sylvain Garsault
Details
New crash information added by DrKonqi (5.02 KB, text/plain)
2012-05-06 19:56 UTC, Thomas Pietrowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre_metzner 2012-05-04 18:54:08 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

when I select an other e-mail (not only new e-mails) Kontact crashes. I have this error since I updated Kubuntu 11.10 to 12.04. On Kubuntu 11.10 I did not have this error.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3d76c157c0 (LWP 14105))]

Thread 4 (Thread 0x7f3d59fc7700 (LWP 14106)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3d7340edec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f3d7340ef19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f3d6e8d5e9a in start_thread (arg=0x7f3d59fc7700) at pthread_create.c:308
#4  0x00007f3d741404bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3d596ae700 (LWP 14107)):
#0  0x00007f3d6e8d7f69 in __pthread_mutex_lock (mutex=0x7f3d54000a60) at pthread_mutex_lock.c:92
#1  0x00007f3d6e444561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3d6e408217 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3d6e408fa9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3d6e409124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3d748b5426 in QEventDispatcherGlib::processEvents (this=0x7f3d540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f3d74884c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3d74884ed7 in QEventLoop::exec (this=0x7f3d596addc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3d74783fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f3d74786fcb in QThreadPrivate::start (arg=0x1532510) at thread/qthread_unix.cpp:298
#10 0x00007f3d6e8d5e9a in start_thread (arg=0x7f3d596ae700) at pthread_create.c:308
#11 0x00007f3d741404bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3d08cef700 (LWP 14125)):
#0  0x00007f3d74134b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3d6e408ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3d6e409124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3d748b5426 in QEventDispatcherGlib::processEvents (this=0x7f3d000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f3d74884c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3d74884ed7 in QEventLoop::exec (this=0x7f3d08ceed90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f3d74783fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f3d748649ff in QInotifyFileSystemWatcherEngine::run (this=0x234bd10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f3d74786fcb in QThreadPrivate::start (arg=0x234bd10) at thread/qthread_unix.cpp:298
#9  0x00007f3d6e8d5e9a in start_thread (arg=0x7f3d08cef700) at pthread_create.c:308
#10 0x00007f3d741404bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3d76c157c0 (LWP 14105)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1541c10, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f3d6f7ab709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1541c10, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f3d7489f446 in QObject::event (this=0x1541c10, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f3d7527a894 in notify_helper (e=0x7f3cec00e830, receiver=0x1541c10, this=0x1367a70) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1367a70, receiver=0x1541c10, e=0x7f3cec00e830) at kernel/qapplication.cpp:4531
#11 0x00007f3d7527f713 in QApplication::notify (this=0x7fffbaee9f20, receiver=0x1541c10, e=0x7f3cec00e830) at kernel/qapplication.cpp:4420
#12 0x00007f3d75fb3b46 in KApplication::notify (this=0x7fffbaee9f20, receiver=0x1541c10, event=0x7f3cec00e830) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f3d74885e9c in QCoreApplication::notifyInternal (this=0x7fffbaee9f20, receiver=0x1541c10, event=0x7f3cec00e830) at kernel/qcoreapplication.cpp:876
#14 0x00007f3d74889c6a in sendEvent (event=0x7f3cec00e830, receiver=0x1541c10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1330380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f3d748b4f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f3d6e408c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f3d6e409060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f3d6e409124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f3d748b53bf in QEventDispatcherGlib::processEvents (this=0x1331c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f3d75322d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f3d74884c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f3d74884ed7 in QEventLoop::exec (this=0x7fffbaee9eb0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f3d74889f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in main (argc=1, argv=0x7fffbaeea548) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 299323, bug 299242, bug 298807, bug 298609, bug 298427.

Reported using DrKonqi
Comment 1 Sylvain Garsault 2012-05-05 09:56:05 UTC
Created attachment 70872 [details]
New crash information added by DrKonqi

kontact (4.8.2) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

- What I was doing when the application crashed:

Selecting another e-mail (not a new one) in Kontact.

-- Backtrace (Reduced):
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xbf993f0, hm=<error reading variable: Cannot access memory at address 0x31>, sc=49, rp=<error reading variable: Cannot access memory at address 0x31>, pu=36, db=<error reading variable: Cannot access memory at address 0x31>, contentLength=-1279274564) at access/qnetworkaccesshttpbackend.cpp:827
#8  0xb3bf637d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xbf993f0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xab12ac38) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
[...]
#10 0xb6425c7b in QObject::event (this=0xbf993f0, e=0xab10c098) at kernel/qobject.cpp:1195
#11 0xb6972ed4 in notify_helper (e=0xab10c098, receiver=0xbf993f0, this=0x914f5e8) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x914f5e8, receiver=0xbf993f0, e=0xab10c098) at kernel/qapplication.cpp:4531
Comment 2 Thomas Pietrowski 2012-05-06 19:56:00 UTC
Created attachment 70903 [details]
New crash information added by DrKonqi

kontact (4.8.2) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

- What I was doing when the application crashed:

Happend while trying to open or remove a mail from Kontact (KMail).

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4690990, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f5d9d68c709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4690990, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f5da2780446 in QObject::event (this=0x4690990, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f5da315b894 in notify_helper (e=0x7f5d2c014ae0, receiver=0x4690990, this=0x1dda420) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1dda420, receiver=0x4690990, e=0x7f5d2c014ae0) at kernel/qapplication.cpp:4531
Comment 3 Christophe Giboudeaux 2012-05-09 12:58:34 UTC

*** This bug has been marked as a duplicate of bug 286307 ***