Bug 296617 - Kontact crashed deleting mail from inbox
Summary: Kontact crashed deleting mail from inbox
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.x
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-23 12:03 UTC by Clive Messer
Modified: 2012-03-26 22:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clive Messer 2012-03-23 12:03:24 UTC
Application: kontact (4.8.1)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-4.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

Deleting a single item of mail from the inbox. The account is an IMAP account. Every time I try to delete a mail from this inbox kontact crashes. Evolution does not have a problem.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f76ef488840 (LWP 11244))]

Thread 4 (Thread 0x7f76e2e9e700 (LWP 11245)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000038705b86ec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3870f7cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000038705b8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003842a07d90 in start_thread (arg=0x7f76e2e9e700) at pthread_create.c:309
#4  0x00000038422f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f76e2585700 (LWP 11246)):
#0  0x00000038422e85c3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003845244fd8 in g_main_context_poll (n_fds=1, fds=0x7f76dc0013e0, priority=<optimized out>, timeout=275, context=0x7f76dc0009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7f76dc0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x000000384524549c in g_main_context_iteration (context=0x7f76dc0009a0, may_block=1) at gmain.c:3152
#4  0x000000384d1a7dc6 in QEventDispatcherGlib::processEvents (this=0x7f76dc0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000384d178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000384d1783d7 in QEventLoop::exec (this=0x7f76e2584d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000384d078b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000384d07bb6b in QThreadPrivate::start (arg=0x1e200a0) at thread/qthread_unix.cpp:298
#9  0x0000003842a07d90 in start_thread (arg=0x7f76e2585700) at pthread_create.c:309
#10 0x00000038422f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f7697dff700 (LWP 11269)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000384d07bfdf in wait (time=30000, this=0x2a0ca00) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a0c978, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000384d06f5af in QThreadPoolThread::run (this=0x2a21870) at concurrent/qthreadpool.cpp:141
#4  0x000000384d07bb6b in QThreadPrivate::start (arg=0x2a21870) at thread/qthread_unix.cpp:298
#5  0x0000003842a07d90 in start_thread (arg=0x7f7697dff700) at pthread_create.c:309
#6  0x00000038422f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f76ef488840 (LWP 11244)):
[KCrash Handler]
#6  ref (this=0x250027003d0030) at ../../src/corelib/arch/qatomic_x86_64.h:121
#7  QList (l=..., this=0x7fff0a91e2f0) at ../../src/corelib/tools/qlist.h:122
#8  QNetworkCacheMetaData::rawHeaders (this=0x7fff0a91e610) at access/qabstractnetworkcache.cpp:240
#9  0x000000384d66f03c in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x2fcda90, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#10 0x000000384d6707d4 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2fcda90, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#11 0x000000384d6f6409 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2fcda90, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#12 0x000000384d191f16 in QObject::event (this=0x2fcda90, e=<optimized out>) at kernel/qobject.cpp:1195
#13 0x00000038571c9994 in notify_helper (e=0x7f768800d980, receiver=0x2fcda90, this=0x1e0cd30) at kernel/qapplication.cpp:4550
#14 QApplicationPrivate::notify_helper (this=0x1e0cd30, receiver=0x2fcda90, e=0x7f768800d980) at kernel/qapplication.cpp:4522
#15 0x00000038571ce813 in QApplication::notify (this=0x7fff0a91f090, receiver=0x2fcda90, e=0x7f768800d980) at kernel/qapplication.cpp:4411
#16 0x0000003859251d56 in KApplication::notify (this=0x7fff0a91f090, receiver=0x2fcda90, event=0x7f768800d980) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#17 0x000000384d17904c in QCoreApplication::notifyInternal (this=0x7fff0a91f090, receiver=0x2fcda90, event=0x7f768800d980) at kernel/qcoreapplication.cpp:876
#18 0x000000384d17cada in sendEvent (event=0x7f768800d980, receiver=0x2fcda90) at kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1dd3600) at kernel/qcoreapplication.cpp:1500
#20 0x000000384d1a7933 in sendPostedEvents () at kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x1e18650) at kernel/qeventdispatcher_glib.cpp:279
#22 0x0000003845244acd in g_main_dispatch (context=0x1e1e5e0) at gmain.c:2441
#23 g_main_context_dispatch (context=0x1e1e5e0) at gmain.c:3011
#24 0x00000038452452c8 in g_main_context_iterate (context=0x1e1e5e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#25 0x000000384524549c in g_main_context_iteration (context=0x1e1e5e0, may_block=1) at gmain.c:3152
#26 0x000000384d1a7d5f in QEventDispatcherGlib::processEvents (this=0x1dd4ee0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#27 0x000000385726c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#28 0x000000384d178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x000000384d1783d7 in QEventLoop::exec (this=0x7fff0a91f020, flags=...) at kernel/qeventloop.cpp:204
#30 0x000000384d17cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#31 0x00000000004036e9 in main (argc=1, argv=0x7fff0a91f6b8) at /usr/src/debug/kdepim-4.8.1/kontact/src/main.cpp:218

Possible duplicates by query: bug 296485, bug 296009, bug 295112, bug 294125, bug 292500.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-26 22:20:01 UTC

*** This bug has been marked as a duplicate of bug 286307 ***