Bug 296485 - Kmail crashed since 4.8.1
Summary: Kmail crashed since 4.8.1
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-21 09:21 UTC by RalfPasieka
Modified: 2012-03-26 22:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RalfPasieka 2012-03-21 09:21:09 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I select an E-Mail then Kmail crashed. I switched to Kmail then the Aplication crashed. This happens not always but somtimes.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0996d3d7c0 (LWP 2101))]

Thread 4 (Thread 0x7f097bbf2700 (LWP 2105)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0993571c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f0993571d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f098ed3eefc in start_thread (arg=0x7f097bbf2700) at pthread_create.c:304
#4  0x00007f099428159d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f097b2d9700 (LWP 2112)):
#0  0x00007f0994275473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f098e86cf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f098e86d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f09949efc06 in QEventDispatcherGlib::processEvents (this=0x19168e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f09949bf3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f09949bf637 in QEventLoop::exec (this=0x7f097b2d8dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f09948bf067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f09948c208b in QThreadPrivate::start (arg=0x1915e40) at thread/qthread_unix.cpp:298
#8  0x00007f098ed3eefc in start_thread (arg=0x7f097b2d9700) at pthread_create.c:304
#9  0x00007f099428159d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0923f83700 (LWP 2311)):
#0  0x00007f0994275473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f098e86cf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f098e86d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f09949efc06 in QEventDispatcherGlib::processEvents (this=0x2539b40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f09949bf3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f09949bf637 in QEventLoop::exec (this=0x7f0923f82d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f09948bf067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f099499f17f in QInotifyFileSystemWatcherEngine::run (this=0x25319c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f09948c208b in QThreadPrivate::start (arg=0x25319c0) at thread/qthread_unix.cpp:298
#9  0x00007f098ed3eefc in start_thread (arg=0x7f0923f83700) at pthread_create.c:304
#10 0x00007f099428159d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0996d3d7c0 (LWP 2101)):
[KCrash Handler]
#6  ref (this=0x31) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
#7  QList (l=..., this=0x7fff94c8b300) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#8  QNetworkCacheMetaData::rawHeaders (this=0x7fff94c8b610) at access/qabstractnetworkcache.cpp:240
#9  0x00007f098fb125ac in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x2c42680, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#10 0x00007f098fb13d04 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2c42680, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#11 0x00007f098fb9f299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2c42680, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#12 0x00007f09949d9ba6 in QObject::event (this=0x2c42680, e=<optimized out>) at kernel/qobject.cpp:1195
#13 0x00007f09953b4104 in notify_helper (e=0x7f0918e6f130, receiver=0x2c42680, this=0x176a310) at kernel/qapplication.cpp:4555
#14 QApplicationPrivate::notify_helper (this=0x176a310, receiver=0x2c42680, e=0x7f0918e6f130) at kernel/qapplication.cpp:4527
#15 0x00007f09953b8f83 in QApplication::notify (this=0x7fff94c8c090, receiver=0x2c42680, e=0x7f0918e6f130) at kernel/qapplication.cpp:4416
#16 0x00007f09960e69a6 in KApplication::notify (this=0x7fff94c8c090, receiver=0x2c42680, event=0x7f0918e6f130) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f09949c05fc in QCoreApplication::notifyInternal (this=0x7fff94c8c090, receiver=0x2c42680, event=0x7f0918e6f130) at kernel/qcoreapplication.cpp:876
#18 0x00007f09949c43ca in sendEvent (event=0x7f0918e6f130, receiver=0x2c42680) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1733380) at kernel/qcoreapplication.cpp:1500
#20 0x00007f09949ef773 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#22 0x00007f098e86ca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f098e86d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f098e86d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f09949efb9f in QEventDispatcherGlib::processEvents (this=0x1734c10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#26 0x00007f099545921e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f09949bf3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f09949bf637 in QEventLoop::exec (this=0x7fff94c8c020, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007f09949c46c7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x0000000000403629 in ?? ()
#31 0x00007f09941bf30d in __libc_start_main (main=0x402b40, argc=3, ubp_av=0x7fff94c8c6b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff94c8c6a8) at libc-start.c:226
#32 0x0000000000403b71 in _start ()

Possible duplicates by query: bug 296009, bug 295112, bug 294125, bug 292500, bug 288324.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-26 22:19:37 UTC

*** This bug has been marked as a duplicate of bug 286307 ***