Bug 299242 - Kmail crashed while opening mail after moved to different folder
Summary: Kmail crashed while opening mail after moved to different folder
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-02 15:04 UTC by util
Modified: 2012-05-02 16:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description util 2012-05-02 15:04:15 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Trying to open mail that had been automatically moved to different folder via filter.

- Custom settings of the application:
Custom filter settings to sort mail into different folders when new mail arrives.

-Note:
This problem happens several times a day but is not consistent. After Kmail crashes, it still attempts to fetch new mail in the background every X minutes.  If the new mail is to be filtered into another folder, Kmail displays one of several error messages, then loads several copies of the message into the other folder.  If the new mail stays in the main inbox, there is no error.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fedee3a67c0 (LWP 2293))]

Thread 5 (Thread 0x7fedd1f6a700 (LWP 2310)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fedeaba9dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fedeaba9f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fede6070e9a in start_thread (arg=0x7fedd1f6a700) at pthread_create.c:308
#4  0x00007fedeb8db4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fedd1669700 (LWP 2319)):
#0  0x00007fedeb8cfb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fede5ba3ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fede5ba4124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fedec050426 in QEventDispatcherGlib::processEvents (this=0x7fedcc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fedec01fc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fedec01fed7 in QEventLoop::exec (this=0x7fedd1668dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fedebf1efa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fedebf21fcb in QThreadPrivate::start (arg=0x1c915a0) at thread/qthread_unix.cpp:298
#8  0x00007fede6070e9a in start_thread (arg=0x7fedd1669700) at pthread_create.c:308
#9  0x00007fedeb8db4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fed73fff700 (LWP 2397)):
#0  0x00007fff151ff8de in ?? ()
#1  0x00007fede43d415d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fedebf78bb4 in do_gettime (frac=0x7fed73ffeb58, sec=0x7fed73ffeb50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fedec050b8d in QTimerInfoList::updateCurrentTime (this=0x7fed6c002660) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fedec050ec3 in QTimerInfoList::timerWait (this=0x7fed6c002660, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fedec04f97c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fed73ffec2c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fedec04fa25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fede5ba371e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fede5ba3f1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fede5ba4124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fedec050426 in QEventDispatcherGlib::processEvents (this=0x7fed6c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fedec01fc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fedec01fed7 in QEventLoop::exec (this=0x7fed73ffed90, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fedebf1efa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fedebfff9ff in QInotifyFileSystemWatcherEngine::run (this=0x2abc0d0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fedebf21fcb in QThreadPrivate::start (arg=0x2abc0d0) at thread/qthread_unix.cpp:298
#17 0x00007fede6070e9a in start_thread (arg=0x7fed73fff700) at pthread_create.c:308
#18 0x00007fedeb8db4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fed83724700 (LWP 3388)):
#0  0x00007fff151ff8de in ?? ()
#1  0x00007fede43d415d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fedebf78bb4 in do_gettime (frac=0x7fed83723b58, sec=0x7fed83723b50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fedec050b8d in QTimerInfoList::updateCurrentTime (this=0x7fed7c0498c0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fedec050ec3 in QTimerInfoList::timerWait (this=0x7fed7c0498c0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fedec04f97c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fed83723c2c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fedec04fa25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fede5ba371e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fede5ba3f1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fede5ba4124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fedec050426 in QEventDispatcherGlib::processEvents (this=0x7fed7c03a880, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fedec01fc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fedec01fed7 in QEventLoop::exec (this=0x7fed83723d90, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fedebf1efa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fedebfff9ff in QInotifyFileSystemWatcherEngine::run (this=0x3db0d20) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fedebf21fcb in QThreadPrivate::start (arg=0x3db0d20) at thread/qthread_unix.cpp:298
#17 0x00007fede6070e9a in start_thread (arg=0x7fed83724700) at pthread_create.c:308
#18 0x00007fedeb8db4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fedee3a67c0 (LWP 2293)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x44dd270, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fede6f46709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x44dd270, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fedec03a446 in QObject::event (this=0x44dd270, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fedeca15894 in notify_helper (e=0x7fed58025bd0, receiver=0x44dd270, this=0x1c8ec50) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1c8ec50, receiver=0x44dd270, e=0x7fed58025bd0) at kernel/qapplication.cpp:4531
#11 0x00007fedeca1a713 in QApplication::notify (this=0x7fff15062e80, receiver=0x44dd270, e=0x7fed58025bd0) at kernel/qapplication.cpp:4420
#12 0x00007feded74eb46 in KApplication::notify (this=0x7fff15062e80, receiver=0x44dd270, event=0x7fed58025bd0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007fedec020e9c in QCoreApplication::notifyInternal (this=0x7fff15062e80, receiver=0x44dd270, event=0x7fed58025bd0) at kernel/qcoreapplication.cpp:876
#14 0x00007fedec024c6a in sendEvent (event=0x7fed58025bd0, receiver=0x44dd270) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1c59380) at kernel/qcoreapplication.cpp:1500
#16 0x00007fedec04ff93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fede5ba3c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fede5ba4060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fede5ba4124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fedec0503bf in QEventDispatcherGlib::processEvents (this=0x1c5ac10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fedecabdd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fedec01fc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fedec01fed7 in QEventLoop::exec (this=0x7fff15062e10, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fedec024f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in ?? ()
#27 0x00007fedeb80a76d in __libc_start_main (main=0x402b40, argc=3, ubp_av=0x7fff150634a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff15063498) at libc-start.c:226
#28 0x0000000000403b61 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 298807, bug 298609, bug 298427, bug 298350, bug 298320.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-05-02 16:17:11 UTC

*** This bug has been marked as a duplicate of bug 286307 ***